summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/haxe/haxe-3.4.2.ebuild')
-rw-r--r--dev-lang/haxe/haxe-3.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/haxe/haxe-3.4.2.ebuild b/dev-lang/haxe/haxe-3.4.2.ebuild
new file mode 100644
index 0000000..3995786
--- /dev/null
+++ b/dev-lang/haxe/haxe-3.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3
+
+EGIT_REPO_URI="https://github.com/HaxeFoundation/${PN}"
+EGIT_COMMIT=${PV}
+SRC_URI=""
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Haxe cross-platform toolkit"
+HOMEPAGE="http://haxe.org/"
+
+LICENSE="GPL-2 LGPL-2.1 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/neko
+ >=dev-lang/ocaml-4.02[ocamlopt]
+ dev-libs/libpcre
+ dev-ml/camlp4[ocamlopt]
+ sys-libs/zlib"
+
+MAKEOPTS+=" -j1"
+
+src_install() {
+ mkdir -p "${D}/usr/bin" # Missing from install target
+ emake INSTALL_DIR="${D}/usr" install
+ # Strip destination from haxelib.
+ sed -i "s|${D}||" "${D}/usr/bin/haxelib"
+}