summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Psota <jasiupsota@gmail.com>2016-03-29 02:51:06 +0200
committerJan Psota <jasiupsota@gmail.com>2016-03-29 02:51:06 +0200
commit4817da2f35a3d4e852a411fa56408458075378df (patch)
treef2247c9af6707f17bad8aedc6c5b9826dc33b4e9
parentapp-portage/portage-utils-0.62-r1 +updated qtail and qportage (diff)
downloadbleeding-edge-4817da2f.tar.gz
bleeding-edge-4817da2f.tar.bz2
bleeding-edge-4817da2f.zip
app-portage/portage-utils-0.63-r1 + qtail, qportage
-rw-r--r--app-portage/portage-utils/Manifest2
-rw-r--r--app-portage/portage-utils/files/qlop-stdin.patch36
-rw-r--r--app-portage/portage-utils/portage-utils-0.63-r1.ebuild (renamed from app-portage/portage-utils/portage-utils-0.62-r1.ebuild)31
3 files changed, 19 insertions, 50 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index 5a693ba..234c259 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1 +1 @@
-DIST portage-utils-0.62.tar.xz 527216 SHA256 f6ce1938e41ec2073be12568470a7aae51489579add0709c08af5d9be1c0c563 SHA512 71b2888cef1bf7549c3829cc7d4bbe2e99a711434bae4fb78c55b9c37815b61623518f19ab87db30f533d771398933c085640dc7c8ffcedf87a70ac702a52fa1 WHIRLPOOL 105d60d3f778a79972e39d2d8e78aa8b971f085721362e4d594d86006752d97b25d41a1e5a9006f603cda0088da89abb179d8bc129815c1363f30dfb6ff59891
+DIST portage-utils-0.63.tar.xz 529012 SHA256 7a754cccad2d4c3331d348ba9df51bb3b9565866674303152b55248b05130a02 SHA512 2b0bceee63b894e7f517f3c938a1873aa90c41b668abbf6a39125a1bb9ce1059731e34216cc357787b5cbf83a0cf0748530147262673ea0bc26404d6274714eb WHIRLPOOL fdaec19af639c744394063dd57f7e64fb02ff10c4ee5b1ef2f49928df6d47fb5bf732e547264390787e20ca6e3251be3935e9f348f2510aa0fc6779778ca44ba
diff --git a/app-portage/portage-utils/files/qlop-stdin.patch b/app-portage/portage-utils/files/qlop-stdin.patch
index 568fa6d..8e5009f 100644
--- a/app-portage/portage-utils/files/qlop-stdin.patch
+++ b/app-portage/portage-utils/files/qlop-stdin.patch
@@ -1,7 +1,7 @@
-diff -pruN portage-utils-0.62.orig/main.c portage-utils-0.62/main.c
---- portage-utils-0.62.orig/main.c 2016-02-22 19:31:41.000000000 +0100
-+++ portage-utils-0.62/main.c 2016-02-23 23:31:36.432002795 +0100
-@@ -1402,7 +1402,8 @@ int main(int argc, char **argv)
+diff -pruN portage-utils-0.63.orig/main.c portage-utils-0.63/main.c
+--- portage-utils-0.63.orig/main.c 2016-03-28 05:53:50.000000000 +0200
++++ portage-utils-0.63/main.c 2016-03-29 02:40:11.935979233 +0200
+@@ -1422,7 +1422,8 @@ int main(int argc, char **argv)
if (fstat(fileno(stdout), &st) != -1)
if (!isatty(fileno(stdout)))
@@ -11,19 +11,19 @@ diff -pruN portage-utils-0.62.orig/main.c portage-utils-0.62/main.c
if ((getenv("TERM") == NULL) || (strcmp(getenv("TERM"), "dumb") == 0))
no_colors();
-diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
---- portage-utils-0.62.orig/qlop.c 2016-02-22 19:31:41.000000000 +0100
-+++ portage-utils-0.62/qlop.c 2016-02-23 23:39:17.758530846 +0100
-@@ -48,7 +48,7 @@ static const char * const qlop_opts_help
- "Show unmerge history",
+diff -pruN portage-utils-0.63.orig/qlop.c portage-utils-0.63/qlop.c
+--- portage-utils-0.63.orig/qlop.c 2016-03-28 05:53:50.000000000 +0200
++++ portage-utils-0.63/qlop.c 2016-03-29 02:42:29.418960636 +0200
+@@ -32,7 +32,7 @@ static const char * const qlop_opts_help
"Show sync history",
"Show current emerging packages",
+ "Limit selection to this time (1st -d is start, 2nd -d is end)",
- "Read emerge logfile instead of $EMERGE_LOG_DIR/" QLOP_DEFAULT_LOGFILE,
-+ "Read emerge logfile instead of " QLOP_DEFAULT_LOGFILE "\n\t\t\t (use \"-\" for stdin)",
++ "Read emerge logfile instead of $EMERGE_LOG_DIR/" QLOP_DEFAULT_LOGFILE "\n\t\t\t (use \"-\" for stdin)",
COMMON_OPTS_HELP
};
- #define qlop_usage(ret) usage(ret, QLOP_FLAGS, qlop_long_opts, qlop_opts_help, lookup_applet_idx("qlop"))
-@@ -56,6 +56,30 @@ static const char * const qlop_opts_help
+ static const char qlop_desc[] =
+@@ -47,6 +47,30 @@ static const char qlop_desc[] =
#define QLOP_LIST 0x01
#define QLOP_UNLIST 0x02
@@ -54,7 +54,7 @@ diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
_q_static void
print_seconds_for_earthlings(const unsigned long t)
{
-@@ -107,10 +131,7 @@ show_merge_times(char *package, const ch
+@@ -98,10 +122,7 @@ show_merge_times(char *package, const ch
pkg = package;
}
@@ -66,7 +66,7 @@ diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
while (fgets(buf[0], sizeof(buf[0]), fp) != NULL) {
if (strstr(buf[0], pkg) == NULL)
-@@ -218,7 +239,7 @@ show_merge_times(char *package, const ch
+@@ -211,7 +232,7 @@ show_merge_times(char *package, const ch
atom_implode(atom);
}
}
@@ -75,7 +75,7 @@ diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
if (count == 0)
return 0;
if (average == 1) {
-@@ -246,10 +267,7 @@ show_emerge_history(int listflag, array_
+@@ -240,10 +261,7 @@ show_emerge_history(int listflag, array_
time_t t;
depend_atom *atom, *logatom;
@@ -87,7 +87,7 @@ diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
buf = NULL;
while ((linelen = getline(&buf, &buflen, fp)) != -1) {
-@@ -309,7 +327,7 @@ show_emerge_history(int listflag, array_
+@@ -305,7 +323,7 @@ show_emerge_history(int listflag, array_
}
free(buf);
@@ -96,7 +96,7 @@ diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
}
/* The format of the sync log has changed over time.
-@@ -339,10 +357,7 @@ show_sync_history(const char *logfile)
+@@ -335,10 +353,7 @@ show_sync_history(const char *logfile, t
char *buf, *p;
time_t t;
@@ -108,7 +108,7 @@ diff -pruN portage-utils-0.62.orig/qlop.c portage-utils-0.62/qlop.c
buf = NULL;
/* Just find the finish lines. */
-@@ -375,7 +390,7 @@ show_sync_history(const char *logfile)
+@@ -373,7 +388,7 @@ show_sync_history(const char *logfile, t
}
free(buf);
diff --git a/app-portage/portage-utils/portage-utils-0.62-r1.ebuild b/app-portage/portage-utils/portage-utils-0.63-r1.ebuild
index 01af7b2..cc6e883 100644
--- a/app-portage/portage-utils/portage-utils-0.62-r1.ebuild
+++ b/app-portage/portage-utils/portage-utils-0.63-r1.ebuild
@@ -45,36 +45,5 @@ src_compile() {
src_install() {
default
-
dobin "${FILESDIR}"/{qtail,qportage}
- exeinto /etc/portage/bin
- doexe "${FILESDIR}"/post_sync
- insinto /etc/portage/postsync.d
- doins "${FILESDIR}"/q-reinitialize
-
- # Portage fixes shebangs, we just need to fix the paths in the files
- sed -i \
- -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
- "${ED}"/etc/portage/bin/post_sync \
- "${ED}"/etc/portage/postsync.d/q-reinitialize || die
-}
-
-pkg_preinst() {
- # preserve +x bit on postsync files #301721
- local x
- pushd "${ED}" >/dev/null
- for x in etc/portage/postsync.d/* ; do
- [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
- elog "If you wish for it to be automatically run at the end of every --sync:"
- elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- elog "Normally this should only take a few seconds to run but file systems"
- elog "such as ext3 can take a lot longer. To disable, simply do:"
- elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- fi
}