aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2025-01-15 14:08:02 +0000
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2025-01-15 17:06:46 +0000
commit95ac51523ba38b4d66b6ec6617355459a260c666 (patch)
treef1c4f293abc812ecb9bfd6f492d1c8360d290f45
parentnet-misc/onedrivegui: update RDEPEND (diff)
downloaddlang-master.tar.gz
dlang-master.tar.bz2
dlang-master.zip
net-misc/onedrivegui-bin: new package, add 1.0.3-r1, 1.1.1HEADmaster
* removes the need of compiling qtwebengine (bin not available on llvm profile) Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
-rw-r--r--net-misc/onedrivegui-bin/Manifest4
-rw-r--r--net-misc/onedrivegui-bin/files/OneDriveGUI.desktop7
-rw-r--r--net-misc/onedrivegui-bin/metadata.xml7
-rw-r--r--net-misc/onedrivegui-bin/onedrivegui-bin-1.0.3-r1.ebuild40
-rw-r--r--net-misc/onedrivegui-bin/onedrivegui-bin-1.1.1.ebuild41
5 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/onedrivegui-bin/Manifest b/net-misc/onedrivegui-bin/Manifest
new file mode 100644
index 0000000..1e6b480
--- /dev/null
+++ b/net-misc/onedrivegui-bin/Manifest
@@ -0,0 +1,4 @@
+DIST OneDriveGUI-1.0.3.ico 234067 BLAKE2B 072f3f1f5c3416d17f01c03b46cba76ba9038da56ada13fb3ceeafb97ee0c64819d30cbe98a939d7e64c0ec93c1e4894fd9e2b66a6adad15b2ddc010e903737d SHA512 34bcb640ddaa3ddf65c696d9ad9f62a30b65383d58ae7d2c7867c69b6bda2a3a5c3f2e72101ac47f8d37a9e4b3393a040697d9a30f71fe26c8e258829ad1524e
+DIST OneDriveGUI-1.1.1.ico 234247 BLAKE2B 339467d784baca16e234a6551e10f29f669dfe80123ed322445abda08258021aaf85fd5d553b29a3d625669c5a22b13d9fe41a2b328fcf4ea8ec189d53a5a6de SHA512 41b73f135182ad6462e2dc5d5ffab5b09c330b0bd6733644c20a1d8dea27ca6ea551d53b63c401a770ad87f3c0a57241700c8f092d84d62d9912e6bacbe17440
+DIST onedrivegui-bin-1.0.3.AppImage 74478784 BLAKE2B 2ce9d3fdf307f60decdd889584be93b4955d403e4d1f2a1789b61dac4c1d60c76e0cc79633ee839e3ebbba55c1549af603e21e6e4200fc2958e609641a5f402f SHA512 8a9bba9e344929b756bcb3627fcc0e5d35bd835ffc05c545628ba1f9c94f1f4657cda8ef93babc80f826472e73b6d0dc0b4a5ff7eba62b501c2d570f0e5b9b29
+DIST onedrivegui-bin-1.1.1.AppImage 63317184 BLAKE2B 9a20c7d1ac0ed14b0ae864053ddf523c8d5eb148d58b3c7575c411d6237a47647cadda3107c5e20a2212a5c620af251579dcf8371b1a353fbbb6ab7da4399ccc SHA512 4752bca3b3bf80122f65f84f2df3b742c368e50aad1dc181e43742de94d8b02c7280c5f464580efe0a671967cd12875a8b26a420dee244bd129bbcec1a63e5d5
diff --git a/net-misc/onedrivegui-bin/files/OneDriveGUI.desktop b/net-misc/onedrivegui-bin/files/OneDriveGUI.desktop
new file mode 100644
index 0000000..e3abd70
--- /dev/null
+++ b/net-misc/onedrivegui-bin/files/OneDriveGUI.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=OneDriveGUI
+StartupNotify=true
+Exec=/opt/bin/OneDriveGUI
+Terminal=false
+Icon=OneDriveGUI
+Type=Application \ No newline at end of file
diff --git a/net-misc/onedrivegui-bin/metadata.xml b/net-misc/onedrivegui-bin/metadata.xml
new file mode 100644
index 0000000..2b4bfb1
--- /dev/null
+++ b/net-misc/onedrivegui-bin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">bpozdena/OneDriveGUI</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/onedrivegui-bin/onedrivegui-bin-1.0.3-r1.ebuild b/net-misc/onedrivegui-bin/onedrivegui-bin-1.0.3-r1.ebuild
new file mode 100644
index 0000000..a288d89
--- /dev/null
+++ b/net-misc/onedrivegui-bin/onedrivegui-bin-1.0.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+M_PN=OneDriveGUI
+
+inherit desktop xdg-utils
+SRC_URI="
+ https://github.com/bpozdena/OneDriveGUI/releases/download/v1.0.3/OneDriveGUI-1.0.3_fix150-x86_64.AppImage -> ${PN}-${PV}.AppImage
+ https://github.com/bpozdena/OneDriveGUI/blob/v${PV}/src/resources/images/OneDriveGUI.ico -> OneDriveGUI-${PV}.ico
+"
+DESCRIPTION="A simple GUI for OneDrive Linux client, with multi-account support."
+HOMEPAGE="https://github.com/bpozdena/OneDriveGUI"
+
+RDEPEND="
+ <=net-misc/onedrive-2.5.3
+ sys-fs/fuse:0
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="strip"
+
+S="${WORKDIR}"
+
+src_install() {
+ #Install binary and alias command
+ insinto /opt/bin/ && newins "${DISTDIR}/${PN}-${PV}.AppImage" "OneDriveGUI"
+ fperms +x /opt/bin/OneDriveGUI
+
+ #Icon and Desktop File
+ newicon "${DISTDIR}/OneDriveGUI-${PV}.ico" -> "OneDriveGUI.ico"
+ domenu "${FILESDIR}/OneDriveGUI.desktop"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
diff --git a/net-misc/onedrivegui-bin/onedrivegui-bin-1.1.1.ebuild b/net-misc/onedrivegui-bin/onedrivegui-bin-1.1.1.ebuild
new file mode 100644
index 0000000..930bceb
--- /dev/null
+++ b/net-misc/onedrivegui-bin/onedrivegui-bin-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+M_PN=OneDriveGUI
+
+inherit desktop xdg-utils
+SRC_URI="
+ https://github.com/bpozdena/OneDriveGUI/releases/download/v1.1.1a/OneDriveGUI-1.1.1-x86_64.AppImage -> ${PN}-${PV}.AppImage
+ https://github.com/bpozdena/OneDriveGUI/blob/v${PV}a/src/resources/images/OneDriveGUI.ico -> OneDriveGUI-${PV}.ico
+"
+DESCRIPTION="A simple GUI for OneDrive Linux client, with multi-account support."
+HOMEPAGE="https://github.com/bpozdena/OneDriveGUI"
+
+RDEPEND="
+ >=net-misc/onedrive-2.5.3
+ sys-fs/fuse:0
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+RESTRICT="strip"
+
+S="${WORKDIR}"
+QA_PREBUILT=".*"
+
+src_install() {
+ #Install binary and alias command
+ insinto /opt/bin/ && newins "${DISTDIR}/${PN}-${PV}.AppImage" "OneDriveGUI"
+ fperms +x /opt/bin/OneDriveGUI
+
+ #Icon and Desktop File
+ newicon "${DISTDIR}/OneDriveGUI-${PV}.ico" -> "OneDriveGUI.ico"
+ domenu "${FILESDIR}/OneDriveGUI.desktop"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}