aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-01-08 17:48:31 -0500
committerJoe Kappus <joe@wt.gd>2023-01-08 17:48:31 -0500
commit213b3eff71c67f8f5d0b7a7ac05d6f91ea5a9fba (patch)
tree5d169bf92af547a05d840285f21150d34b2c93fd
parentnet-misc/onedrive: add 2.4.22 (diff)
downloaddlang-213b3eff71c67f8f5d0b7a7ac05d6f91ea5a9fba.tar.gz
dlang-213b3eff71c67f8f5d0b7a7ac05d6f91ea5a9fba.tar.bz2
dlang-213b3eff71c67f8f5d0b7a7ac05d6f91ea5a9fba.zip
net-misc/onedrive: add 2.4.23
Signed-off-by: Joe Kappus <joe@wt.gd>
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.4.23.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index 47fbbaa..71e762b 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -2,3 +2,4 @@ DIST onedrive-2.4.19.tar.gz 1145669 BLAKE2B ab2537089be2da474fcdff23c9e12c002136
DIST onedrive-2.4.20.tar.gz 1147454 BLAKE2B 397fb17d6b0f71ad20a91ca7e8d75a0cbd0c91562d25f24961b48d7c6704af0931d2a9a3bd2bce7a4c3d6a4560b198f7d8acd45da09b2fda499c50106a967e46 SHA512 c70f0ad8943582eeee98bc6612d94c1b4d53992da78e8e578ba24f9dbb422f37527decfac02e0745f853b32f5546debc30dc27bec30cc7cf9587204e0189e11f
DIST onedrive-2.4.21.tar.gz 1223054 BLAKE2B ecb424c303ec1e47ea49f3429c6db5436573df537ae4f75468a80385f4dc43d56a99253baa8b1b537450836326c78609ccd924ed7ae0cc0599e4e90561394801 SHA512 e1f74d68e82dd65027642b0585e5379a41c7d900fdad3015cd55d4e161bdd3ed5580f1a3a0bd3ea69faa34c417d17ab13774bec58c3497368eeae9017dd46ecd
DIST onedrive-2.4.22.tar.gz 1232399 BLAKE2B bf17688ab1c86422c7e32c5229451a44db9d2d28a75f3f40fbbfcad87375b044b3062c933ddfea8ded756b575dae679bdd3c7fc1e198de945cb9c7d31dae06ac SHA512 865ccbb4ff8c8253a0e4028f7488d5e3cb92a7cb915d753e1a3be946d8dc223f8d96497ddb71ead7de6d3e1cd1a0f5e17b53958ee26d2b647f14163da3fbda42
+DIST onedrive-2.4.23.tar.gz 1233921 BLAKE2B acf12b29101732dbb392d8a440cc08a7a321e4a7452d485366141b10623167be6f06d07d8840a728f8fbef1c09a7e42e30226a5600f42ac276fa001b51c4c261 SHA512 7117e23ee6e6e8499664aef899f37a3efbace57491f1756574c76fd0bfe6ddb76cf95b3001c717609cab7a6d7591d4347a24bc55437423b035b6e39fca4a7d3d
diff --git a/net-misc/onedrive/onedrive-2.4.23.ebuild b/net-misc/onedrive/onedrive-2.4.23.ebuild
new file mode 100644
index 0000000..eff9231
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.4.23.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://abraunegg.github.io/"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.087-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-fish-completion-dir=/usr/share/fish/completions \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "When upgrading from 2.3 you are required to reauthorise your client."
+ ewarn "This is due to changing the client identifier to assist with resolving"
+ ewarn "the correct handling of 429 error responses (activityLimitReached)"
+}