aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-11-03 01:22:03 +0100
committerMarco Leise <marco.leise@gmx.de>2019-11-17 16:36:41 +0100
commit7b07c6a1dd5e165595858a9a7224ec80b611c339 (patch)
tree6021231d0f036ae42ef149d6b6f95daf31192aca
parentdmd-2.088.1 (diff)
downloaddlang-7b07c6a1.tar.gz
dlang-7b07c6a1.tar.bz2
dlang-7b07c6a1.zip
stabilization sweep
Signed-off-by: Marco Leise <marco.leise@gmx.de>
-rw-r--r--dev-lang/ldc2/ldc2-1.17.0.ebuild2
-rw-r--r--dev-util/dub/Manifest1
-rw-r--r--dev-util/dub/dub-1.16.0.ebuild39
-rw-r--r--dev-util/dub/dub-1.17.0.ebuild2
-rw-r--r--dev-util/dub/files/dub-1.16.0-gdc-dmd-pathfix.patch16
-rw-r--r--eclass/dlang-compilers.eclass1
-rw-r--r--profiles/use.desc1
7 files changed, 4 insertions, 58 deletions
diff --git a/dev-lang/ldc2/ldc2-1.17.0.ebuild b/dev-lang/ldc2/ldc2-1.17.0.ebuild
index d01e602..f526ac8 100644
--- a/dev-lang/ldc2/ldc2-1.17.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.17.0.ebuild
@@ -12,7 +12,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="LLVM D Compiler"
HOMEPAGE="https://ldc-developers.github.com/ldc"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="BSD"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
diff --git a/dev-util/dub/Manifest b/dev-util/dub/Manifest
index df15b75..aefe6c2 100644
--- a/dev-util/dub/Manifest
+++ b/dev-util/dub/Manifest
@@ -1,2 +1 @@
-DIST dub-1.16.0.tar.gz 1280193 BLAKE2B c569e2b189609d64801478f219139463552717b82d12b69792f0488ed52ffaefbe3b9ccfcec56c8324e03851a92b0a33f55730b759e56ecd8c322155980185c0 SHA512 e088fcdb0930439606c7575183d96cc4d743109d0d513f3606ae1ac1df41d4862aff8bfd36be90228aed4c4fc2f46528cb7a650ec6f988f146b051a10ccce177
DIST dub-1.17.0.tar.gz 1280689 BLAKE2B b7236bce2e2cc1218a8043ae95087876e6fa67e696e3320c2ba089451870eccc3f7d7aafb89d7ec192fad4bc5de89eab15f79c1e128ca7c12c1c906b4151ba1c SHA512 8907e7b66d5a5c3d6013a2073a61cdab2a9276454b9c63628b30bb787cee2a7f785bf5ee1db781bf241fe4196a792f74682872ad55bb42349ae5452ce0ffec92
diff --git a/dev-util/dub/dub-1.16.0.ebuild b/dev-util/dub/dub-1.16.0.ebuild
deleted file mode 100644
index 757e33a..0000000
--- a/dev-util/dub/dub-1.16.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Package and build management system for D"
-HOMEPAGE="http://code.dlang.org/"
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="debug"
-
-GITHUB_URI="https://codeload.github.com/dlang"
-SRC_URI="${GITHUB_URI}/${PN}/tar.gz/v${PV} -> ${PN}-${PV}.tar.gz"
-PATCHES="${FILESDIR}/${P}-gdc-dmd-pathfix.patch"
-
-DLANG_VERSION_RANGE="2.076-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-DEPEND="net-misc/curl"
-RDEPEND="${DEPEND}"
-
-d_src_compile() {
- local imports=source versions="DubApplication DubUseCurl" libs="curl z"
- dlang_compile_bin bin/dub $(<build-files.txt)
-}
-
-d_src_test() {
- echo "Test phase disabled due to multiple problems."
- #DUB="${S}/bin/dub" test/run-unittest.sh || die "Test phase failed"
-}
-
-d_src_install() {
- dobin bin/dub
- dodoc README.md
-}
diff --git a/dev-util/dub/dub-1.17.0.ebuild b/dev-util/dub/dub-1.17.0.ebuild
index 237a2db..757e33a 100644
--- a/dev-util/dub/dub-1.17.0.ebuild
+++ b/dev-util/dub/dub-1.17.0.ebuild
@@ -8,7 +8,7 @@ HOMEPAGE="http://code.dlang.org/"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm x86"
IUSE="debug"
GITHUB_URI="https://codeload.github.com/dlang"
diff --git a/dev-util/dub/files/dub-1.16.0-gdc-dmd-pathfix.patch b/dev-util/dub/files/dub-1.16.0-gdc-dmd-pathfix.patch
deleted file mode 100644
index 497ef50..0000000
--- a/dev-util/dub/files/dub-1.16.0-gdc-dmd-pathfix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/source/dub/generators/build.d b/source/dub/generators/build.d
---- a/source/dub/generators/build.d
-+++ b/source/dub/generators/build.d
-@@ -119,10 +119,10 @@ class BuildGenerator : ProjectGenerator {
- auto build_id = computeBuildID(config, buildsettings, settings);
-
- // make all paths relative to shrink the command line
-- string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
-+ /+string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
- foreach (ref f; buildsettings.sourceFiles) f = makeRelative(f);
- foreach (ref p; buildsettings.importPaths) p = makeRelative(p);
-- foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);
-+ foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);+/
-
- // perform the actual build
- bool cached = false;
diff --git a/eclass/dlang-compilers.eclass b/eclass/dlang-compilers.eclass
index 443c767..318cb91 100644
--- a/eclass/dlang-compilers.eclass
+++ b/eclass/dlang-compilers.eclass
@@ -58,6 +58,7 @@ dlang-compilers_declare_versions() {
["1.14"]="2.084 amd64 ~arm ~arm64 ~ppc64 x86"
["1.15"]="2.085 amd64 ~arm ~arm64 ~ppc64 x86"
["1.16"]="2.086 amd64 ~arm ~arm64 ~ppc64 x86"
+ ["1.17"]="2.087 amd64 ~arm ~arm64 ~ppc64 x86"
)
}
diff --git a/profiles/use.desc b/profiles/use.desc
index da00b6f..6f0ec5b 100644
--- a/profiles/use.desc
+++ b/profiles/use.desc
@@ -34,3 +34,4 @@ ldc2-1_13 - Build for ldc2 1.13
ldc2-1_14 - Build for ldc2 1.14
ldc2-1_15 - Build for ldc2 1.15
ldc2-1_16 - Build for ldc2 1.16
+ldc2-1_17 - Build for ldc2 1.17