aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@proton.me>2024-01-24 20:21:55 +0200
committerHorodniceanu Andrei <a.horodniceanu@proton.me>2024-01-24 20:38:46 +0200
commitce1aa5d8fdb60dcd1c08cc1d35cf77fc2998959b (patch)
tree4915b4dc9606a937a91a01f5fa79a42416b91077
parentdev-util/dub: keyword 1.35.1-r1 for ~arm64 (diff)
downloaddlang-ce1aa5d8fdb60dcd1c08cc1d35cf77fc2998959b.tar.gz
dlang-ce1aa5d8fdb60dcd1c08cc1d35cf77fc2998959b.tar.bz2
dlang-ce1aa5d8fdb60dcd1c08cc1d35cf77fc2998959b.zip
dev-lang/ldc2: pass -fno-strict-aliasing
Bug: https://bugs.gentoo.org/show_bug.cgi?id=922590 Signed-off-by: Horodniceanu Andrei <a.horodniceanu@proton.me>
-rw-r--r--dev-lang/ldc2/ldc2-1.36.0-r1.ebuild (renamed from dev-lang/ldc2/ldc2-1.36.0.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/ldc2/ldc2-1.36.0.ebuild b/dev-lang/ldc2/ldc2-1.36.0-r1.ebuild
index f6837c0..bc995b9 100644
--- a/dev-lang/ldc2/ldc2-1.36.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.36.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit multilib-build cmake llvm
+inherit flag-o-matic multilib-build cmake llvm
MY_PV="${PV//_/-}"
MY_P="ldc-${MY_PV}-src"
@@ -18,7 +18,7 @@ SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
IUSE="static-libs"
-# Upstream supports LLVM 11.0 through 16.0.
+# Upstream supports LLVM 11.0 through 17.0.
DEPEND="
|| (
sys-devel/llvm:17
@@ -53,6 +53,8 @@ d_src_configure() {
# We disable assertions so we have to apply the same workaround as for
# sys-devel/llvm: add -DNDEBUG to CPPFLAGS.
local CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+ # https://bugs.gentoo.org/show_bug.cgi?id=922590
+ append-flags -fno-strict-aliasing
local mycmakeargs=(
-DD_VERSION=2
-DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)