aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-05-30 18:39:08 +0200
committerMarco Leise <marco.leise@gmx.de>2020-05-30 18:39:08 +0200
commitd8629dcc474754c43359a472d114ded7f4229d6f (patch)
tree4f08d1ba3d58ad4d9ba5d97119fe0abca2eaf94f
parentonedrive-2.4.2 (diff)
downloaddlang-d8629dcc474754c43359a472d114ded7f4229d6f.tar.gz
dlang-d8629dcc474754c43359a472d114ded7f4229d6f.tar.bz2
dlang-d8629dcc474754c43359a472d114ded7f4229d6f.zip
dmd-2.092.0 & dub-1.21.0
Signed-off-by: Marco Leise <marco.leise@gmx.de>
-rw-r--r--dev-lang/dmd/Manifest1
-rw-r--r--dev-lang/dmd/dmd-2.092.0.ebuild20
-rw-r--r--dev-util/dlang-tools/Manifest1
-rw-r--r--dev-util/dlang-tools/dlang-tools-2.092.0.ebuild54
-rw-r--r--dev-util/dub/Manifest1
-rw-r--r--dev-util/dub/dub-1.21.0.ebuild39
-rw-r--r--dev-util/dub/files/dub-1.21.0-gdc-dmd-pathfix.patch16
-rw-r--r--eclass/dmd.eclass2
8 files changed, 133 insertions, 1 deletions
diff --git a/dev-lang/dmd/Manifest b/dev-lang/dmd/Manifest
index 145b43c..d07522e 100644
--- a/dev-lang/dmd/Manifest
+++ b/dev-lang/dmd/Manifest
@@ -27,3 +27,4 @@ DIST dmd.2.088.1.linux.tar.xz 25122116 BLAKE2B e573a97cf9f547a3017a0b904523f4877
DIST dmd.2.089.1.linux.tar.xz 25877024 BLAKE2B 38fdbac595a6d9ea7548ee331aacefec530594be750a1b3dbfad7af8a5e310d6fb5e774106adfaa0d0c33cfec8e94c7a29f4c3c5c3088cc827f6ccd8a3472e56 SHA512 8a5343060d7f28394be81d8732997d96a23522c87912f2c8d0979375297467068d093ab4ef2b92b0ce8be941b5c65061660eef8d1e9252c626197014ac4331a9
DIST dmd.2.090.1.linux.tar.xz 25595804 BLAKE2B addd21fc482aa90d816593312aa6490949e54c3f8f36989eec193e9b09412022afe5d1f7006153f9b258a2c96fed9266ef5a9a94ca9c999cbc3ec1230937dec8 SHA512 ebc769d9c4c784b7e59730606e57bbde8dbfaea07be2492a0e475e0818f0ef4aaf3cb2bc8b1be066cc14479d9a3dd0d9655e0b0025c79383dbbbe9b2f2caf04f
DIST dmd.2.091.1.linux.tar.xz 23977732 BLAKE2B 4db4c1733ecfdaa79a396039b8be735c217841deefd41b91b72a25e075e0f064892aa07497d840ef738021f66b58071d3d8c228573110614c43036ad51d7f701 SHA512 94db61b8cabd6229b404ce34e1618a710d6780bd7ce6db4ac666221b9bef616046ab9e4e793651e4e976fb4dd0eeedd5445abc9169ca27be753ff5611001e6bb
+DIST dmd.2.092.0.linux.tar.xz 24272644 BLAKE2B 417d406b071b8ea35ace5a8da303ba4c9e239bd5aae038ac45797383f54df460d3c169f451ea9bd4bde224e33fd1932412b341c057177f39550dab2c575066b1 SHA512 d385f06949a545e35cd93ef4a06ae613648dba641c19cdb66d7650730c8192ef80e4fb0d902e7f948629cc151b3fc940d1a4453056a0b70f901afd1c6de49026
diff --git a/dev-lang/dmd/dmd-2.092.0.ebuild b/dev-lang/dmd/dmd-2.092.0.ebuild
new file mode 100644
index 0000000..6b582a8
--- /dev/null
+++ b/dev-lang/dmd/dmd-2.092.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="-* ~amd64 ~x86"
+YEAR=2020
+DLANG_VERSION_RANGE="2.076-"
+
+inherit dmd
+
+PATCHES=(
+ "${FILESDIR}/2.083-link-32-bit-shared-lib-with-ld.bfd.patch"
+)
+
+dmd_src_prepare_extra() {
+ # Copy default DDOC theme file into resource directory
+ mkdir "dmd/res" || die "Failed to create 'dmd/res' directory"
+ cp "${FILESDIR}/2.086-default_ddoc_theme.ddoc" "dmd/res/default_ddoc_theme.ddoc" || die "Failed to copy 'default_ddoc_theme.ddoc' file into 'src/res' directory."
+}
diff --git a/dev-util/dlang-tools/Manifest b/dev-util/dlang-tools/Manifest
index 8d581ee..3c090fb 100644
--- a/dev-util/dlang-tools/Manifest
+++ b/dev-util/dlang-tools/Manifest
@@ -26,6 +26,7 @@ DIST dlang-tools-2.088.1.tar.gz 117104 BLAKE2B 2920cb8950fb0e921665bab161584c35a
DIST dlang-tools-2.089.1.tar.gz 117693 BLAKE2B 6e499fd01bda7a58036b08f30319549ca2c786ea348ac93d045019fde745a3b30179af0d7c3999af8bd09f15d86876e43927cf069a70dc5120ebc08eb82a84c3 SHA512 ffc1eb9d42f167d2a519a052fdc87fb3db576d9b549dac80c993859f597dfbc492e783129b9c94dc664e33817bacf09b040d0cb2efbc679971ba768163eb4e42
DIST dlang-tools-2.090.1.tar.gz 117709 BLAKE2B 8a714a5bd6860bf4a856fbbde2a7188b404b819e11f9ed815688b9acb5fa6e95a95c0fb4aa407495da89a0e3b19dba584be1d90f3c60c2af95090d6e81f221d6 SHA512 82f6d3fd4a7f6fd013425894ec5f817c960764479649c97139a019802fc5c2a83671102f1b2a9427e88446055e5a1a4fa884a4b86400a84107b2d5ca322b7a32
DIST dlang-tools-2.091.1.tar.gz 117714 BLAKE2B bd0957f0e70401b1ededf29be7f942da1445c66e3ea4b47f31b136413b506c3dd03faa4cb1962a10ae51edd0cb18b282da072b0ba63f0f0d7e2cd3e460924e3a SHA512 b8fb4f4c1e9aed1e2134644152a32a7c6073d801458bf0a45a23e86cd761a19c4b517365112edc7af73fbef3c26b4106fa0ee7478a78fa41c531a060c25e3955
+DIST dlang-tools-2.092.0.tar.gz 119007 BLAKE2B fbcd288973eb12a8f551fb27dc9c567d7a30895bf82c871ad96f47eb0691ec3fef697086ee0c3d202d668707c06716185d859325dae6214a083740bde09f57b1 SHA512 3d3b0f0cc02297119773f54576d350e9124166fad8ed31c6a08eeb1018e1095cebde1ae5056d8d68a6272297cc7ee35d487f4de152536935bac9ca175ffb9e0e
DIST dlang.org-2.064.2.tar.gz 963131 BLAKE2B a7cf0d43a1cd531722bda717882a34e01c0186f0832a12064bf0600aede0a0913190724011f0b13c76cf794434e1c82490f48e9fda66409aa2820adc7c8a40f9 SHA512 a1284955764385539dcd8949cd851100af9be47908e85d8cfd897d6409903763919dc082fc0ca88fbaaf49647168357656aee82717a375ed45407eb15ccd44cf
DIST dlang.org-2.065.0.tar.gz 1005429 BLAKE2B 01fc8ec0c5148f910e2923be556208c08a18f00453ffa1f1a22d6725db6489b6f9022cd170caa3a05078baddde353ee819984da5efa53547e78006d2f0a97b9c SHA512 0fb185603766b54c3b9dc57824b18ec7ea9f37281610729860543630f4546591f9523bff48eee5414235d2ee656201c444e6d2efc44ba66a052b98a0d9b4729e
DIST dlang.org-2.066.1.tar.gz 1024075 BLAKE2B cfdb4922c38d9f0ced941eeb4578d71f09d65201d2f89cfc73e46ae73f0939c74fa92d7f003b87a28f814c5b2cc0dda6855b86e64fd86be3920c129f8c20df6a SHA512 d3838cc2ab6236d57c17f92fa5eaef8458176715985aecbea9653cc772725e1b9f813c9ffc8e06490e08c1031826ab84d1fcfbd88008791cac3257db814e3dc8
diff --git a/dev-util/dlang-tools/dlang-tools-2.092.0.ebuild b/dev-util/dlang-tools/dlang-tools-2.092.0.ebuild
new file mode 100644
index 0000000..6b8a8e1
--- /dev/null
+++ b/dev-util/dlang-tools/dlang-tools-2.092.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Ancilliary tools for the D programming language compiler"
+HOMEPAGE="http://dlang.org/"
+LICENSE="Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+TOOLS="ddemangle detab dustmite rdmd"
+IUSE="+ddemangle detab dustmite +rdmd"
+REQUIRED_USE="|| ( ${TOOLS} )"
+
+inherit eapi7-ver
+
+DLANG_SLOT="$(ver_cut 1-2)"
+RESTRICT="mirror"
+
+BETA="$(ver_cut 4)"
+VERSION="$(ver_cut 1-3)"
+
+if [[ -n "${BETA}" ]]; then
+ VERSION="${VERSION}-b${BETA:4}"
+fi
+SRC_URI="https://codeload.github.com/dlang/tools/tar.gz/v${VERSION} -> dlang-tools-${VERSION}.tar.gz"
+
+DLANG_VERSION_RANGE="2.076-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit eutils dlang
+
+S="${WORKDIR}/tools-${VERSION}"
+
+d_src_compile() {
+ use ddemangle && dlang_compile_bin ddemangle ddemangle.d
+ use detab && dlang_compile_bin detab detab.d
+ use dustmite && dlang_compile_bin dustmite DustMite/dustmite.d DustMite/splitter.d
+ use rdmd && dlang_compile_bin rdmd rdmd.d
+}
+
+d_src_install() {
+ for tool in ${TOOLS}; do
+ if use "${tool}"; then
+ dobin "${tool}"
+ fi
+ done
+
+ # file icons
+ for size in 16 22 24 32 48 256; do
+ newicon --size "${size}" --context mimetypes "${FILESDIR}/icons/${size}/dmd-source.png" text-x-dsrc.png
+ done
+}
diff --git a/dev-util/dub/Manifest b/dev-util/dub/Manifest
index 9544359..23d30bd 100644
--- a/dev-util/dub/Manifest
+++ b/dev-util/dub/Manifest
@@ -1,2 +1,3 @@
DIST dub-1.20.0.tar.gz 1270037 BLAKE2B 33da3da316c2fc2b51b3d0febfd47c7f48e866195b47c6acbe621f46898f72961f78ec4b3cc61d0274f29b51378da77f2e0278b40ddaa8bca2296c4c8df7c6a8 SHA512 4ad750ab8b968005d1510f1ab6125d8167c67e1d2374b0f7df4d3624139430fedfa45d88b0ded64577981e0ffd863554eb4ee2b736eb22354d5ace4b0da589a8
DIST dub-1.20.1.tar.gz 1269733 BLAKE2B 15f0e3042249687eb35d9e54b97bb22ba9db4184f54fd5154849aff952d667cd38cbb15a9d349573bd984fd1b30459c22003fab7d647961355c30498fa0b2203 SHA512 9509c5272f72811ddedb840379dc474abc2328b1863464dcc1cba1c4a017f7409c206d38366e68c5e37c602a380c50189d5fe300664015d16e3629aa57e48afb
+DIST dub-1.21.0.tar.gz 1272369 BLAKE2B afcc92d9c7a9c49497259011d9c70aaeb559c0835d45d7e90c54c2e2361ec3c9ec69928e16c06ace0bb6c03f9e66ecad6717a64df5f83e41d671763296540339 SHA512 d85be6e35f51e34d34afce71fe902b8ef623c6f49ed6f5f755dded5bceda49416f9d625377136b928d0f95496e57999f0dd57a4cea796360edd34c72556debd7
diff --git a/dev-util/dub/dub-1.21.0.ebuild b/dev-util/dub/dub-1.21.0.ebuild
new file mode 100644
index 0000000..23205f6
--- /dev/null
+++ b/dev-util/dub/dub-1.21.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Package and build management system for D"
+HOMEPAGE="http://code.dlang.org/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+GITHUB_URI="https://codeload.github.com/dlang"
+SRC_URI="${GITHUB_URI}/${PN}/tar.gz/v${PV} -> ${PN}-${PV}.tar.gz"
+PATCHES="${FILESDIR}/${P}-gdc-dmd-pathfix.patch"
+
+DLANG_VERSION_RANGE="2.076-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang
+
+DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
+
+d_src_compile() {
+ local imports=source versions="DubApplication DubUseCurl" libs="curl z"
+ dlang_compile_bin bin/dub $(<build-files.txt)
+}
+
+d_src_test() {
+ echo "Test phase disabled due to multiple problems."
+ #DUB="${S}/bin/dub" test/run-unittest.sh || die "Test phase failed"
+}
+
+d_src_install() {
+ dobin bin/dub
+ dodoc README.md
+}
diff --git a/dev-util/dub/files/dub-1.21.0-gdc-dmd-pathfix.patch b/dev-util/dub/files/dub-1.21.0-gdc-dmd-pathfix.patch
new file mode 100644
index 0000000..497ef50
--- /dev/null
+++ b/dev-util/dub/files/dub-1.21.0-gdc-dmd-pathfix.patch
@@ -0,0 +1,16 @@
+diff --git a/source/dub/generators/build.d b/source/dub/generators/build.d
+--- a/source/dub/generators/build.d
++++ b/source/dub/generators/build.d
+@@ -119,10 +119,10 @@ class BuildGenerator : ProjectGenerator {
+ auto build_id = computeBuildID(config, buildsettings, settings);
+
+ // make all paths relative to shrink the command line
+- string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
++ /+string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
+ foreach (ref f; buildsettings.sourceFiles) f = makeRelative(f);
+ foreach (ref p; buildsettings.importPaths) p = makeRelative(p);
+- foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);
++ foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);+/
+
+ // perform the actual build
+ bool cached = false;
diff --git a/eclass/dmd.eclass b/eclass/dmd.eclass
index c77ece4..5e346d6 100644
--- a/eclass/dmd.eclass
+++ b/eclass/dmd.eclass
@@ -130,7 +130,7 @@ dmd_src_compile() {
dmd_ge 2.071 && HOST_CXX="HOST_CXX" || HOST_CXX="HOST_CC"
# 2.072 and 2.073 have support for LTO, but would need a Makefile patch.
# From 2.088 on, the build fails with it active.
- dmd_ge 2.074 && ! dmd_eq 2.088 && ! dmd_eq 2.089 && ! dmd_eq 2.090 && ! dmd_eq 2.091 && LTO="ENABLE_LTO=1"
+ dmd_ge 2.074 && ! dmd_eq 2.088 && ! dmd_eq 2.089 && ! dmd_eq 2.090 && ! dmd_eq 2.091 && ! dmd_eq 2.092 && LTO="ENABLE_LTO=1"
# 2.080 and below used RELEASE instead of ENABLE_RELEASE
dmd_ge 2.081 && ENABLE_RELEASE="ENABLE_RELEASE" || ENABLE_RELEASE="RELEASE"