aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-04-18 15:47:44 +0200
committerMarco Leise <marco.leise@gmx.de>2020-04-18 15:47:44 +0200
commit540f58dde0d602ede24ceb2f59f76d7a78af2723 (patch)
tree027e0390cc6c5bdf984902172ba3df2445af009d /net-misc/onedrive
parentdscanner-0.9.0 (diff)
downloaddlang-540f58dde0d602ede24ceb2f59f76d7a78af2723.tar.gz
dlang-540f58dde0d602ede24ceb2f59f76d7a78af2723.tar.bz2
dlang-540f58dde0d602ede24ceb2f59f76d7a78af2723.zip
onedrive-2.4.0
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'net-misc/onedrive')
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.4.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index a2b4d19..752401e 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1 +1,2 @@
DIST onedrive-2.3.13.tar.gz 662746 BLAKE2B c49b5a27bb1d9288c0e56fa639470ba92a04d69a2ee3d8a7765dc9f68269ccd597c10db0b00ec51ca694ce9026c80f1a247e81afb44d4a4ae03fa99b6abbc433 SHA512 fe5ec03b9f80bffb96e69599184aba2c285fec02f3fb5480796f78b170a6763ae93d613b10a007391a9ad5c4ec5215caa7f3b3b48d76a9493a84dcd3b9a6889d
+DIST onedrive-2.4.0.tar.gz 670382 BLAKE2B 1b6adfe6c1eecb3a32461a2a12c1bcae4db534b6fa73bddda2787317dd9285c17081fdeb783c1362e055eaed4ebbe2f2aec5f5bdc80640e9d90e4fd73fa525c8 SHA512 57c57c716b95ab2d517f73a849938dfa49a167d548050eefd4729a5c2ff128072dcc5ca0633eb6eb7722d45533e767dd03b5c7ea529652d36b087d4ab57a542c
diff --git a/net-misc/onedrive/onedrive-2.4.0.ebuild b/net-misc/onedrive/onedrive-2.4.0.ebuild
new file mode 100644
index 0000000..29affec
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://github.com/abraunegg/onedrive"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.082-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "This release will require you to reauthorise your client. This is due to"
+ ewarn "changing the client identifier to assist with resolving the correct handling"
+ ewarn "of 429 error responses (activityLimitReached)"
+}