aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-11-16 03:22:44 +0100
committerMarco Leise <marco.leise@gmx.de>2020-11-16 05:03:53 +0100
commit85dff06053c078bb34d8a7a55bae8b16255275ee (patch)
treee32e378ca51590f7a6e16922bcfecfaa02553de4 /net-misc/onedrive
parentdscanner-0.11.0 (diff)
downloaddlang-85dff06053c078bb34d8a7a55bae8b16255275ee.tar.gz
dlang-85dff06053c078bb34d8a7a55bae8b16255275ee.tar.bz2
dlang-85dff06053c078bb34d8a7a55bae8b16255275ee.zip
onedrive-2.4.7
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'net-misc/onedrive')
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.4.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index 214e973..f922bae 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1 +1,2 @@
DIST onedrive-2.4.5.tar.gz 965217 BLAKE2B 7c0b8476c862ba2950292e0e4e29b0884f6448d09ec29bd9e14fb33f15a9ad8fbe7a47f37f0a4332a744f000957fecaf2a26ec6c35a37b5cab808c58decfac29 SHA512 5f8d0aea962034c50e920b3cb759bff2e6223a581e63562ab77a9cf364bdca890a62b757a3b4c8046864605edec3abea7e52e877ab384d3c9904f8b83bccf3c3
+DIST onedrive-2.4.7.tar.gz 974339 BLAKE2B 6a45831068414fdbcfe0e8f0012f2c05bda0fd2882292fd984e3fb88dbf5fcf2ade78b1f277a6485d8b634e35d992f51049c5c4cd577909a699c8fc490d303bf SHA512 dde102ec985bbc4b1b6a0b0c1313b257e6561f15e736716f33502fd78c27747fbdc8ec8968717c3cbd4c46e21c014587a92e3e460d2ea78201f6664387b8a131
diff --git a/net-misc/onedrive/onedrive-2.4.7.ebuild b/net-misc/onedrive/onedrive-2.4.7.ebuild
new file mode 100644
index 0000000..e2c8738
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.4.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://abraunegg.github.io/"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.082-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-fish-completion-dir=/usr/share/fish/completions \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "When upgrading from 2.3 you are required you to reauthorise your client."
+ ewarn "This is due to changing the client identifier to assist with resolving"
+ ewarn "the correct handling of 429 error responses (activityLimitReached)"
+}