aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/dmd/dmd-2.090.0.ebuild')
-rw-r--r--dev-lang/dmd/dmd-2.090.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-lang/dmd/dmd-2.090.0.ebuild b/dev-lang/dmd/dmd-2.090.0.ebuild
new file mode 100644
index 0000000..6b582a8
--- /dev/null
+++ b/dev-lang/dmd/dmd-2.090.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="-* ~amd64 ~x86"
+YEAR=2020
+DLANG_VERSION_RANGE="2.076-"
+
+inherit dmd
+
+PATCHES=(
+ "${FILESDIR}/2.083-link-32-bit-shared-lib-with-ld.bfd.patch"
+)
+
+dmd_src_prepare_extra() {
+ # Copy default DDOC theme file into resource directory
+ mkdir "dmd/res" || die "Failed to create 'dmd/res' directory"
+ cp "${FILESDIR}/2.086-default_ddoc_theme.ddoc" "dmd/res/default_ddoc_theme.ddoc" || die "Failed to copy 'default_ddoc_theme.ddoc' file into 'src/res' directory."
+}