aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/dlang-tools/dlang-tools-2.072.2.ebuild')
-rw-r--r--dev-util/dlang-tools/dlang-tools-2.072.2.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/dlang-tools/dlang-tools-2.072.2.ebuild b/dev-util/dlang-tools/dlang-tools-2.072.2.ebuild
deleted file mode 100644
index 1b61994..0000000
--- a/dev-util/dlang-tools/dlang-tools-2.072.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Ancilliary tools for the D programming language compiler"
-HOMEPAGE="http://dlang.org/"
-LICENSE="Boost-1.0"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-TOOLS="ddemangle detab dustmite rdmd"
-IUSE="+ddemangle detab dustmite +rdmd"
-REQUIRED_USE="|| ( ${TOOLS} )"
-
-DLANG_SLOT="$(ver_cut 1-2)"
-RESTRICT="mirror"
-
-BETA="$(ver_cut 4)"
-VERSION="$(ver_cut 1-3)"
-
-if [[ -n "${BETA}" ]]; then
- # We want to convert a Gentoo version string into an upstream one: 2.097.0_rc1 -> 2.097.0-rc.1
- VERSION="$(ver_rs 3 "-" 4 ".")"
-fi
-SRC_URI="https://codeload.github.com/dlang/tools/tar.gz/v${VERSION} -> dlang-tools-${VERSION}.tar.gz"
-
-DLANG_VERSION_RANGE="${DLANG_SLOT}-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit desktop dlang xdg-utils
-
-S="${WORKDIR}/tools-${VERSION}"
-
-d_src_compile() {
- for tool in ${TOOLS}; do
- if use "${tool}"; then
- emake -f posix.mak DMD="${DMD}" DFLAGS="${DMDFLAGS}" "${tool}"
- fi
- done
-}
-
-d_src_install() {
- for tool in ${TOOLS}; do
- if use "${tool}"; then
- dobin generated/linux/*/"${tool}"
- fi
- done
-
- # file icons
- for size in 16 22 24 32 48 256; do
- newicon --size "${size}" --context mimetypes "${FILESDIR}/icons/${size}/dmd-source.png" text-x-dsrc.png
- done
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}