aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2019-02-21 12:52:54 +0100
committerGerion Entrup <gerion.entrup@flump.de>2019-02-21 12:54:25 +0100
commit29771f15ea374ca403147e71072e0965c9106077 (patch)
tree8edaade18e7df1d8263bee7be5aa7ed824233b23
parentmedia-plugins/kodi-vfs-libarchive: drop, upstream (diff)
downloadgerislay-29771f15ea374ca403147e71072e0965c9106077.tar.gz
gerislay-29771f15ea374ca403147e71072e0965c9106077.tar.bz2
gerislay-29771f15ea374ca403147e71072e0965c9106077.zip
app-text/zotero-bin: update from 5.0.36 to 5.0.60
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-5.0.60.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
new file mode 100644
index 0000000..0282879
--- /dev/null
+++ b/app-text/zotero-bin/Manifest
@@ -0,0 +1,2 @@
+DIST Zotero-5.0.60_linux-x86_64.tar.bz 59437570 BLAKE2B ce80ab6ea50df68cda9619614beccadd709aab70483bc47ef894221af54728405ea1c8bd89f46ebda8edc68330fe526840c48f47c2afa53d9fd9948a700f6aa3 SHA512 d703ade65d0f828b4d489ab5c41bb5c24e46a380c653307b327811c7dfa4517d3caaed431a6a932f866482038b32426eb340274b2eaac1ab5b9601ca2a088c23
+EBUILD zotero-bin-5.0.60.ebuild 1552 BLAKE2B 31186c23028347e4cec3140fe093ca531b2b0a8feb9c5a74eec0e7e4255cbe36a14ab2055f5796a0ccaf46945e37a2b376c826dc99da6e5d09d554e2f2cc5f01 SHA512 a723a56fafcb2698ef7d8716abdecb53379edf4873c223e329861fb193d6a29b7d060ad3bb48743af32878a73340700b48f6890c48f4dcbcc98040f23bc54571
diff --git a/app-text/zotero-bin/zotero-bin-5.0.60.ebuild b/app-text/zotero-bin/zotero-bin-5.0.60.ebuild
new file mode 100644
index 0000000..2bb849e
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-5.0.60.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop
+
+MY_PN="Zotero"
+LNXARCH="linux-x86_64"
+
+DESCRIPTION="A tool to help you collect, organize, cite, and share your research sources."
+HOMEPAGE="https://www.zotero.org/"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=${LNXARCH}&version=${PV} -> ${MY_PN}-${PV}_${LNXARCH}.tar.bz"
+
+MY_P="${MY_PN}-${PV}"
+
+S="${WORKDIR}/${MY_PN}_${LNXARCH}"
+
+IUSE=""
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+ZOTERO_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install zotero files to /opt/zotero
+ dodir ${ZOTERO_INSTALL_DIR}
+ cp -a ${S}/. ${D}${ZOTERO_INSTALL_DIR} || die "Installing files failed"
+
+ # install zotero-start.sh in /opt/zotero
+ touch $D${ZOTERO_INSTALL_DIR}/zotero-start.sh
+
+ # give it some instructions to start zotero
+ echo "#!/bin/sh" >> $D${ZOTERO_INSTALL_DIR}/zotero-start.sh
+ echo "exec \"/opt/${PN}/zotero\"" >> $D${ZOTERO_INSTALL_DIR}/zotero-start.sh
+
+ # make zotero-start.sh executable
+ fperms +x ${ZOTERO_INSTALL_DIR}/zotero-start.sh
+
+ # sym link /opt/zotero/zotero-start.sh to /opt/bin/zotero
+ dosym ${ZOTERO_INSTALL_DIR}/zotero-start.sh /opt/bin/zotero
+
+ newicon -s 48 chrome/icons/default/default48.png zotero.png
+ newicon chrome/icons/default/default48.png zotero.png
+ newicon -s 32 chrome/icons/default/default32.png zotero.png
+ newicon -s 16 chrome/icons/default/default16.png zotero.png
+ make_desktop_entry "/opt/bin/zotero" Zotero zotero Science
+}