aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2018-05-18 13:36:22 +0200
committerGerion Entrup <gerion.entrup@flump.de>2018-05-18 13:36:22 +0200
commita029f2cae33ae12b9632e5599f6d5314dd299a85 (patch)
treeab01456af2fe623ddfb39ad7c190fa9f6264f8ef /dev-python
parentopenrct2: drop, it's in the gentoo tree (diff)
downloadgerislay-a029f2cae33ae12b9632e5599f6d5314dd299a85.tar.gz
gerislay-a029f2cae33ae12b9632e5599f6d5314dd299a85.tar.bz2
gerislay-a029f2cae33ae12b9632e5599f6d5314dd299a85.zip
add dev-python/rauth
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rauth/Manifest2
-rw-r--r--dev-python/rauth/rauth-0.7.2.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/rauth/Manifest b/dev-python/rauth/Manifest
new file mode 100644
index 0000000..b9c9340
--- /dev/null
+++ b/dev-python/rauth/Manifest
@@ -0,0 +1,2 @@
+DIST rauth-0.7.2.tar.gz 34688 BLAKE2B 412b777d51e5682fec98088fc6af9cb799231deba7d9f808d61e0e6d57ff4f6f49c0e42dc1c6507f59053d603df85c5acd7105c76ce8c4ea02cc20c016402210 SHA512 8b2b0dd3b6878b928ca16b8ce2a264381cb465e7b2abcdae0bde3102dfd34e098606d7efc44ef5cfde0e89113044656df4f9fd7006c78d1300e02d321913cbb6
+EBUILD rauth-0.7.2.ebuild 545 BLAKE2B 3f426449ec56ea39acddc3e954641ddc5d2b18f0f7563a48e74d18a82c19003ff55a190692de5a171efaeb9a4635a691392a9fe2cd1f799eaabf478417bf8856 SHA512 5323d34dea752707d393edc4fc5355db508d5dfa4d5c11ef3860ba6cfd6339227c06aeca469cd4756a60d8484cd3cdb695d22cddc5d57351d2288716a2401246
diff --git a/dev-python/rauth/rauth-0.7.2.ebuild b/dev-python/rauth/rauth-0.7.2.ebuild
new file mode 100644
index 0000000..2635e72
--- /dev/null
+++ b/dev-python/rauth/rauth-0.7.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A Python library for OAuth 1.0/a, 2.0, and Ofly."
+HOMEPAGE="https://github.com/litl/rauth"
+SRC_URI="https://github.com/litl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"