summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/freeorion/Manifest2
-rw-r--r--games-strategy/freeorion/freeorion-0.4.6.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
new file mode 100644
index 0000000..c5ac6a7
--- /dev/null
+++ b/games-strategy/freeorion/Manifest
@@ -0,0 +1,2 @@
+DIST freeorion-0.4.6.tar.gz 145720274 SHA256 3e3ff3a758c8a1ffa71773dff18faff2c792051bb5162758b5f5b8ea59e8e311 SHA512 0488e36286358e8db2dcfe0cdae68e4638388fd2d4c627a258cdecf0afd57e9dbac03111f7683c3ef22edecbedd197a172d177400ddbb585a50f34804a50c50a WHIRLPOOL 30d56a2ca76158168492aa0d1b3fe5a9f164afd7dc378128fe2796ce149a9d65a64cd10c41c5b6c1510773e9ead564dff452869e6c384d949cd0789a51198b6c
+EBUILD freeorion-0.4.6.ebuild 2443 SHA256 e7e06c17d02e185a8c7bf952b2cd8db4ecf3dbd95b2e4fe30db940dd813dbdd5 SHA512 0800deeada52609a2a198b68a3b429b6859c8bcff284fdb326ccf0735e9f71ad06c2cd973b4ce5c0713454b247f7d0d274a3839fe19f81918693f16f9e449d12 WHIRLPOOL dd8aa4c676ec27834a55bcbc9a1adf7486dc0c5012f6006b094119cd7f6c81bdb0d4013d724559c7b57e9d626e7a74ce1d0f863eb49e170d9ca094d83f0685fc
diff --git a/games-strategy/freeorion/freeorion-0.4.6.ebuild b/games-strategy/freeorion/freeorion-0.4.6.ebuild
new file mode 100644
index 0000000..096d918
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.6.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-any-r1 games
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/FreeOrion_v0.4.6_2016-09-16.49f9123_Source.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cg"
+
+# Needs it's own version of GG(dev-games/gigi) which it ships.
+# The split version dev-games/gigi is not used anymore as of 0.4.3
+RDEPEND="
+ !dev-games/gigi
+ media-libs/libsdl2
+ >=dev-libs/boost-1.47[python]
+ media-libs/freealut
+ media-libs/libogg
+ media-libs/libsdl[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+CMAKE_USE_DIR="${S}"
+CMAKE_VERBOSE="1"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ default
+ mv src-tarball "${P}" || die
+ }
+
+src_prepare() {
+ # parse subdir sets -O3
+ sed -e "s:-O3::" -i parse/CMakeLists.txt
+ epatch "${FILESDIR}/${P}-boost-1.61.patch"
+
+ # For snapshots, the following can be used to the set revision
+ # for display in game -- update on bump!
+ # sed -i -e 's/???/8051/' CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRELEASE_COMPILE_FLAGS=""
+ -DCMAKE_SKIP_RPATH=ON
+ )
+
+ append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # data files
+ rm "${CMAKE_USE_DIR}"/default/COPYING || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${CMAKE_USE_DIR}"/default || die
+
+ # bin
+ dogamesbin "${CMAKE_BUILD_DIR}"/${PN}{ca,d} || die
+ newgamesbin "${CMAKE_BUILD_DIR}"/${PN} ${PN}.bin || die
+ games_make_wrapper ${PN} \
+ "${GAMES_BINDIR}/${PN}.bin --resource-dir ${GAMES_DATADIR}/${PN}/default" \
+ "${GAMES_DATADIR}/${PN}"
+
+ # lib
+ dogameslib "${CMAKE_BUILD_DIR}"/libfreeorion{common,parse}.so || die
+ dogameslib "${CMAKE_BUILD_DIR}"/libGiGi*.so || die
+
+ # other
+ dodoc "${CMAKE_USE_DIR}"/changelog.txt || die
+ newicon "${CMAKE_USE_DIR}"/default/data/art/icons/FO_Icon_32x32.png \
+ ${PN}.png || die
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}