aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2022-02-03 01:59:14 +0000
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2022-02-03 01:59:14 +0000
commit77c0e4363a366556850ffa69eee2a3ab88471d9b (patch)
tree227e45421426b372bb2d878832211f1ec7a53d1d
parentRemove stripped directories from build (diff)
downloadssnb-77c0e436.tar.gz
ssnb-77c0e436.tar.bz2
ssnb-77c0e436.zip
Remove pcm ebuild because it is outdated
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
-rw-r--r--sys-apps/pcm/Manifest3
-rw-r--r--sys-apps/pcm/metadata.xml9
l---------sys-apps/pcm/pcm-201902.0.ebuild1
-rw-r--r--sys-apps/pcm/pcm-999999.ebuild68
4 files changed, 0 insertions, 81 deletions
diff --git a/sys-apps/pcm/Manifest b/sys-apps/pcm/Manifest
deleted file mode 100644
index fbd34da..0000000
--- a/sys-apps/pcm/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-EBUILD pcm-201902.0.ebuild 1369 BLAKE2B 80817aa0b696b005580cc2d0776a3a843446f2bc70163d8809b5181fd0a44fd1ea78f90bcdfb77ad4693a6cd047ae34bcfd65a95a11ae8cdae2c68034a07e429 SHA512 d07151849edba7995db8fae6d489256a17c1e9a08ed7e7e271eb14f5161c1519691522a3c559c9d0c0fd167aa149cf0e8059fe59728174ce12766d822039a180
-EBUILD pcm-999999.ebuild 1369 BLAKE2B 80817aa0b696b005580cc2d0776a3a843446f2bc70163d8809b5181fd0a44fd1ea78f90bcdfb77ad4693a6cd047ae34bcfd65a95a11ae8cdae2c68034a07e429 SHA512 d07151849edba7995db8fae6d489256a17c1e9a08ed7e7e271eb14f5161c1519691522a3c559c9d0c0fd167aa149cf0e8059fe59728174ce12766d822039a180
-MISC metadata.xml 465 BLAKE2B ec83d6c09feb51ff6b91e9369c26c9a1e3749489cc9f36d9cac9a32d1eb3c4a2ac4087ed8c40b47c1c30faac92ead54b0f73d27acf8ed0a4fd551dda0c1b4dd5 SHA512 4978d475dbdc8667bb3d7157c28c7975605ec85a5a6af7200e3e6a4812b6c8ef2be7ce55c0c8703c8b317ee9d1e6f41b38b28d5711a5f098786b61daa563e9cc
diff --git a/sys-apps/pcm/metadata.xml b/sys-apps/pcm/metadata.xml
deleted file mode 100644
index 00bcf7b..0000000
--- a/sys-apps/pcm/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>samuelbernardo.mail@gmail.com</email>
- <name>Samuel Bernardo</name>
- <description>Processor Counter Monitor (PCM) is an application programming interface (API) and a set of tools based on the API to monitor performance and energy metrics of Intel processors</description>
- </maintainer>
-</pkgmetadata>
diff --git a/sys-apps/pcm/pcm-201902.0.ebuild b/sys-apps/pcm/pcm-201902.0.ebuild
deleted file mode 120000
index 096e097..0000000
--- a/sys-apps/pcm/pcm-201902.0.ebuild
+++ /dev/null
@@ -1 +0,0 @@
-pcm-999999.ebuild \ No newline at end of file
diff --git a/sys-apps/pcm/pcm-999999.ebuild b/sys-apps/pcm/pcm-999999.ebuild
deleted file mode 100644
index cacb75a..0000000
--- a/sys-apps/pcm/pcm-999999.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=7
-
-inherit eutils multilib git-r3
-
-
-DESCRIPTION="Processor Counter Monitor (PCM) is an application programming interface (API) and a set of tools based on the API to monitor performance and energy metrics of Intel processors"
-HOMEPAGE="https://github.com/opcm/pcm"
-if [[ ${PV} == *999999* ]];then
- EGIT_REPO_URI="https://github.com/opcm/pcm.git"
- KEYWORDS=""
- EGIT_SUBMODULES=( '*' )
-else
- MYPV=$(ver_cut 1)
- EGIT_REPO_URI="https://github.com/opcm/pcm.git"
- EGIT_COMMIT="${MYPV}"
- EGIT_SUBMODULES=( '*' )
- KEYWORDS="~x86 ~amd64"
-fi
-
-LICENSE="Intel"
-SLOT="0"
-IUSE=""
-
-#DEPEND=""
-#RDEPEND="${DEPEND}"
-
-PATCHES=( )
-
-if [[ ${PV} != *999999* ]];then
- src_prepare(){
- default
- }
-fi
-
-src_configure(){
- true
-}
-
-src_compile(){
- cd "${S}"
- emake INSTALL_ROOT="${D}" || die
-}
-
-src_install(){
- insinto usr/share/licenses/${PN}
- doins LICENSE
-
- newbin pcm.x pcm
- newbin pcm-numa.x pcm-numa
- newbin pcm-latency.x pcm-latency
- newbin pcm-power.x pcm-power
- newbin pcm-sensor.x pcm-sensor
- newbin pcm-msr.x pcm-msr
- newbin pcm-memory.x pcm-memory
- newbin pcm-tsx.x pcm-tsx
- newbin pcm-pcie.x pcm-pcie
- newbin pcm-core.x pcm-core
- newbin pcm-iio.x pcm-iio
- newbin pcm-lspci.x pcm-lspci
- newbin pcm-pcicfg.x pcm-pcicfg
-
- into usr/lib/${PN}
- dolib.a libPCM.a
-}