aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2021-06-26 15:40:30 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2021-06-26 15:40:30 +0100
commit949ae6697e1e02349162d3e47997ac596d76f07b (patch)
tree738e61c9e7138c004fe7c72a6d361b5e7696604e
parentUpdate visual-studio-code manifest (diff)
downloadssnb-949ae669.tar.gz
ssnb-949ae669.tar.bz2
ssnb-949ae669.zip
Correct QA check errors in cache regen
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
-rw-r--r--app-office/yed/Manifest2
-rw-r--r--app-office/yed/yed-3.16.2.1.ebuild32
-rw-r--r--dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild88
-rw-r--r--dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild72
-rw-r--r--dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild72
-rw-r--r--sys-block/partclone/partclone-0.2.88.ebuild92
-rw-r--r--www-client/google-chrome/Manifest3
-rw-r--r--www-client/google-chrome/google-chrome-57.0.2987.133.ebuild154
-rw-r--r--www-client/google-chrome/metadata.xml23
-rw-r--r--www-client/opera-developer/Manifest4
-rw-r--r--www-client/opera-developer/files/desktop-57.0.3072.0-r1.patch12
-rw-r--r--www-client/opera-developer/metadata.xml8
-rw-r--r--www-client/opera-developer/opera-developer-57.0.3072.0-r1.ebuild103
13 files changed, 0 insertions, 665 deletions
diff --git a/app-office/yed/Manifest b/app-office/yed/Manifest
deleted file mode 100644
index 931ea53..0000000
--- a/app-office/yed/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST yEd-3.16.2.1.zip 34677676 SHA256 47ac746ad30eb6375b8f45e9382efd0db0b6e3b1eb8f4760625963175b753805 SHA512 fb9f6f82947bef1b96e0c7534ecd39fe75a490ad7e450e92c5048079833c78aa20b14fb3feb66bc7b6bfb907c890dcc6a86146aa91e18d21ac8681d4062ba9b8 WHIRLPOOL 0ebb134ce90820236962ba9fc328865e5a2087b51ae2700ad40c214bc8963e740a39c56f13f0354c28e99d27ca0fb77de0732e2c78ab6e398e84f64e45fb2929
-EBUILD yed-3.16.2.1.ebuild 656 SHA256 25b2c7a6eecae9c07031169415d1ac243c8895218a20be838b69b4b06cd52753 SHA512 df8029dc6bf6f5578f545aacacfb9bec30c6243cd30439f0f86f26b433881c0e3b61805f3c71393184a113d6f03239993f00b6412cfb076e53ebf89c8cfe75fd WHIRLPOOL 2ae75b9ef2b741f8144a5b4c09042f91aa3c37ebc109954c669a6e54afa517a7f57c23479adc1df0af7dc23991f2fdec028dec39ec97a489b145a801bfb9aadc
diff --git a/app-office/yed/yed-3.16.2.1.ebuild b/app-office/yed/yed-3.16.2.1.ebuild
deleted file mode 100644
index 6daa08a..0000000
--- a/app-office/yed/yed-3.16.2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-EAPI="2"
-
-inherit eutils java-pkg-2
-
-DESCRIPTION="Diagram editor written in Java"
-HOMEPAGE="www.yworks.com/products/yed/"
-SRC_URI="https://www.yworks.com/resources/yed/demo/yEd-${PV}.zip"
-
-LICENSE="yed"
-SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc64"
-IUSE=""
-#RESTRICT="fetch"
-
-RDEPEND=">=virtual/jre-1.8
- ${COMMON_DEP}"
-
-DEPEND=">=virtual/jdk-1.8
- ${COMMON_DEP}"
-
-S=${WORKDIR}/${P}
-
-src_install() {
- cd "${S}"
- java-pkg_dojar ${PN}.jar vectorgraphics.jar
-
- java-pkg_dolauncher ${PN} --main B.A.A.B -into "/usr"
-
- doicon "${WORKDIR}"/${P}/icons/yicon32.png
- make_desktop_entry yed yEd yicon32 "Graphics;2DGraphics"
-}
-
diff --git a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild b/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild
deleted file mode 100644
index 25692cb..0000000
--- a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils user versionator systemd
-
-DESCRIPTION="Maven Repository Manager"
-HOMEPAGE="http://nexus.sonatype.org/"
-LICENSE="GPL-3"
-MY_PN="nexus"
-MY_PV="${PV}-04-unix"
-#echo "Debug: custom package version: ${MY_PV}"
-MY_P="${MY_PN}-${MY_PV}"
-MY_MV="3"
-
-SRC_URI="http://download.sonatype.com/${MY_PN}/${MY_MV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-KEYWORDS="~x86 ~amd64"
-SLOT="${MY_MV}"
-IUSE=""
-S="${WORKDIR}"
-#echo "Debug: working directory: ${WORKDIR}"
-RDEPEND=">=virtual/jdk-1.8"
-INSTALL_DIR="/opt/nexus-oss"
-
-pkg_setup() {
-#enewgroup <name> [gid]
-enewgroup nexus
-#enewuser <user> [uid] [shell] [homedir] [groups] [params]
-enewuser nexus -1 /bin/bash "${INSTALL_DIR}" "nexus"
-}
-
-src_unpack() {
-unpack ${A}
-}
-
-src_prepare() {
-cd "${S}"
-if -f "${FILESDIR}/${P}.patch"; then
- epatch "${FILESDIR}/${P}.patch"
-fi
-epatch_user
-}
-
-src_install() {
-#echo "Debug: install sonatype work dir"
-dodir ${INSTALL_DIR/nexus-oss/sonatype-work}
-insinto ${INSTALL_DIR/nexus-oss/sonatype-work}
-doins -r sonatype-work/*
-
-fowners -R nexus:nexus ${INSTALL_DIR/nexus-oss/sonatype-work}
-
-#echo "Debug: INSTALL_DIR: ${INSTALL_DIR}"
-#echo "Debug: doins nexus-${MY_PV}"
-#echo "Debug: ${WORKDIR}/nexus-${MY_PV}/bin/nexus"
-insinto ${INSTALL_DIR}
-
-dodir ${INSTALL_DIR}/run
-dodir "/etc/init.d/"
-doins -r ${MY_P/-unix/}/*
-doins -r ${MY_P/-unix/}/.??*
-#BUG: nexus init script needs a symlink because it uses program path to find their configuration files
-#newinitd "${WORKDIR}/nexus-${MY_PV}/bin/nexus" nexus
-dosym ${INSTALL_DIR}/bin/nexus /etc/init.d/nexus
-systemd_dounit "${FILESDIR}"/nexus-oss.service
-
-fowners -R nexus:nexus ${INSTALL_DIR}
-fperms 755 "${INSTALL_DIR}/bin/nexus"
-
-#echo "Change NEXUS_HOME to the absolute folder location in your .bashrc file, then save"
-echo NEXUS_HOME=\"${INSTALL_DIR}\" >> ${ED}/${INSTALL_DIR}/.bashrc
-fowners -R nexus:nexus ${INSTALL_DIR}/.bashrc
-fperms 644 ${INSTALL_DIR}/.bashrc
-}
-
-pkg_postinst() {
- ewarn "Activate the service with the following commands:"
- ewarn "sudo systemctl daemon-reload"
- ewarn "sudo systemctl enable nexus-oss.service"
- ewarn "sudo systemctl start nexus-oss.service"
- ewarn " "
- elog "After starting the service in Gentoo, verify that"
- elog "the service started successfully."
- elog "tail -f /opt/sonatype-work/nexus3/log/nexus.log"
-}
-
diff --git a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild b/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild
deleted file mode 100644
index abeff12..0000000
--- a/dev-java/nexus-oss-bin/nexus-oss-bin-3.14.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils user versionator systemd
-
-DESCRIPTION="Maven Repository Manager"
-HOMEPAGE="http://nexus.sonatype.org/"
-LICENSE="GPL-3"
-MY_PN="nexus"
-MY_PV="${PV}-04-unix"
-#echo "Debug: custom package version: ${MY_PV}"
-MY_P="${MY_PN}-${MY_PV}"
-MY_MV="3"
-
-SRC_URI="http://download.sonatype.com/${MY_PN}/${MY_MV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-KEYWORDS="~x86 ~amd64"
-SLOT="${MY_MV}"
-IUSE=""
-S="${WORKDIR}"
-#echo "Debug: working directory: ${WORKDIR}"
-RDEPEND=">=virtual/jdk-1.8"
-INSTALL_DIR="/opt/nexus-oss"
-
-pkg_setup() {
-#enewgroup <name> [gid]
-enewgroup nexus
-#enewuser <user> [uid] [shell] [homedir] [groups] [params]
-enewuser nexus -1 /bin/bash "${INSTALL_DIR}" "nexus"
-}
-
-src_unpack() {
-unpack ${A}
-}
-
-src_prepare() {
-cd "${S}"
-if -f "${FILESDIR}/${P}.patch"; then
- epatch "${FILESDIR}/${P}.patch"
-fi
-epatch_user
-}
-
-src_install() {
-#echo "Debug: install sonatype work dir"
-dodir ${INSTALL_DIR/nexus-oss/sonatype-work}
-insinto ${INSTALL_DIR/nexus-oss/sonatype-work}
-doins -r sonatype-work/*
-
-fowners -R nexus:nexus ${INSTALL_DIR/nexus-oss/sonatype-work}
-
-#echo "Debug: INSTALL_DIR: ${INSTALL_DIR}"
-#echo "Debug: doins nexus-${MY_PV}"
-#echo "Debug: ${WORKDIR}/nexus-${MY_PV}/bin/nexus"
-insinto ${INSTALL_DIR}
-
-dodir ${INSTALL_DIR}/run
-dodir "/etc/init.d/"
-doins -r ${MY_P/-unix/}/*
-doins -r ${MY_P/-unix/}/.??*
-#BUG: nexus init script needs a symlink because it uses program path to find their configuration files
-#newinitd "${WORKDIR}/nexus-${MY_PV}/bin/nexus" nexus
-dosym ${INSTALL_DIR}/bin/nexus /etc/init.d/nexus
-systemd_dounit "${FILESDIR}"/nexus-oss.service
-
-fowners -R nexus:nexus ${INSTALL_DIR}
-fperms 755 "${INSTALL_DIR}/bin/nexus"
-
-}
diff --git a/dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild b/dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild
deleted file mode 100644
index abeff12..0000000
--- a/dev-java/nexus-oss-bin/nexus-oss-bin-3.7.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils user versionator systemd
-
-DESCRIPTION="Maven Repository Manager"
-HOMEPAGE="http://nexus.sonatype.org/"
-LICENSE="GPL-3"
-MY_PN="nexus"
-MY_PV="${PV}-04-unix"
-#echo "Debug: custom package version: ${MY_PV}"
-MY_P="${MY_PN}-${MY_PV}"
-MY_MV="3"
-
-SRC_URI="http://download.sonatype.com/${MY_PN}/${MY_MV}/${MY_P}.tar.gz"
-RESTRICT="mirror"
-KEYWORDS="~x86 ~amd64"
-SLOT="${MY_MV}"
-IUSE=""
-S="${WORKDIR}"
-#echo "Debug: working directory: ${WORKDIR}"
-RDEPEND=">=virtual/jdk-1.8"
-INSTALL_DIR="/opt/nexus-oss"
-
-pkg_setup() {
-#enewgroup <name> [gid]
-enewgroup nexus
-#enewuser <user> [uid] [shell] [homedir] [groups] [params]
-enewuser nexus -1 /bin/bash "${INSTALL_DIR}" "nexus"
-}
-
-src_unpack() {
-unpack ${A}
-}
-
-src_prepare() {
-cd "${S}"
-if -f "${FILESDIR}/${P}.patch"; then
- epatch "${FILESDIR}/${P}.patch"
-fi
-epatch_user
-}
-
-src_install() {
-#echo "Debug: install sonatype work dir"
-dodir ${INSTALL_DIR/nexus-oss/sonatype-work}
-insinto ${INSTALL_DIR/nexus-oss/sonatype-work}
-doins -r sonatype-work/*
-
-fowners -R nexus:nexus ${INSTALL_DIR/nexus-oss/sonatype-work}
-
-#echo "Debug: INSTALL_DIR: ${INSTALL_DIR}"
-#echo "Debug: doins nexus-${MY_PV}"
-#echo "Debug: ${WORKDIR}/nexus-${MY_PV}/bin/nexus"
-insinto ${INSTALL_DIR}
-
-dodir ${INSTALL_DIR}/run
-dodir "/etc/init.d/"
-doins -r ${MY_P/-unix/}/*
-doins -r ${MY_P/-unix/}/.??*
-#BUG: nexus init script needs a symlink because it uses program path to find their configuration files
-#newinitd "${WORKDIR}/nexus-${MY_PV}/bin/nexus" nexus
-dosym ${INSTALL_DIR}/bin/nexus /etc/init.d/nexus
-systemd_dounit "${FILESDIR}"/nexus-oss.service
-
-fowners -R nexus:nexus ${INSTALL_DIR}
-fperms 755 "${INSTALL_DIR}/bin/nexus"
-
-}
diff --git a/sys-block/partclone/partclone-0.2.88.ebuild b/sys-block/partclone/partclone-0.2.88.ebuild
deleted file mode 100644
index e7305a6..0000000
--- a/sys-block/partclone/partclone-0.2.88.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Partition cloning tool"
-HOMEPAGE="http://partclone.org"
-SRC_URI="http://sourceforge.net/projects/partclone/files/stable/${PV}/partclone_${PV}.orig.tar.gz/download -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="btrfs reiserfs reiser4 hfs fat minix ntfs jfs static vmfs xfs f2fs nilfs2"
-
-# xfsprogs, see https://bugs.gentoo.org/show_bug.cgi?id=486514
-RDEPEND="${common_depends}
- sys-fs/e2fsprogs
- btrfs? ( sys-fs/btrfs-progs )
- fat? ( sys-fs/dosfstools )
- ntfs? ( sys-fs/ntfs3g )
- hfs? ( sys-fs/hfsutils )
- jfs? ( sys-fs/jfsutils )
- reiserfs? ( sys-fs/progsreiserfs )
- reiser4? ( sys-fs/reiser4progs )
- xfs? ( >=sys-fs/xfsprogs-3.1.11-r1 )
- nilfs2? ( >=sys-fs/nilfs-utils-2.1.5-r1 )
- f2fs? ( >=sys-libs/e2fsprogs-libs-1.42.13 )
- static? ( sys-fs/e2fsprogs[static-libs]
- sys-libs/e2fsprogs-libs[static-libs]
- sys-fs/xfsprogs[static-libs]
- sys-libs/ncurses[static-libs]
- sys-fs/ntfs3g[static-libs]
- )"
-DEPEND=""
-
-src_unpack()
-{
- unpack ${A}
- #epatch "${FILESDIR}/${PN}-xfslib.patch"
- cd ${S}
-}
-
-src_compile()
-{
- local myconf
- myconf="${myconf} --enable-extfs --enable-ncursesw --enable-fs-test"
- use xfs && myconf="${myconf} --enable-xfs"
- use reiserfs && myconf="${myconf} --enable-reiserfs"
- use reiser4 && myconf="${myconf} --enable-reiser4"
- use hfs && myconf="${myconf} --enable-hfsp"
- use fat && myconf="${myconf} --enable-fat --enable-exfat"
- use ntfs && myconf="${myconf} --enable-ntfs"
- use minix && myconf="${myconf} --enable-minix"
- use jfs && myconf="${myconf} --enable-jfs"
- use btrfs && myconf="${myconf} --enable-btrfs"
- use vmfs && myconf="${myconf} --enable-vmfs"
- use f2fs && myconf="${myconf} --enable-f2fs"
- use nilfs2 && myconf="${myconf} --enable-nilfs2"
- use static && myconf="${myconf} --enable-static"
-
- econf ${myconf} || die "econf failed"
- emake || die "make failed"
-}
-
-src_install()
-{
- #emake install || die "make install failed"
- #emake DIST_ROOT="${D}" install || die "make install failed"
- cd ${S}/src
- dosbin partclone.dd partclone.restore partclone.chkimg partclone.info partclone.imager
- dosbin partclone.extfs
- dosym /usr/sbin/partclone.extfs /usr/sbin/partclone.ext4
- dosym /usr/sbin/partclone.extfs /usr/sbin/partclone.ext4dev
- use xfs && dosbin partclone.xfs
- use reiserfs && dosbin partclone.reiserfs
- use reiser4 && dosbin partclone.reiser4
- use hfs && dosbin partclone.hfsp
- use fat && (dosbin partclone.fat
- dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat12
- dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat16
- dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat32)
- use ntfs && dosbin partclone.ntfs
- use ntfs && (dosbin partclone.ntfsfixboot
- dosym /usr/sbin/partclone.ntfsfixboot /usr/sbin/partclone.ntfsreloc)
- use btrfs && dosbin partclone.btrfs
- use f2fs && dosbin partclone.f2fs
- use nilfs2 && dosbin partclone.nilfs2
-}
-
diff --git a/www-client/google-chrome/Manifest b/www-client/google-chrome/Manifest
deleted file mode 100644
index 94d17f6..0000000
--- a/www-client/google-chrome/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST google-chrome-stable_57.0.2987.133-1_amd64.deb 47321450 SHA256 4a62a77b3c7960f9313d41a40f645b7178d6a8b91f9f1141d7664026692ef63d SHA512 d69c0d0c333c789d38efc57c700a8ce168e84f3195f51a75e4967496cbb5fd6d770afd9cbedbd5f182f6ae5591ba49b2f309148a26d8d0eddff358be8632d6f5 WHIRLPOOL 33351ca6600f1672dcecbd7f82755376d02c4ed454cfac291f5e0eba41d1596b99dde9a139c81bdd71ddde7db8e1e1d3675920d418aa625add17bad301c6f9e3
-EBUILD google-chrome-57.0.2987.133.ebuild 3537 SHA256 f0868571e7c79a9106780352e8a8c30860913185f6a63ac35bb1581a7275fded SHA512 f4109dafdd4f5b86efd15d69cd0309dea01464263ffc0b840be15a938e5015f4d37997197726e283484ff5db245cb47cbdbdc2c4415bb19c3a5eae50975cf682 WHIRLPOOL f9287c0a598353a52ced33c6614155e1f424c7a14dd5f8767131f5e331424add6d889f4c5b10fa42387a83fd866caf6534c056edd777aca0dfa0a0a208f07e45
-MISC metadata.xml 728 SHA256 928f4e550d8e5d4b9799b2688a57d972099e7351b686db223b595440213fb8be SHA512 3f6704952f48253e75510533434d38257c2b14e2690a01c5fc8a77deb826b433d3cc84c8aee89dd625aaa7cbc3607139cf989144e911efa3c342ee7c6090eff9 WHIRLPOOL 60c7164cec23c8ce2b98c4c5568c8f6ceb9d326acccbb77b1f92be858c76e5f86717b0a98d799e65b2c7302b8669088d7779bea925cc67a1d5eea2d24ffbbe94
diff --git a/www-client/google-chrome/google-chrome-57.0.2987.133.ebuild b/www-client/google-chrome/google-chrome-57.0.2987.133.ebuild
deleted file mode 100644
index ad534ab..0000000
--- a/www-client/google-chrome/google-chrome-57.0.2987.133.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-CHROMIUM_LANGS="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he
- hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
- sv sw ta te th tr uk vi zh-CN zh-TW"
-
-inherit readme.gentoo-r1 chromium-2 eutils gnome2-utils pax-utils unpacker xdg-utils
-
-DESCRIPTION="The web browser from Google"
-HOMEPAGE="https://www.google.com/chrome"
-
-if [[ ${PN} == google-chrome ]]; then
- MY_PN=${PN}-stable
-else
- MY_PN=${PN}
-fi
-
-MY_P="${MY_PN}_${PV}-1"
-
-SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
-
-LICENSE="google-chrome"
-SLOT="0"
-KEYWORDS="-* ~amd64"
-IUSE="+plugins"
-RESTRICT="bindist mirror strip"
-
-DEPEND=""
-RDEPEND="
- app-arch/bzip2
- app-misc/ca-certificates
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- gnome-base/gconf:2
- media-libs/alsa-lib
- media-libs/fontconfig
- media-libs/freetype:2
- net-print/cups
- sys-apps/dbus
- sys-libs/libcap
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
- >=x11-libs/libX11-1.5.0
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- x11-libs/pango
- x11-misc/xdg-utils
-"
-
-QA_PREBUILT="*"
-QA_DESKTOP_FILE="usr/share/applications/google-chrome.*\\.desktop"
-S=${WORKDIR}
-CHROME_HOME="opt/google/chrome${PN#google-chrome}"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-Some web pages may require additional fonts to display properly.
-Try installing some of the following packages if some characters
-are not displayed properly:
-- media-fonts/arphicfonts
-- media-fonts/bitstream-cyberbit
-- media-fonts/droid
-- media-fonts/ipamonafont
-- media-fonts/ja-ipafonts
-- media-fonts/takao-fonts
-- media-fonts/wqy-microhei
-- media-fonts/wqy-zenhei
-
-Depending on your desktop environment, you may need
-to install additional packages to get icons on the Downloads page.
-
-For KDE, the required package is kde-frameworks/oxygen-icons.
-
-For other desktop environments, try one of the following:
-- x11-themes/gnome-icon-theme
-- x11-themes/tango-icon-theme
-
-Please notice the bundled flash player (PepperFlash).
-You can (de)activate all flash plugins via chrome://plugins
-"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your tree before reporting a bug for google-chrome fetch failures."
-}
-
-pkg_pretend() {
- # Protect against people using autounmask overzealously
- use amd64 || die "google-chrome only works on amd64"
-}
-
-pkg_setup() {
- chromium_suid_sandbox_check_kernel_config
-}
-
-src_unpack() {
- :
-}
-
-src_install() {
- dodir /
- cd "${ED}" || die
- unpacker
-
- rm -r etc usr/share/menu || die
- mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
-
- pushd "${CHROME_HOME}/locales" > /dev/null || die
- chromium_remove_language_paks
- popd > /dev/null || die
-
- if use plugins ; then
- local plugins="--extra-plugin-dir=/usr/$(get_libdir)/nsbrowser/plugins"
- sed -e "/^exec/ i set -- \"${plugins}\" \"\$@\"" \
- -i "${CHROME_HOME}/${PN}" || die
- fi
-
- local size
- for size in 16 22 24 32 48 64 128 256 ; do
- newicon -s ${size} "${CHROME_HOME}/product_logo_${size}.png" ${PN}.png
- done
-
- pax-mark m "${CHROME_HOME}/chrome"
-
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- readme.gentoo_print_elog
-}
diff --git a/www-client/google-chrome/metadata.xml b/www-client/google-chrome/metadata.xml
deleted file mode 100644
index ca28e10..0000000
--- a/www-client/google-chrome/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>floppym@gentoo.org</email>
- <name>Mike Gilbert</name>
- </maintainer>
- <maintainer type="person">
- <email>xmw@gentoo.org</email>
- <name>Michael Weber</name>
- </maintainer>
- <maintainer type="project">
- <email>chromium@gentoo.org</email>
- <name>Chromium in Gentoo Project</name>
- </maintainer>
- <longdescription>
- Google Chrome is a browser that combines a minimal design with
- sophisticated technology to make the web faster, safer, and easier.
- </longdescription>
- <use>
- <flag name="plugins">Add system plugins path to launcher</flag>
- </use>
-</pkgmetadata>
diff --git a/www-client/opera-developer/Manifest b/www-client/opera-developer/Manifest
deleted file mode 100644
index fd756a3..0000000
--- a/www-client/opera-developer/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX desktop-57.0.3072.0-r1.patch 595 BLAKE2B e9f392a497e4b0ac7fd712aac9f9152020cf4d99a1006778d3a5621c1e777af4c20405656b8fcde51133cf9700d4991fca4742859720f3477580b575dd72b130 SHA512 6d9f0b4e7eaff9de008a55397d224d59941980685e33cdc8d270e777738f4bc40b77392376ae1e41b96ac3cf5399ac781a9e527d7a39d11683821236cbb89760
-DIST opera-developer_57.0.3072.0_amd64.rpm 55503092 BLAKE2B 9e326fa416e707057895257aeb3e248aca57e3b3d748d707684e2392f331b3a166bdceac7e8b66e74312442438a71161ff9dab38eeb89a5316c47d60e6a38869 SHA512 4645a6edcf6cb52203637e316930f670f3c08cc4c2ca4c90234daa12e63b91051a5e4bf80e824c1d516f1e771476e4fa2d96b1b1eedf23740c8254fd7fc80a20
-EBUILD opera-developer-57.0.3072.0-r1.ebuild 2073 BLAKE2B 43f9b2348b76dd4d89fade381a51b345db1af574aa582286fae5698e56ef86078dfe53ac79c7bbae662813ef5f5a87d540c25a6da9bd36546325cf9a9ac441fb SHA512 46376bfe8501767184425939ac83173b772d827928fdf0f5ce323a72dcc74e3a7883de402a3b193a7d3b26f5545036eee6e3ec0de1dc6caf8a54cad755f417f6
-MISC metadata.xml 254 BLAKE2B 54ebd61500e1a9a78a907f035de7a6cfd9b04808d3e10c598b7578fed816cbae84bfbb9c0ae0d1724810835453150ea86f2ec0223e77fed3c4fab0a68542e4d1 SHA512 40afd8225ecb72aaa0710a0347d5044f49ffd257bae49e114189d1039f25f041349d10b47ff0bf294be1de11722d051f4b526de8caf468808baadb9044f2d7ef
diff --git a/www-client/opera-developer/files/desktop-57.0.3072.0-r1.patch b/www-client/opera-developer/files/desktop-57.0.3072.0-r1.patch
deleted file mode 100644
index 34387a8..0000000
--- a/www-client/opera-developer/files/desktop-57.0.3072.0-r1.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur a/usr/share/applications/opera-developer.desktop b/usr/share/applications/opera-developer.desktop
---- a/usr/share/applications/opera-developer.desktop 2018-09-09 23:22:12.000000000 +0100
-+++ b/usr/share/applications/opera-developer.desktop 2018-09-15 19:59:49.390129993 +0100
-@@ -6,7 +6,7 @@
- TryExec=opera-developer
- Exec=opera-developer %U
- Terminal=false
--Icon=
-+Icon=opera-developer
- Type=Application
- Categories=Network;WebBrowser;
- MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;application/x-opera-download;
diff --git a/www-client/opera-developer/metadata.xml b/www-client/opera-developer/metadata.xml
deleted file mode 100644
index c577d70..0000000
--- a/www-client/opera-developer/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
-<email>samuelbernardo.mail@gmail.com</email>
-<name>Samuel Bernardo</name>
-</maintainer>
-</pkgmetadata>
diff --git a/www-client/opera-developer/opera-developer-57.0.3072.0-r1.ebuild b/www-client/opera-developer/opera-developer-57.0.3072.0-r1.ebuild
deleted file mode 100644
index 441d8a8..0000000
--- a/www-client/opera-developer/opera-developer-57.0.3072.0-r1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-CHROMIUM_LANGS="
- be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
- ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
- zh-CN zh-TW
-"
-inherit chromium-2 gnome2-utils multilib rpm xdg-utils
-
-DESCRIPTION="A fast and secure web browser"
-HOMEPAGE="https://www.opera.com/"
-LICENSE="OPERA-2014"
-SLOT="0"
-SRC_URI_BASE="
- https://download1.operacdn.com/pub/
- https://download2.operacdn.com/pub/
- https://download3.operacdn.com/pub/
- https://download4.operacdn.com/pub/
-"
-SRC_URI="amd64? ("
-for uri in ${SRC_URI_BASE}; do
-SRC_URI+="
- "${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.rpm"
-"
-done
-SRC_URI+=")"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- gnome-base/gconf:2
- media-libs/alsa-lib
- media-libs/fontconfig
- media-libs/freetype
- net-misc/curl
- net-print/cups
- sys-apps/dbus
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/libXScrnSaver
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXtst
- x11-libs/libnotify
- x11-libs/pango[X]
-"
-
-QA_PREBUILT="*"
-S=${WORKDIR}
-OPERA_HOME="usr/$(get_libdir)/${PN}"
-
-PATCHES="${FILESDIR}/desktop-${PVR}.patch"
-
-src_prepare() {
- epatch ${PATCHES}
-
- rm usr/bin/${PN} || die
-
- pushd "${OPERA_HOME}/localization" > /dev/null || die
- chromium_remove_language_paks
- popd > /dev/null || die
-
- sed -i \
- -e 's|^TargetEnvironment|X-&|g' \
- usr/share/applications/${PN}.desktop || die
-
- epatch_user
-}
-
-src_install() {
- mv * "${D}" || die
- dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
- fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}