aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2016-04-30 15:59:18 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2016-04-30 15:59:18 +0100
commitc21285bb28d87bc7190b935456c1a9afd8b1fc03 (patch)
treeb9d9695adb7a8372e5ebd9362b38241063c45da7
parentadded metastore ebuild (diff)
downloadssnb-c21285bb.tar.gz
ssnb-c21285bb.tar.bz2
ssnb-c21285bb.zip
partclone and vmfs-tools update (already tested and working)
-rw-r--r--sys-block/partclone/Manifest5
-rw-r--r--sys-block/partclone/partclone-0.2.69.ebuild79
-rw-r--r--sys-block/partclone/partclone-0.2.88.ebuild92
-rw-r--r--sys-block/partclone/partclone-9999.ebuild68
-rw-r--r--sys-fs/vmfs-tools/Manifest1
-rw-r--r--sys-fs/vmfs-tools/files/vmfs-tools-0.2.5-buildsystem.patch43
-rw-r--r--sys-fs/vmfs-tools/metadata.xml10
-rw-r--r--sys-fs/vmfs-tools/vmfs-tools-0.2.5.ebuild31
8 files changed, 329 insertions, 0 deletions
diff --git a/sys-block/partclone/Manifest b/sys-block/partclone/Manifest
new file mode 100644
index 0000000..6ffd7e7
--- /dev/null
+++ b/sys-block/partclone/Manifest
@@ -0,0 +1,5 @@
+DIST partclone-0.2.69.tar.gz 566531 SHA256 2248b1e0387e9d44c45be091dd3fb29e2f0d079f42023b713e6cc19b54587f55 SHA512 70c5056fe31fbe1099e0f9603efa35ea7729d1af9efab692493a8e3e93b64c4b23c69d943185c62b4574089ed1320aedf67b93fab93c212e048eaaefb0905847 WHIRLPOOL ae33f335e69d7eba1a85a741705fbb93f300da963a9c0871980d3c0971035692c1583f6bb3976ddb145d5d61315e2c0965d1be54bbc776544537d0984d5d8894
+DIST partclone-0.2.88.tar.gz 1024941 SHA256 01acaab3f8f7a393ed930cebec8a77623f6598cc26239a78240d2a48d8544f36 SHA512 f05480363ee5604b3e3ea7dbb28dbb3dbec9e4fbf8350f69c88be1392e84a7de248a9b786faa59bdcce2b82a16e7108c5cb9a37aa07a35cd5cf1d06d230a55f9 WHIRLPOOL bd36b6d4c3cf15b8dba1ad144bbc77d7a0bbec0a684c778ab58fc5478fd570d5558e474c5b57713fa7dd09d6d146bdc49fd5abe30eedd0ce4d803d4c615eb39e
+EBUILD partclone-0.2.69.ebuild 2270 SHA256 6904cea5e97259285b0aca68301a181db04828e4dc054a7293fc1a76dee23339 SHA512 d035e6ac4eef65f8368517530f8cab89b15c2dbc8d4ff4c35f0adf0421de70ce386baac4f3e44efb0a1e3f96a0dad7ae925407f00da2e10122732b0df243135c WHIRLPOOL eccbadcf8a54e52158341168b039a7d4860575515d85cca8e478806cf2347acb6c5b28eb6d0b09ff323e2236cd2ec7dd508728be2e0dede391c11cc33ad528b1
+EBUILD partclone-0.2.88.ebuild 2985 SHA256 810de8ac6f6946aee1bb56fd736bea83576d8af7fb080008773dffa86a542b2c SHA512 456c3dbd988a7b3675522eee1779002aff78ba4b3020efd60431b5dc58a05e5cd8d8221422e7c73a2a0c8c372f959f25ec796fb7661cdd9c470eabd929612e8d WHIRLPOOL ecad42015dbcb0bff753ab185058878d567a12f0c9d26c4e36154e410be149c94a62b726099259684eddf10213a59d51ebf8026939cb6c297076d185cf2c0a9e
+EBUILD partclone-9999.ebuild 1694 SHA256 3a15b1d5576b298c2ce0d1d38f3a973d1cf0c088d5494448e5d233cee79b0e11 SHA512 62158878ed0dd0dd8eb4023e79fbd45402b0202becfebd8c7b1a3affd35b383d20e57a16a5456d310c88fb6f621095218f2d54af3b6cc5589fd409e0c1469807 WHIRLPOOL 2b60ee28435936b8006dfecb3061986ead97acc55b6fa7187983ba241a00f77145862c72e7aec908ef71540e099fb30e48a330044dfef13fb922e82b4efbc6cd
diff --git a/sys-block/partclone/partclone-0.2.69.ebuild b/sys-block/partclone/partclone-0.2.69.ebuild
new file mode 100644
index 0000000..39b4e3e
--- /dev/null
+++ b/sys-block/partclone/partclone-0.2.69.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Partition cloning tool"
+HOMEPAGE="http://partclone.org"
+SRC_URI="http://sourceforge.net/projects/partclone/files/stable/${PV}/partclone_${PV}.orig.tar.gz/download -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="btrfs reiserfs reiser4 hfs fat minix ntfs jfs static vmfs xfs"
+
+# xfsprogs, see https://bugs.gentoo.org/show_bug.cgi?id=486514
+RDEPEND="${common_depends}
+ sys-fs/e2fsprogs
+ btrfs? ( sys-fs/btrfs-progs )
+ fat? ( sys-fs/dosfstools )
+ ntfs? ( sys-fs/ntfs3g )
+ hfs? ( sys-fs/hfsutils )
+ jfs? ( sys-fs/jfsutils )
+ reiserfs? ( sys-fs/progsreiserfs )
+ reiser4? ( sys-fs/reiser4progs )
+ xfs? ( >=sys-fs/xfsprogs-3.1.11-r1 )
+ static? ( sys-fs/e2fsprogs[static-libs]
+ sys-libs/e2fsprogs-libs[static-libs]
+ sys-fs/xfsprogs[static-libs]
+ sys-libs/ncurses[static-libs]
+ sys-fs/ntfs3g[static-libs]
+ )"
+DEPEND=""
+
+src_unpack()
+{
+ unpack ${A}
+ #epatch "${FILESDIR}/${PN}-xfslib.patch"
+ cd ${S}
+}
+
+src_compile()
+{
+ local myconf
+ myconf="${myconf} --enable-extfs --enable-ncursesw --enable-fs-test"
+ use xfs && myconf="${myconf} --enable-xfs"
+ use reiserfs && myconf="${myconf} --enable-reiserfs"
+ use reiser4 && myconf="${myconf} --enable-reiser4"
+ use hfs && myconf="${myconf} --enable-hfsp"
+ use fat && myconf="${myconf} --enable-fat --enable-exfat"
+ use ntfs && myconf="${myconf} --enable-ntfs"
+ use minix && myconf="${myconf} --enable-minix"
+ use jfs && myconf="${myconf} --enable-jfs"
+ use btrfs && myconf="${myconf} --enable-btrfs"
+ use vmfs && myconf="${myconf} --enable-vmfs"
+ use static && myconf="${myconf} --enable-static"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install()
+{
+ #emake install || die "make install failed"
+ #emake DIST_ROOT="${D}" install || die "make install failed"
+ cd ${S}/src
+ dosbin partclone.dd partclone.restore partclone.chkimg
+ dosbin partclone.extfs
+ use xfs && dosbin partclone.xfs
+ use reiserfs && dosbin partclone.reiserfs
+ use reiser4 && dosbin partclone.reiser4
+ use hfs && dosbin partclone.hfsp
+ use fat && dosbin partclone.fat
+ use ntfs && dosbin partclone.ntfs
+ use ntfs && dosbin partclone.ntfsfixboot
+}
+
diff --git a/sys-block/partclone/partclone-0.2.88.ebuild b/sys-block/partclone/partclone-0.2.88.ebuild
new file mode 100644
index 0000000..e7305a6
--- /dev/null
+++ b/sys-block/partclone/partclone-0.2.88.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Partition cloning tool"
+HOMEPAGE="http://partclone.org"
+SRC_URI="http://sourceforge.net/projects/partclone/files/stable/${PV}/partclone_${PV}.orig.tar.gz/download -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="btrfs reiserfs reiser4 hfs fat minix ntfs jfs static vmfs xfs f2fs nilfs2"
+
+# xfsprogs, see https://bugs.gentoo.org/show_bug.cgi?id=486514
+RDEPEND="${common_depends}
+ sys-fs/e2fsprogs
+ btrfs? ( sys-fs/btrfs-progs )
+ fat? ( sys-fs/dosfstools )
+ ntfs? ( sys-fs/ntfs3g )
+ hfs? ( sys-fs/hfsutils )
+ jfs? ( sys-fs/jfsutils )
+ reiserfs? ( sys-fs/progsreiserfs )
+ reiser4? ( sys-fs/reiser4progs )
+ xfs? ( >=sys-fs/xfsprogs-3.1.11-r1 )
+ nilfs2? ( >=sys-fs/nilfs-utils-2.1.5-r1 )
+ f2fs? ( >=sys-libs/e2fsprogs-libs-1.42.13 )
+ static? ( sys-fs/e2fsprogs[static-libs]
+ sys-libs/e2fsprogs-libs[static-libs]
+ sys-fs/xfsprogs[static-libs]
+ sys-libs/ncurses[static-libs]
+ sys-fs/ntfs3g[static-libs]
+ )"
+DEPEND=""
+
+src_unpack()
+{
+ unpack ${A}
+ #epatch "${FILESDIR}/${PN}-xfslib.patch"
+ cd ${S}
+}
+
+src_compile()
+{
+ local myconf
+ myconf="${myconf} --enable-extfs --enable-ncursesw --enable-fs-test"
+ use xfs && myconf="${myconf} --enable-xfs"
+ use reiserfs && myconf="${myconf} --enable-reiserfs"
+ use reiser4 && myconf="${myconf} --enable-reiser4"
+ use hfs && myconf="${myconf} --enable-hfsp"
+ use fat && myconf="${myconf} --enable-fat --enable-exfat"
+ use ntfs && myconf="${myconf} --enable-ntfs"
+ use minix && myconf="${myconf} --enable-minix"
+ use jfs && myconf="${myconf} --enable-jfs"
+ use btrfs && myconf="${myconf} --enable-btrfs"
+ use vmfs && myconf="${myconf} --enable-vmfs"
+ use f2fs && myconf="${myconf} --enable-f2fs"
+ use nilfs2 && myconf="${myconf} --enable-nilfs2"
+ use static && myconf="${myconf} --enable-static"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install()
+{
+ #emake install || die "make install failed"
+ #emake DIST_ROOT="${D}" install || die "make install failed"
+ cd ${S}/src
+ dosbin partclone.dd partclone.restore partclone.chkimg partclone.info partclone.imager
+ dosbin partclone.extfs
+ dosym /usr/sbin/partclone.extfs /usr/sbin/partclone.ext4
+ dosym /usr/sbin/partclone.extfs /usr/sbin/partclone.ext4dev
+ use xfs && dosbin partclone.xfs
+ use reiserfs && dosbin partclone.reiserfs
+ use reiser4 && dosbin partclone.reiser4
+ use hfs && dosbin partclone.hfsp
+ use fat && (dosbin partclone.fat
+ dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat12
+ dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat16
+ dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat32)
+ use ntfs && dosbin partclone.ntfs
+ use ntfs && (dosbin partclone.ntfsfixboot
+ dosym /usr/sbin/partclone.ntfsfixboot /usr/sbin/partclone.ntfsreloc)
+ use btrfs && dosbin partclone.btrfs
+ use f2fs && dosbin partclone.f2fs
+ use nilfs2 && dosbin partclone.nilfs2
+}
+
diff --git a/sys-block/partclone/partclone-9999.ebuild b/sys-block/partclone/partclone-9999.ebuild
new file mode 100644
index 0000000..18d7537
--- /dev/null
+++ b/sys-block/partclone/partclone-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils git-2
+
+DESCRIPTION="Back up and restore used-blocks of a partition"
+HOMEPAGE="http://partclone.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/Thomas-Tsai/partclone"
+EGIT_BRANCH="release"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+extfs +fat exfat hfsp jfs +ntfs reiserfs reiser4 ufs xfs f2fs nilfs2 minix vmfs btrfs"
+
+DEPEND="reiserfs? ( sys-fs/progsreiserfs )
+ exfat? ( sys-fs/exfat-utils )
+ ntfs? ( sys-fs/ntfs3g )
+ extfs? ( sys-libs/e2fsprogs-libs )
+ reiser4? ( sys-fs/reiser4progs )
+ reiserfs? ( sys-fs/progsreiserfs )
+ xfs? ( sys-fs/xfsprogs )
+ ufs? ( sys-fs/ufsutils )
+ jfs? ( sys-fs/jfsutils )
+ btrfs? ( sys-fs/btrfs-progs )
+ nilfs2? ( >=sys-fs/nilfs-utils-2.1.5-r1 )
+ f2fs? ( >=sys-libs/e2fsprogs-libs-1.42.13 )"
+ # sys-libs/ncurses[tinfo]
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+my_use_enable() {
+ use $1 && echo --enable-$1
+}
+
+src_prepare() {
+ sed -i '/SUBDIRS/s/tests//' "${S}/Makefile.am" || die
+ sed -i 's/sizeof(badsector_magic)/(strlen(badsector_magic) + 1)/' "${S}/src/partclone.c" || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(my_use_enable extfs)
+ $(my_use_enable fat)
+ $(my_use_enable hfsp)
+ $(my_use_enable jfs)
+ $(my_use_enable ntfs)
+ $(my_use_enable reiserfs)
+ $(my_use_enable reiser4)
+ $(my_use_enable ufs)
+ $(my_use_enable xfs)
+ $(my_use_enable f2fs)
+ $(my_use_enable nilfs2)
+ $(my_use_enable minix)
+ $(my_use_enable vmfs)
+ $(my_use_enable btrfs)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sys-fs/vmfs-tools/Manifest b/sys-fs/vmfs-tools/Manifest
new file mode 100644
index 0000000..9e6806f
--- /dev/null
+++ b/sys-fs/vmfs-tools/Manifest
@@ -0,0 +1 @@
+DIST vmfs-tools-0.2.5.tar.gz 77095 SHA256 d706138fdd5a71895f30765b6116717f6ef55971ffb07d3bee56bd48b4772653 SHA512 9231509d6e370ddc2a270d80e6cdc16caa9e36bcf5ae3680d83dc28a39ca1c4663680a7107e791c5a037c8e3e145e8d518da9863afb52fa4e09b0792acd7a74c WHIRLPOOL 23a9ff1ed1b0ccb4a5b32a63306c5156592058e8a49601214f6717c19085c79feff1e680de5944f024ec879513ff8b5f3560476b583ce31fbe9ec4e630a9b7c6
diff --git a/sys-fs/vmfs-tools/files/vmfs-tools-0.2.5-buildsystem.patch b/sys-fs/vmfs-tools/files/vmfs-tools-0.2.5-buildsystem.patch
new file mode 100644
index 0000000..986979c
--- /dev/null
+++ b/sys-fs/vmfs-tools/files/vmfs-tools-0.2.5-buildsystem.patch
@@ -0,0 +1,43 @@
+--- vmfs-tools-0.2.5/GNUmakefile
++++ vmfs-tools-0.2.5/GNUmakefile
+@@ -55,7 +55,7 @@
+ endef
+ $(foreach subdir,$(strip $(call order_by_requires,$(SUBDIRS))),$(eval $(call subdir_rules,$(subdir))))
+
+-CC := gcc
++CC ?= gcc
+ OPTIMFLAGS := $(if $(filter -O%,$(ENV_CFLAGS)),,-O2)
+ CFLAGS := $(ENV_CFLAGS) $(filter-out $(ENV_CFLAGS),-Wall $(OPTIMFLAGS) -g -D_FILE_OFFSET_BITS=64 $(EXTRA_CFLAGS))
+ CFLAGS += $(if $(HAS_STRNDUP),,-DNO_STRNDUP=1)
+@@ -71,7 +71,7 @@
+
+ EXTRA_DIST := LICENSE README TODO AUTHORS test.img configure
+
+-all: $(BUILD_PROGRAMS) $(wildcard .gitignore) test.img
++all: $(BUILD_PROGRAMS) $(wildcard .gitignore) test.img doc
+
+ ALL_MAKEFILES = $(filter-out config.cache,$(MAKEFILE_LIST)) configure.mk
+
+@@ -84,8 +84,8 @@
+ echo "#endif" >> $@
+
+ $(BUILD_LIBS):
+- ar -r $@ $^
+- ranlib $@
++ $(AR) -r $@ $^
++ $(RANLIB) $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+
+--- vmfs-tools-0.2.5/configure.mk
++++ vmfs-tools-0.2.5/configure.mk
+@@ -10,7 +10,9 @@
+
+ # configure rules really start here
+ $(call PKG_CONFIG_CHK,uuid,-I/usr/include/uuid,-luuid)
++ifneq (,$(WANT_FUSE))
+ $(call PKG_CONFIG_CHK,fuse)
++endif
+ $(call PATH_LOOKUP,asciidoc)
+ $(call PATH_LOOKUP,xsltproc)
+
diff --git a/sys-fs/vmfs-tools/metadata.xml b/sys-fs/vmfs-tools/metadata.xml
new file mode 100644
index 0000000..5aef247
--- /dev/null
+++ b/sys-fs/vmfs-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>root@fs.lmu.de</email>
+</maintainer>
+<use>
+ <flag name="fuse">Enable image mount support via fuse</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-fs/vmfs-tools/vmfs-tools-0.2.5.ebuild b/sys-fs/vmfs-tools/vmfs-tools-0.2.5.ebuild
new file mode 100644
index 0000000..235b941
--- /dev/null
+++ b/sys-fs/vmfs-tools/vmfs-tools-0.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools for vmfs"
+HOMEPAGE="http://glandium.org/projects/vmfs-tools/"
+SRC_URI="http://glandium.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fuse"
+
+RDEPEND="sys-apps/util-linux
+ fuse? ( sys-fs/fuse )"
+
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+ tc-export CC AR RANLIB
+ export NO_STRIP=1
+ export WANT_FUSE=$(usex fuse 1 "")
+}