aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo@tecnico.ulisboa.pt>2016-08-11 19:13:53 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2016-08-11 19:13:53 +0100
commit3850b91d503a85b0a3f25f9448a2fc4e1118022b (patch)
treee705349593c1b2c9a1dbe32d8ec57b8134291ece /app-admin
parentadd mattermost-desktop, but installation not tested yet (diff)
downloadssnb-3850b91d503a85b0a3f25f9448a2fc4e1118022b.tar.gz
ssnb-3850b91d503a85b0a3f25f9448a2fc4e1118022b.tar.bz2
ssnb-3850b91d503a85b0a3f25f9448a2fc4e1118022b.zip
chefdk-omnibus latest version
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/chefdk-omnibus/Manifest2
-rw-r--r--app-admin/chefdk-omnibus/chefdk-omnibus-0.16.28.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/chefdk-omnibus/Manifest b/app-admin/chefdk-omnibus/Manifest
new file mode 100644
index 0000000..6103764
--- /dev/null
+++ b/app-admin/chefdk-omnibus/Manifest
@@ -0,0 +1,2 @@
+DIST chefdk_0.16.28-1_amd64.deb 141448156 SHA256 2126434d87149cc8373d882705b1f538706f2194ef62abed995ff4cc923bd886 SHA512 89787cb17b7e1e0dd99b6248e63d1e7b93ca5ceaf5bce51a44312d99d6db7c3be96aafdaa29236619c7676493750ee046ad0797ca99ed80e5b357b0e1da398ff WHIRLPOOL 4f445541097d35d54e77b8ea643737fb71a108fb2de142e1fdfba3c846669d6c2a20fdf2e2acbeb37db201508dda8c7cab48ef069d3ef619fea41f945b6986a6
+EBUILD chefdk-omnibus-0.16.28.ebuild 986 SHA256 2eee6476fc6b2a59c67b47f316242c82e633b37094d2529e244e901e5ab59636 SHA512 2b3d5677ba6b462346200bdfb62ac48f5fc015ec234f08dbb15df8f191c687d2d1d01d8967e29ac202201ca9dbdbae752d7990ae1d879e70edede8f9c72d16be WHIRLPOOL b1d68ccf24e55b2721b301cc36099c8f73b00bef4041327abb45b3574df2116f16cf97b6c586cac714b0fe766bc601766800c5c5a94cb0b7408ae6a6b81f417f
diff --git a/app-admin/chefdk-omnibus/chefdk-omnibus-0.16.28.ebuild b/app-admin/chefdk-omnibus/chefdk-omnibus-0.16.28.ebuild
new file mode 100644
index 0000000..624bb77
--- /dev/null
+++ b/app-admin/chefdk-omnibus/chefdk-omnibus-0.16.28.ebuild
@@ -0,0 +1,39 @@
+# Blatently stolen from https://github.com/lxmx/gentoo-overlay
+
+EAPI="4"
+
+DESCRIPTION="Omnibus installation of ChefDK"
+HOMEPAGE="http://www.opscode.com/chefdk/install/"
+SRC_URI="https://packages.chef.io/stable/ubuntu/12.04/chefdk_${PV}-1_amd64.deb"
+
+LICENSE="Apache"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A} ./data.tar.gz
+}
+
+src_install() {
+
+ local dest="${D}/opt"
+ mkdir -p "$dest"
+
+ # cleanup .git folders, any idea why they are in the package?
+ find "$dest" -type d -name ".git" | xargs rm -rf
+
+ cp -pR ./opt/* "$dest"
+
+ # link executables
+ binaries="berks chef chef-apply chef-shell chef-solo chef-zero delivery fauxhai foodcritic kitchen knife ohai push-apply pushy-client pushy-service-manager rubocop cookstyle chef-client chef-vault print_execution_environment"
+ for binary in $binaries; do
+ dosym "$dest/chefdk/bin/$binary" "/usr/bin/$binary" || die "Cannot link $binary to /usr/bin"
+ done
+
+}