aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.8.0.ebuild')
-rw-r--r--dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.8.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.8.0.ebuild b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.8.0.ebuild
new file mode 100644
index 0000000..2fcd126
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils versionator
+
+SR="R"
+RNAME="photon"
+
+SRC_BASE="https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/${RNAME}/${SR}/eclipse-java-${RNAME}-${SR}-linux-gtk"
+
+DESCRIPTION="Eclipse SDK"
+HOMEPAGE="http://www.eclipse.org"
+SRC_URI="
+ amd64? ( ${SRC_BASE}-x86_64.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-x86_64-${PV}.tar.gz )
+ x86? ( ${SRC_BASE}.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-${PV}.tar.gz )"
+
+LICENSE="EPL-1.0"
+SLOT="4.7"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jdk-1.8
+ x11-libs/gtk+:2"
+
+S=${WORKDIR}/eclipse
+
+src_install() {
+ local dest=/opt/${PN}-${SLOT}
+
+ insinto ${dest}
+ doins -r features icon.xpm plugins artifacts.xml p2 eclipse.ini configuration dropins
+
+ exeinto ${dest}
+ doexe eclipse
+
+ dohtml -r readme/*
+
+ cp "${FILESDIR}"/eclipserc-bin-${SLOT} "${T}" || die
+ cp "${FILESDIR}"/eclipse-bin-${SLOT} "${T}" || die
+ sed "s@%SLOT%@${SLOT}@" -i "${T}"/eclipse{,rc}-bin-${SLOT} || die
+
+ insinto /etc
+ newins "${T}"/eclipserc-bin-${SLOT} eclipserc-bin-${SLOT}
+
+ newbin "${T}"/eclipse-bin-${SLOT} eclipse-bin-${SLOT}
+ make_desktop_entry "eclipse-bin-${SLOT}" "Eclipse ${PV} (bin)" "${dest}/icon.xpm"
+}