summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2019-01-27 22:17:38 -0500
committerPhilip Miess <Philip_Miess@yahoo.com>2019-01-27 22:17:38 -0500
commit197b67f51eb500b19c8830beffcb2ea0fb6ba913 (patch)
tree93699d35bdf6053335b904dbc8142850407f7087
parentadd obus (diff)
downloadsuperposition-197b67f5.tar.gz
superposition-197b67f5.tar.bz2
superposition-197b67f5.zip
add obus remove build time deps from RDEPENDS
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
-rw-r--r--sys-apps/0install/0install-2.12.3.ebuild29
-rw-r--r--sys-apps/0install/0install-2.13.ebuild31
-rw-r--r--sys-apps/0install/Manifest4
3 files changed, 35 insertions, 29 deletions
diff --git a/sys-apps/0install/0install-2.12.3.ebuild b/sys-apps/0install/0install-2.12.3.ebuild
index dbf4b2a..5698abf 100644
--- a/sys-apps/0install/0install-2.12.3.ebuild
+++ b/sys-apps/0install/0install-2.12.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,23 +11,28 @@ SRC_URI="https://sourceforge.net/projects/zero-install/files/${PN}/${PV}/${P}.ta
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="gtk +ocamlopt test"
+IUSE="gtk +ocamlopt test +dbus"
-DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
- dev-ml/cppo[ocamlopt?]
+COMMEN_DEPEND="<dev-lang/ocaml-4.07[ocamlopt?]
+ <dev-ml/lwt-4.0.0[ocamlopt?]
dev-ml/lwt_react[ocamlopt?]
- dev-ml/ocamlbuild[ocamlopt?]
>=dev-ml/ocurl-0.7.9
- dev-ml/ounit[ocamlopt?]
>=dev-ml/ocaml-sha-1.9
dev-ml/xmlm
dev-ml/yojson
gtk? ( dev-ml/lablgtk[ocamlopt?]
- dev-ml/lwt_glib[ocamlopt?] )"
- #dbus? ( obus[ocamlopt?] )"
-RDEPEND="${DEPEND}
- app-crypt/gnupg
- app-arch/xz-utils"
+ dev-ml/lwt_glib[ocamlopt?] )
+ dbus? ( dev-ml/obus[ocamlopt?] )"
+DEPEND="${COMMEN_DEPEND}
+ dev-ml/cppo[ocamlopt?]
+ dev-ml/ocamlbuild[ocamlopt?]
+ test? ( dev-ml/ounit[ocamlopt?] )"
+RDEPEND="${COMMEN_DEPEND}
+ app-crypt/gnupg
+ app-arch/xz-utils"
+
+# Disable test phase when test USE flag is disabled
+RESTRICT="!test? ( test )"
src_compile() {
emake -j1 all
@@ -38,7 +43,6 @@ src_test() {
}
src_install() {
-
emake DESTDIR="${D}" install_system
rm -rf "${D}/usr/share/0install.net"
einstalldocs
@@ -53,4 +57,3 @@ pkg_postrm()
{
gnome2_icon_cache_update
}
-
diff --git a/sys-apps/0install/0install-2.13.ebuild b/sys-apps/0install/0install-2.13.ebuild
index 058c226..88f9a00 100644
--- a/sys-apps/0install/0install-2.13.ebuild
+++ b/sys-apps/0install/0install-2.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,23 +11,28 @@ SRC_URI="https://sourceforge.net/projects/zero-install/files/${PN}/${PV}/${P}.ta
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="gtk +ocamlopt test"
+IUSE="gtk +ocamlopt test +dbus"
-DEPEND=">=dev-lang/ocaml-4.06[ocamlopt?]
- dev-ml/cppo[ocamlopt?]
+COMMEN_DEPEND=">=dev-lang/ocaml-4.03.0[ocamlopt?]
dev-ml/lwt_react[ocamlopt?]
- dev-ml/ocamlbuild[ocamlopt?]
>=dev-ml/ocurl-0.7.9
- dev-ml/ounit[ocamlopt?]
>=dev-ml/ocaml-sha-1.9
dev-ml/xmlm
dev-ml/yojson
- gtk? ( >=dev-ml/lablgtk-2.18.2[ocamlopt?]
- dev-ml/lwt_glib[ocamlopt?] )"
- #dbus? ( obus[ocamlopt?] )"
-RDEPEND="${DEPEND}
- app-crypt/gnupg
- app-arch/xz-utils"
+ gtk? ( >=dev-ml/lablgtk-2.18.2[ocamlopt?]
+ dev-ml/lwt_glib[ocamlopt?] )
+ dbus? ( dev-ml/obus[ocamlopt?] )"
+DEPEND="${COMMEN_DEPEND}
+ dev-ml/cppo[ocamlopt?]
+ dev-ml/ocamlbuild[ocamlopt?]
+ test? ( dev-ml/ounit[ocamlopt?] )"
+RDEPEND="${COMMEN_DEPEND}
+ app-crypt/gnupg
+ app-arch/xz-utils"
+
+# Disable test phase when test USE flag is disabled
+RESTRICT="!test? ( test )"
+
src_compile() {
emake -j1 all
@@ -38,7 +43,6 @@ src_test() {
}
src_install() {
-
emake DESTDIR="${D}" install_system
rm -rf "${D}/usr/share/0install.net"
einstalldocs
@@ -53,4 +57,3 @@ pkg_postrm()
{
gnome2_icon_cache_update
}
-
diff --git a/sys-apps/0install/Manifest b/sys-apps/0install/Manifest
index 64a2c92..0f08da5 100644
--- a/sys-apps/0install/Manifest
+++ b/sys-apps/0install/Manifest
@@ -5,7 +5,7 @@ DIST 0install-2.12.3.tar.bz2 445327 BLAKE2B f469aa2a2193f62f42de2595fe505c0df3f2
DIST 0install-2.13.tar.bz2 446022 BLAKE2B d5315b3c50fd6abe950efc2f943aa89c28aa4fe1050b858a197a3344a31af0b9cfb9de789d5431d480a2403bcc424a1eec001578ff7da27279264c92d139db38 SHA512 6f650de62b92597500c4439032076d1a0da621eaf0232dcce2576656889da70d529aef500a67edc13cc0d7f8ad10b1f65ea9483a42f7bdcbeda37c53a4115e8f
DIST 0install-2.3.5.tar.bz2 466037 BLAKE2B 5f80ca0b48e67274d741e08a1e80960295359d542f927608ea64991a8071224228146c31f7a7b671dd0e2fb8b00a6dc9ea3861f4de47df603b7485f712c090f3 SHA512 38ca8d1f51cdc671e076bf873ba6731110bdb06830d6d5bc2727e1bc5f390ce183359ed3347a64bee2cf6fab00a159ba7dd8ca989101584a7ccfb3d7670c4e8f
EBUILD 0install-1.16.ebuild 1220 BLAKE2B 01c7642eca89f38f6f243ee33410cf143707846649124d9926b54219770a449e860b53507e837fd5fcc776dd72f5af3924a9091208eb021a72b71f2231e717ca SHA512 ab294e8c9cd48a40ac1055cc29813121bd4ac30d714a65f7b82b268d92e6dde0f2f5b0ffc4a65f2aadff0b4210605c1e5ae977f7d402b2d5e94262d67eabc7a1
-EBUILD 0install-2.12.3.ebuild 1072 BLAKE2B c9619133c8c6862342aac106869d1d7ce96ca8a4221b66aadb1d364589cf0f22f7f67de3fb96cb0a8a53c4faec0010657824c2be6d4c26cd7c2d11d7ec136657 SHA512 7021216b44b3b9ab3a749870044f3a608324ef411bc7451fb5f67ffadece56dffaba0dade90e2d88be3b959a9295a674e55fec9fdd62d702af31cec3a66fae5c
-EBUILD 0install-2.13.ebuild 1080 BLAKE2B 91748d614d697c14cc9022dff8de43c8ec6cd88ccb50caad81f63ac3066959ee66515e2e6b8b5c19b7e94890422013d77071cda07209f75b3216dd0761d50823 SHA512 d7799ebfedcbeaba63e0239d839da44d177511ced642e688f18c9960a3551690fb7e24823ccd862a3be5263894da6e3dadf6c7809f483938c82cebee36dd3f6a
+EBUILD 0install-2.12.3.ebuild 1240 BLAKE2B 3cb24cb292ad3803945ec6a54725d1af5ac0b93a76a6a0cbb26d3f1ce19a7e2b3811379d988b404c7011183e70eb0fe1e57c563bfec318de40a501fefa14908f SHA512 940f6ed4e6740bbb300008e22e66ff116d8659e93a93310184426b8c0cfa95fdffecc6d95f214c45b60b421fb3d314317c289f7cbcf0ec7648a2c4baf67c6f75
+EBUILD 0install-2.13.ebuild 1224 BLAKE2B 8f783da6990d374785fa1f397b375fdd3532d0404073ea70c3eae54e236b12e46d83917d43c2e4ad117f06bad84ce55b4223f3a37caf002f64338e6ed0b0c050 SHA512 b15999edf56a9980b4f2822f0e0e4b9dc5a9daa32e06111da49bb98cfd80eea144fd54f3863d8a4942153e13452b94e12700e8dc94cb95026341bdbc2ddf0418
EBUILD 0install-2.3.5.ebuild 1222 BLAKE2B 24983c13fa184c252f76e21f3255ccc56b8a4ab7b08b4c768976f711583bc800357be8ede1dd683594e0ab2f6adf85f3544be3b0214a60c424f949b4b22b1dbd SHA512 f9b5e8e99608689bb58485cd22f9ac0b7f81e51af8b8d06dc7b78fe55350df3fa3cb12d3c16090a5d45a3c18df4aea15b47a07854c36170c9941bad448e9c6f2
MISC metadata.xml 285 BLAKE2B 7665ca7b22bf0c8b2e486a5633130588ea83952d863912d0e8299707ed6d26dd66e40e1faa53173eb24079d4607cb783c9e0f6dce8f298607e5baf1ec5f1e587 SHA512 a8207edb781bc25e9bdc7f074ae3164ea9037077c6f6e0284474d033d57ceb188c3e1e9a77a0bbc9c7cac538a75ba23c42993340bd6555b0a71085d43c3f905d