summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2018-06-10 23:09:31 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2018-06-10 23:09:31 -0400
commita73b29b1046093e0ecb82ca4338018c3d7c2d50e (patch)
tree2712130c39182ddbcdff78ccbc09859b1e148b27
parentadd xdg-utils (diff)
downloadsuperposition-a73b29b1.tar.gz
superposition-a73b29b1.tar.bz2
superposition-a73b29b1.zip
add infinifactory
-rw-r--r--games-puzzle/infinifactory/infinifactory-1.ebuild70
-rw-r--r--games-puzzle/infinifactory/metadata.xml15
2 files changed, 85 insertions, 0 deletions
diff --git a/games-puzzle/infinifactory/infinifactory-1.ebuild b/games-puzzle/infinifactory/infinifactory-1.ebuild
new file mode 100644
index 0000000..c15cbe9
--- /dev/null
+++ b/games-puzzle/infinifactory/infinifactory-1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit unpacker eutils
+
+DESCRIPTION="Build factories that assemble products for your alien overlords, and don't die."
+HOMEPAGE="http://www.zachtronics.com/infinifactory/"
+SRC_URI="infinifactory_linux.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist fetch"
+
+MYGAMEDIR=/opt/${PN}
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ dev-libs/expat
+ dev-libs/libbsd
+ media-libs/mesa
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxshmfence
+"
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local arch=x86
+ use amd64 && arch=x86_64
+
+ insinto ${MYGAMEDIR}
+ exeinto ${MYGAMEDIR}
+ newexe "${PN}.${arch}" "${PN}"
+ doins -r infinifactory_Data
+ dodoc CREDITS.txt LICENSE.txt
+
+ newicon -s 128 infinifactory_Data/Resources/UnityPlayer.png ${PN}.png
+ make_wrapper ${PN} "./${PN}" "${MYGAMEDIR}"
+ make_desktop_entry "${PN}" "Infinifacory" "${PN}" "Game"
+
+ domenu ${PN}
+
+}
diff --git a/games-puzzle/infinifactory/metadata.xml b/games-puzzle/infinifactory/metadata.xml
new file mode 100644
index 0000000..52de5c3
--- /dev/null
+++ b/games-puzzle/infinifactory/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@yahoo.com</email>
+</maintainer>
+<longdescription lang="en">
+Infinifactory is a sandbox puzzle game by Zachtronics, the creators of SpaceChem and Infiniminer. Build factories that assemble products for your alien overlords, and try not to die in the process.
+
+ LIKE SPACECHEM… IN 3D! - Design and run factories in a first-person, fully 3D environment.
+ HISTOGRAMS ARE BACK! - Optimize your solutions, and then optimize them more when you see how much better your friends did.
+ VISIT EXOTIC ALIEN LOCALES! - Explore a story-driven campaign with 50+ puzzles, audio logs, and more.
+ BLOCKS THAT MOVE! - Go beyond the campaign and push the limits of Infinifactory’s next-generation block engine in the sandbox.
+</longdescription>
+</pkgmetadata>