summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-08-11 19:07:16 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-08-11 19:07:16 -0400
commitc1887fe72882d67995ed524a23b67c406ba03a0b (patch)
treeb8d6f11a288983daba071085857a608d0e017b14
parentblank lines leading or trailing spaces (diff)
downloadsuperposition-c1887fe7.tar.gz
superposition-c1887fe7.tar.bz2
superposition-c1887fe7.zip
shipper erbuild
-rw-r--r--dev-python/shipper/Manifest4
-rw-r--r--dev-python/shipper/metadata.xml19
-rw-r--r--dev-python/shipper/shipper-1.12.ebuild24
-rw-r--r--dev-python/shipper/test.py12
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/shipper/Manifest b/dev-python/shipper/Manifest
new file mode 100644
index 0000000..dc0eea0
--- /dev/null
+++ b/dev-python/shipper/Manifest
@@ -0,0 +1,4 @@
+DIST shipper-1.12.tar.gz 44495 SHA256 35fe43013e1220723d9e2b42c38cd115440a60103392417b2689364581a58343 SHA512 162e1f6c683e3bb6d162c9fdca2169fc9c21006e03204a4fcd84e2ed2151573485fdcb498b8ba644138f288e476eef25f9039be064ed0d61ab2230e42f9c31c9 WHIRLPOOL 5f5f412cbe0426b4a8348dc7f527bba617b8860302394b0b5613793c7261500d4fa2ad0d57ce9a1b7cbbbfbc1d31a57b21426671bdb86368a9c10525c2f5bd8b
+EBUILD shipper-1.12.ebuild 672 SHA256 0cea8563cb5076d6eefdaee83f511a6e990b3793430703f777e9039a8127cd92 SHA512 749333e204d5149d24bd8925ada995f16002ee1545dfb9905aba0d98a357ea0dd3b10d8845209a0484b1dd2bf57cd9f0907308c2d4433d553fcfec556f90de45 WHIRLPOOL 0e3789accff98dde66441b6f1732db3ad4baaf6e4de1ee81d4a35fa79ff1dd5156a6a3bf9f538b89d4521de287e4005d6ca2a95ddc4d7814c025ff954b5c957e
+MISC metadata.xml 1129 SHA256 dc5365173b2e9121bc446e663342a8fe92e9c1fb4ac1359a8c16843383c3d617 SHA512 257bf4baa019faf485c43342b1f34e596b08bbe652fd5c9e1efcf6a4d447211af5bde906c82f52cdf284dc002c039232c523d7b3f52e581dca78111105bb324b WHIRLPOOL 431005d182862d05c3d76c86665d60254fce2def764ec2138db990958cbaf3bdef27e5e4fa8c8c7f157f43c1d0dc631ce5be80ffddeb3489d491b1188b6da96f
+MISC test.py 309 SHA256 c2066d5b472c1f7edc4f4e80dd7dd61a577f9072bb40c6d6891048146e0e4a61 SHA512 a9d52a6e1f8f8c4baf29453e36bae485a953eb8318184751a9c434ac713623049ebfa40ebf1311be89186262b3fa78157b101de654f1780e0d83d468374d4c87 WHIRLPOOL ffcb9df383dbfae179c1558378f1affe24b9b60a2852a782d6b7f835a233c2ea61c757e1129810aa9771997bd514f08ec44e725a5cb62daadc7be3aeb7eb2111
diff --git a/dev-python/shipper/metadata.xml b/dev-python/shipper/metadata.xml
new file mode 100644
index 0000000..7ac538c
--- /dev/null
+++ b/dev-python/shipper/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@yahoo.com</email>
+</maintainer>
+<longdescription lang="en">
+shipper is a power distribution tool for developers with multiple projects who do frequent releases. It automates the tedious process of shipping a software release and (if desired) templating a project web page. It can deliver releases in correct form to SourceForge, Berlios, and Savannah, and knows how to post a release announcement via freecode-submit.
+</longdescription>
+<use>
+ <flag name="lftp">Install <pkg>net-ftp/lftp</pkg> for shipping to ftp sites.</flag>
+ <flag name="email">For shipping email announcements. Either classic
+<pkg>mail-mta/sendmail</pkg> or <pkg>mail-mta/postfix</pkg> sendmail will work. All it has to be able to do
+is ship mail presented on standard input to a list of addresses
+specified as arguments.</flag>
+ <flag name="scp">Install <pkg>virtual/ssh</pkg>For shipping to websites. There are several different
+implementations of scp</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-python/shipper/shipper-1.12.ebuild b/dev-python/shipper/shipper-1.12.ebuild
new file mode 100644
index 0000000..eb6a7ee
--- /dev/null
+++ b/dev-python/shipper/shipper-1.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Automated shipping of open-source project releases."
+HOMEPAGE="http://www.catb.org/~esr/shipper/"
+SRC_URI="http://www.catb.org/~esr/shipper/${PF}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lftp email scp"
+# todo add freecode-submit and irkerd
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ lftp? ( net-ftp/lftp )
+ email? ( || ( mail-mta/sendmail mail-mta/postfix ) )
+ scp? ( virtual/ssh )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/dev-python/shipper/test.py b/dev-python/shipper/test.py
new file mode 100644
index 0000000..61c736b
--- /dev/null
+++ b/dev-python/shipper/test.py
@@ -0,0 +1,12 @@
+#!/usr/bin/env python
+#
+# shipper -- a tool for shipping software
+#
+# SPDX-License-Identifier: BSD-2-Clause
+#
+# Runs under both Python 2 and Python 3. Preserve this property!
+# from __future__ import print_function
+
+import sys, os, re, subprocess, time, glob, optparse, stat, email.utils, cgi, copy
+
+