summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-10-15 21:49:31 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-10-15 21:49:31 -0400
commitdc4f1dc56ca25a8623cb43bfcaf25c4bfdf31198 (patch)
tree1f1d01dcf4df33a01fd6c296571132a5a5eb2e5f
parentfix patch to call java not ijava (diff)
downloadsuperposition-dc4f1dc5.tar.gz
superposition-dc4f1dc5.tar.bz2
superposition-dc4f1dc5.zip
ultratron
-rw-r--r--games-action/ultratron/Manifest4
-rw-r--r--games-action/ultratron/files/20151219-launcher.patch54
-rw-r--r--games-action/ultratron/metadata.xml22
-rw-r--r--games-action/ultratron/ultratron-20151219.ebuild65
4 files changed, 145 insertions, 0 deletions
diff --git a/games-action/ultratron/Manifest b/games-action/ultratron/Manifest
new file mode 100644
index 0000000..8b6ee26
--- /dev/null
+++ b/games-action/ultratron/Manifest
@@ -0,0 +1,4 @@
+AUX 20151219-launcher.patch 1406 SHA256 9aadd448a16946547ed3e40f8d59c617e120223bda56ffc6bbc681939237170a SHA512 01b4a3dfb980bcd715a2b7ee0da061dad7a2407e15070ff20ce8701e18954fb19ddffda43491aef6c01aef14eff549a97464294c239d0455d8a4ae467f86bb28 WHIRLPOOL 18fad453740c011ca9354f71215cbd78c5acb3fe54de07e22f9367f05eec30823313917cc4b9f360e8341ec235ed4fbdc1a6689a6f5048c6854dfb1921cf26e7
+DIST Ultratron-HIB-20151219.tar.gz 88992216 SHA256 133945642ad0fb4a75eb6dac5f452485b8b53a960b445b4065914a6b9156b496 SHA512 8dd369060c539401ae33b760a0168c3e3ac54f62e36e770e6b8f57cfc980ff3cf9f0ca80361e8ad50d520901317059ab3347efe718fedcb7f327610ad37bb8bb WHIRLPOOL ff9704daed989036fcfb2dcd8ebd83415a03050576b3f0f492f49f06507c32542d17f2c9a69790939ff50bedd90362d81e51ca734d81e3af1aa6324452ada130
+EBUILD ultratron-20151219.ebuild 1284 SHA256 ef18ae7d45f00549fc1cb4807ca483c54427914279111094e24e61ed67265b6a SHA512 ea2a0c73f71918ce94efaf2c25e6ccf06be4ecd7d55dc84aaccf1e10aa565610424db8d7d63077ffc270cae32cb761dec06f22d0dd2fa3cb6a08a3b4e5fef568 WHIRLPOOL 104d7a28c2c411418d439a362fa91db8621714d7572906923d48e9b297740871c0bb0fe78f79a2715ce58186dc76874fdd46df13ac9c850eac262134df1aea46
+MISC metadata.xml 1308 SHA256 9ed76ba991a14e12d737453e31353847a6d1c0932ad5feb34da9661a76004931 SHA512 f3375b63c802a5d4404753be6822c4dd3eb830ef641f3485dac1038c6ebbbc2ebc06adb8b943fba31c7d668ae5e3088c3bb28981b9d89c0862bfcf346f045bcd WHIRLPOOL 12906803e0a96901eb2d025fea70beffeb8f172efa06d797417188725271795a863987c70efced566bde919567cfee7191d16649112e8b34ad450725f350ef14
diff --git a/games-action/ultratron/files/20151219-launcher.patch b/games-action/ultratron/files/20151219-launcher.patch
new file mode 100644
index 0000000..5a4d576
--- /dev/null
+++ b/games-action/ultratron/files/20151219-launcher.patch
@@ -0,0 +1,54 @@
+--- ultron.sh 2015-12-18 19:14:42.000000000 -0500
++++ ultron.patched.sh 2017-10-15 21:11:37.372845150 -0400
+@@ -7,47 +7,15 @@
+ SCRIPT="`basename \"$0\"`"
+ GAMEDIR="${HOME}/.ultratron"
+ LOGFILE="${GAMEDIR}/${SCRIPT}.log"
+-INSTDIR="`dirname \"$0\"`" ; cd "${INSTDIR}" ; INSTDIR="`pwd`"
+-
++INSTDIR="/opt/ultratron-20151219"
++cd "${INSTDIR}"
+ [[ ! -d "${GAMEDIR}" ]] && mkdir -m 0755 "${GAMEDIR}"
+
+-if [ 1 == 0 ]
+-then
+- # 32 bit only
+- JVM="./bin/java32"
+- BOOTCLASSPATH="./lib/rt32.jar"
+-
+-elif [ `uname -m` == "i686" ]
+-then
+- JVM="./bin/java32"
+- BOOTCLASSPATH="./lib/rt32.jar"
+-
+- # Decompress JVM on first run
+- if [ ! -d "bin" ]
+- then
+- ./7za_i386 x jvm.7z
+- chmod u+x bin/java32
+- rm -f 7za_* jvm.7z
+- fi
+-else
+- JVM="./bin/java64"
+- BOOTCLASSPATH="./lib/rt64.jar"
+-
+- # Decompress JVM on first run
+- if [ ! -d "bin" ]
+- then
+- ./7za_amd64 x jvm.7z
+- chmod u+x bin/java64
+- rm -f 7za_* jvm.7z
+- fi
+-fi
+-
+ # XMODIFIERS is cleared here to prevent SCIM screwing up keyboard input
+-_JAVA_OPTIONS= XMODIFIERS= "${JVM}" \
++_JAVA_OPTIONS= XMODIFIERS= "java" \
+ -server \
+- -Xbootclasspath/p:${BOOTCLASSPATH} \
+ -Djava.library.path="${INSTDIR}" \
+- -Dorg.lwjgl.librarypath="${INSTDIR}" \
++ -Dorg.lwjgl.librarypath="/usr/lib64/lwjgl-2.9" \
+ -Dorg.lwjgl.util.NoChecks=false \
+ -Djava.net.preferIPv4Stack=true \
+ -Dnet.puppygames.applet.Launcher.resources=resources-hib.dat \
diff --git a/games-action/ultratron/metadata.xml b/games-action/ultratron/metadata.xml
new file mode 100644
index 0000000..006bdda
--- /dev/null
+++ b/games-action/ultratron/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@yahoo.com</email>
+<name>Philip Miess</name>
+</maintainer>
+<longdescription lang="en">
+Enter the world of Ultratron and experience the addictive gameplay of old-school arcade favourites such as Robotron: 2084, updated and improved for the 21st century!
+
+Unique retro-futuristic sound and graphics, player responsive difficulty, and a subtle system of tactics combined with classic gameplay make Ultratron a fun and hypnotic arcade blast.
+
+The last human has been slain by evil killer robots. You are the one remaining humanoid battle droid. Your mission: avenge the human race!
+
+Blast your way through 40+ glowing neon levels, avoiding Chasers, Turrets, Spawners, Minelayers, bombs, and bullets, and take on the four giant boss 'bots of the Apocalypse - Ieiunitas, Bellum, Lues and Letum!
+Classic old-school arcade arena action!
+
+Boost your battledroid with ever more powerful weaponry, destroy Spiderbots to gain extra special weapon abilities and field defence and pet drones to help you along.
+
+Think you've got what it takes to be the best? Compete on the online hiscores table for the ultimate glory!
+</longdescription>
+</pkgmetadata>
diff --git a/games-action/ultratron/ultratron-20151219.ebuild b/games-action/ultratron/ultratron-20151219.ebuild
new file mode 100644
index 0000000..d4fda78
--- /dev/null
+++ b/games-action/ultratron/ultratron-20151219.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Destroy the robots Avenge the Human Race!"
+HOMEPAGE="http://www.puppygames.net/ultratron"
+SRC_URI="Ultratron-HIB-20151219.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jre-1.7:*
+ virtual/opengl
+ media-libs/openal
+ dev-java/gson:2.2.2
+ dev-java/lwjgl:2.9"
+RDEPEND="${DEPEND}"
+
+RESTRICT="bindist fetch mirror strip"
+S="${WORKDIR}/ultratron"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI}"
+ einfo "from your personal page in Humble Bundle site"
+ einfo "(http://www.humblebundle.com) and place it in ${DISTDIR}"
+}
+
+JAVA_RM_FILES=(
+ gson.jar
+ lwjgl.jar
+ lwjgl_util.jar
+ libjinput-linux.so
+ libjinput-linux64.so
+ liblwjgl.so
+ liblwjgl64.so
+ 7za_amd64
+ 7za_i386
+ jvm.7z
+)
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-launcher.patch"
+ default
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ java-pkg_jarinto "${dir}"
+ java-pkg_dojar *.jar
+
+ java-pkg_sointo "${dir}"
+ java-pkg_doso libgdx.so libgdx64.so
+
+ exeinto "${dir}"
+ doexe ultratron.sh || die "doexe"
+
+ make_wrapper ${PN} ./ulttraron.sh "${dir}" "${dir}"
+ doicon ultron.png
+ make_desktop_entry ${PN} "Ultratron" ultratron Game
+}