summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'loongson.txt')
-rw-r--r--loongson.txt111
1 files changed, 109 insertions, 2 deletions
diff --git a/loongson.txt b/loongson.txt
index 6aac6dc4934e..4b30bb7f69da 100644
--- a/loongson.txt
+++ b/loongson.txt
@@ -20,9 +20,116 @@ pkgcore 0.12.20
$ pmaint --config /var/lib/repo-mirror-ci/data-sync/etc/portage sync loongson
WARNING:pkgcore:flussence repo at '/var/lib/repo-mirror-ci/sync/flussence', doesn't specify masters in metadata/layout.conf. Please explicitly set masters (use "masters =" if the repo is standalone).
-WARNING:pkgcore:lanodanOverlay repo at '/var/lib/repo-mirror-ci/sync/lanodanOverlay', doesn't specify masters in metadata/layout.conf. Please explicitly set masters (use "masters =" if the repo is standalone).
*** syncing loongson
-Already up to date.
+From https://github.com/xen0n/loongson-overlay
+ a979f5d..f25d50a master -> origin/master
+Updating a979f5d..f25d50a
+Fast-forward
+ dev-lang/go/Manifest | 1 +
+ dev-lang/go/files/go-sets.conf | 7 +
+ ...-RDTIME-L-H-.W-RDTIME.D-support-for-loong.patch | 859 +++++
+ ...-improve-logical-shift-with-MASKEQZ-on-lo.patch | 1291 ++++++++
+ ...ompile-optimize-multiplication-on-loong64.patch | 762 +++++
+ ...lement-cputicks-with-the-stable-counter-o.patch | 74 +
+ ...l-obj-loong64-remove-invalid-branch-delay.patch | 37 +
+ ...ime-refactor-the-linux-loong64-entrypoint.patch | 48 +
+ ...k-morestack_noctxt-SPWRITE-for-linux-loon.patch | 44 +
+ ...-internal-runtime-use-NOOP-for-hardware-N.patch | 62 +
+ ...ternal-loong64-use-BREAK-0-as-the-code-pa.patch | 42 +
+ ...l-obj-loong64-add-the-PCALAU12I-instructi.patch | 75 +
+ ...ove-the-fake-mstart-caller-in-systemstack.patch | 43 +
+ ...time-remove-the-RSB-register-from-loong64.patch | 128 +
+ ...l-obj-loong64-add-support-for-movgr2cf-an.patch | 64 +
+ ...l-obj-loong64-realize-all-unconditional-j.patch | 170 +
+ ...e-and-restore-fcc-registers-in-async-pree.patch | 82 +
+ ...l-obj-loong64-clean-up-code-for-short-con.patch | 72 +
+ ...l-obj-loong64-save-LR-after-decrementing-.patch | 55 +
+ ...an-atomic_loong64.s-of-unnecessary-packag.patch | 57 +
+ ...ove-unnecessary-writes-to-gp.sched.g-on-l.patch | 38 +
+ ...e-restore-callee-saved-registers-in-loong.patch | 232 ++
+ ...runtime-add-comment-for-sys_linux_loong64.patch | 253 ++
+ ...l-obj-loong64-assemble-BEQ-BNEs-comparing.patch | 123 +
+ ...l-obj-loong64-remove-Optab.family-and-reo.patch | 796 +++++
+ ...al-obj-remove-redundant-cnames-on-loong64.patch | 40 +
+ ...d-internal-obj-loong64-support-the-PCALIG.patch | 174 +
+ ...tealg-runtime-align-some-loong64-asm-loop.patch | 176 +
+ ...mp-loong64-function-alignment-to-16-bytes.patch | 49 +
+ ...nch.go1.20-cmd-compile-cmd-dist-internal-.patch | 69 +
+ ...l-obj-loong64-cmd-link-internal-switch-to.patch | 334 ++
+ ...-support-for-buildmode-c-shared-on-loong6.patch | 99 +
+ ...l-obj-arm64-improve-comment-and-signature.patch | 75 +
+ ...md-compile-split-DIVV-DIVVU-op-on-loong64.patch | 1039 ++++++
+ ...l-obj-loong64-auto-align-loop-heads-to-16.patch | 197 ++
+ ...nch.go1.20-cmd-internal-obj-loong64-cmd-i.patch | 264 ++
+ ...nch.go1.20-cmd-internal-sys-cmd-dist-misc.patch | 87 +
+ ...nch.go1.20-cmd-dist-internal-enable-build.patch | 40 +
+ ...-add-support-for-loong64-FMA-instructions.patch | 206 ++
+ ...-support-for-the-rest-of-loong64-unary-bi.patch | 275 ++
+ ...dd-support-for-loong64-CRC32-instructions.patch | 129 +
+ ...u-runtime-make-linux-loong64-HWCAP-data-a.patch | 134 +
+ ...optimize-the-loong64-crc32-implementation.patch | 321 ++
+ ...-support-for-loong64-bit-string-instructi.patch | 275 ++
+ ...-single-instruction-forms-for-all-loong64.patch | 220 ++
+ ...nch.go1.20-cmd-compile-wire-up-math-bits..patch | 3474 ++++++++++++++++++++
+ ...nch.go1.20-cmd-compile-implement-FMA-code.patch | 1229 +++++++
+ ...nch.go1.20-cmd-compile-wire-up-math-bits..patch | 490 +++
+ ...nch.go1.20-cmd-compile-wire-up-Bswap-Reve.patch | 210 ++
+ ...-wire-up-bits.Reverse-intrinsics-for-loon.patch | 318 ++
+ dev-lang/go/go-1.20.3.ebuild | 218 ++
+ dev-lang/go/metadata.xml | 17 +
+ 52 files changed, 15574 insertions(+)
+ create mode 100644 dev-lang/go/Manifest
+ create mode 100644 dev-lang/go/files/go-sets.conf
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0001-cmd-asm-add-RDTIME-L-H-.W-RDTIME.D-support-for-loong.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0002-cmd-compile-improve-logical-shift-with-MASKEQZ-on-lo.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0003-cmd-compile-optimize-multiplication-on-loong64.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0004-runtime-implement-cputicks-with-the-stable-counter-o.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0005-cmd-internal-obj-loong64-remove-invalid-branch-delay.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0006-runtime-refactor-the-linux-loong64-entrypoint.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0007-runtime-mark-morestack_noctxt-SPWRITE-for-linux-loon.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0008-cmd-compile-internal-runtime-use-NOOP-for-hardware-N.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0009-cmd-link-internal-loong64-use-BREAK-0-as-the-code-pa.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0010-cmd-internal-obj-loong64-add-the-PCALAU12I-instructi.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0011-runtime-remove-the-fake-mstart-caller-in-systemstack.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0012-cmd-asm-runtime-remove-the-RSB-register-from-loong64.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0013-cmd-internal-obj-loong64-add-support-for-movgr2cf-an.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0014-cmd-internal-obj-loong64-realize-all-unconditional-j.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0015-runtime-save-and-restore-fcc-registers-in-async-pree.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0016-cmd-internal-obj-loong64-clean-up-code-for-short-con.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0017-cmd-internal-obj-loong64-save-LR-after-decrementing-.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0018-runtime-clean-atomic_loong64.s-of-unnecessary-packag.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0019-runtime-remove-unnecessary-writes-to-gp.sched.g-on-l.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0020-runtime-save-restore-callee-saved-registers-in-loong.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0021-runtime-add-comment-for-sys_linux_loong64.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0022-cmd-internal-obj-loong64-assemble-BEQ-BNEs-comparing.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0023-cmd-internal-obj-loong64-remove-Optab.family-and-reo.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0024-cmd-internal-obj-remove-redundant-cnames-on-loong64.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0025-cmd-link-cmd-internal-obj-loong64-support-the-PCALIG.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0026-internal-bytealg-runtime-align-some-loong64-asm-loop.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0027-cmd-link-bump-loong64-function-alignment-to-16-bytes.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0028-release-branch.go1.20-cmd-compile-cmd-dist-internal-.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0029-cmd-internal-obj-loong64-cmd-link-internal-switch-to.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0030-runtime-add-support-for-buildmode-c-shared-on-loong6.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0031-cmd-internal-obj-arm64-improve-comment-and-signature.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0032-cmd-compile-split-DIVV-DIVVU-op-on-loong64.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0033-cmd-internal-obj-loong64-auto-align-loop-heads-to-16.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0034-release-branch.go1.20-cmd-internal-obj-loong64-cmd-i.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0035-release-branch.go1.20-cmd-internal-sys-cmd-dist-misc.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0036-release-branch.go1.20-cmd-dist-internal-enable-build.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0037-cmd-asm-add-support-for-loong64-FMA-instructions.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0038-cmd-asm-add-support-for-the-rest-of-loong64-unary-bi.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0039-cmd-asm-add-support-for-loong64-CRC32-instructions.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0040-internal-cpu-runtime-make-linux-loong64-HWCAP-data-a.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0041-hash-crc32-optimize-the-loong64-crc32-implementation.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0042-cmd-asm-add-support-for-loong64-bit-string-instructi.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0043-cmd-asm-use-single-instruction-forms-for-all-loong64.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0044-release-branch.go1.20-cmd-compile-wire-up-math-bits..patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0045-release-branch.go1.20-cmd-compile-implement-FMA-code.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0046-release-branch.go1.20-cmd-compile-wire-up-math-bits..patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0047-release-branch.go1.20-cmd-compile-wire-up-Bswap-Reve.patch
+ create mode 100644 dev-lang/go/files/testing-1.20.3/0048-cmd-compile-wire-up-bits.Reverse-intrinsics-for-loon.patch
+ create mode 100644 dev-lang/go/go-1.20.3.ebuild
+ create mode 100644 dev-lang/go/metadata.xml
*** synced loongson
* Sync succeeded
$ git log --format=%ci -1