summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-10-12 14:45:40 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-10-12 14:45:40 -0400
commit16039609fa10c396874bb0a13343f05501c63f8a (patch)
tree854353be881f0961e5930f08bb03b34efdd85a99
parentMinor fix: zsdx & zsxd variables quoted (diff)
downloadArmageddon-16039609fa10c396874bb0a13343f05501c63f8a.tar.gz
Armageddon-16039609fa10c396874bb0a13343f05501c63f8a.tar.bz2
Armageddon-16039609fa10c396874bb0a13343f05501c63f8a.zip
SDL USE flag added.
-rw-r--r--games-strategy/curseofwar/curseofwar-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/games-strategy/curseofwar/curseofwar-9999.ebuild b/games-strategy/curseofwar/curseofwar-9999.ebuild
index 7769617..d34e556 100644
--- a/games-strategy/curseofwar/curseofwar-9999.ebuild
+++ b/games-strategy/curseofwar/curseofwar-9999.ebuild
@@ -13,11 +13,12 @@ EGIT_REPO_URI="https://github.com/a-nikolaev/${PN}.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="sdl"
RDEPEND="
app-shells/bash
- sys-libs/ncurses"
+ sys-libs/ncurses
+ sdl? ( media-libs/libsdl )"
DEPEND="${RDEPEND}
sys-devel/gcc"
@@ -27,3 +28,13 @@ src_configure() {
sed -i -e 's/LDFLAGS\ =/LDFLAGS\ \+=/' Makefile || \
die "couldn't patch Makefile LDFLAGS"
}
+
+src_compile() {
+ local myconf=""
+
+ if use sdl; then
+ myconf+="SDL=yes"
+ fi
+
+ emake ${myconf}
+}