summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-16 21:17:01 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-16 21:17:01 -0400
commit1e0876ae272447e135c64693f1a7df162d8c8286 (patch)
tree3caa386cf2a7fd35c0a741e0f1966f83b3dd8d18
parentAdded IUSE to new and live version of udevil... (diff)
downloadArmageddon-1e0876ae272447e135c64693f1a7df162d8c8286.tar.gz
Armageddon-1e0876ae272447e135c64693f1a7df162d8c8286.tar.bz2
Armageddon-1e0876ae272447e135c64693f1a7df162d8c8286.zip
Deleted IUSE and added optional dependencies in elogs...
-rw-r--r--sys-apps/udevil/metadata.xml26
-rw-r--r--sys-apps/udevil/udevil-0.2.8.ebuild31
-rw-r--r--sys-apps/udevil/udevil-9999.ebuild31
3 files changed, 36 insertions, 52 deletions
diff --git a/sys-apps/udevil/metadata.xml b/sys-apps/udevil/metadata.xml
index aa5512f..7d94137 100644
--- a/sys-apps/udevil/metadata.xml
+++ b/sys-apps/udevil/metadata.xml
@@ -6,30 +6,4 @@
<name>Elijah El Lazkani</name>
</maintainer>
<longdescription lang="en">new command line Linux program which mounts and unmounts removable devices without a password, shows device info, and monitors device changes. It can also mount ISO files and nfs://, smb://, and ftp:// URLs.</longdescription>
-
- <use>
- <flag name="zenity">
- Enables devmon popups through <pkg>gnome-extra/zenity</pkg>.
- </flag>
-
- <flag name="samba">
- Enables mounting samba shares (using <pkg>net-fs/cifs-utils</pkg>).
- </flag>
-
- <flag name="ftp">
- Enables mounting ftp shares (using <pkg>net-fs/curlftpfs</pkg>).
- </flag>
-
- <flag name="nfs">
- Enables mounting nfs shares (using <pkg>net-fs/nfs-utils</pkg>).
- </flag>
-
- <flag name="sftp">
- Enables mounting sftp shares (using <pkg>sys-fs/sshfs-fuse</pkg>).
- </flag>
-
- <flag name="eject">
- Enables eject via devmon (using <pkg>virtual/eject</pkg>).
- </flag>
- </use>
</pkgmetadata>
diff --git a/sys-apps/udevil/udevil-0.2.8.ebuild b/sys-apps/udevil/udevil-0.2.8.ebuild
index dfc496a..68a0624 100644
--- a/sys-apps/udevil/udevil-0.2.8.ebuild
+++ b/sys-apps/udevil/udevil-0.2.8.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.ta
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="zenity samba ftp nfs sftp eject"
+IUSE=""
COMMON_DEPEND="
>=app-shells/bash-4.0
@@ -24,13 +24,7 @@ DEPEND="${COMMON_DEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- zenity? ( gnome-extra/zenity )
- samba? ( net-fs/cifs-utils )
- ftp? ( net-fs/curlftpfs )
- nfs? ( net-fs/nfs-utils )
- sftp? ( sys-fs/sshfs-fuse )
- eject? ( virtual/eject )"
+RDEPEND="${COMMON_DEPEND}"
pkg_setup(){
enewgroup plugdev
@@ -58,9 +52,20 @@ pkg_postinst() {
elog "Please add your user to the plugdev group"
elog "to be able to use ${PN} as a user"
elog
- ewarn "If ${PN}'s monitor command does not report"
- ewarn "changes to the devices when CD is inserted,"
- ewarn "make sure you have _kernel polling_ enabled or"
- ewarn "sys-fs/udisks installed on your system."
- ewarn "Reference: http://ignorantguru.github.com/udevil/#polling"
+ elog "Optional dependencies:"
+ elog "gnome-extra/zenity (devmon popups)"
+ elog "net-fs/cifs-utils (mounting samba shares)"
+ elog "net-fs/curlftpfs (mounting ftp shares)"
+ elog "net-fs/nfs-utils (mounting nfs shares)"
+ elog "sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog "virtual/eject (eject via devmon)"
+ einfo
+ if ! has_version 'sys-fs/udisks' ; then
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<sys-fs/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
}
diff --git a/sys-apps/udevil/udevil-9999.ebuild b/sys-apps/udevil/udevil-9999.ebuild
index d43c4c2..985f154 100644
--- a/sys-apps/udevil/udevil-9999.ebuild
+++ b/sys-apps/udevil/udevil-9999.ebuild
@@ -15,7 +15,7 @@ SRC_URI=""
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="zenity samba ftp nfs sftp eject"
+IUSE=""
COMMON_DEPEND="
>=app-shells/bash-4.0
@@ -26,13 +26,7 @@ DEPEND="${COMMON_DEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- zenity? ( gnome-extra/zenity )
- samba? ( net-fs/cifs-utils )
- ftp? ( net-fs/curlftpfs )
- nfs? ( net-fs/nfs-utils )
- sftp? ( sys-fs/sshfs-fuse )
- eject? ( virtual/eject )"
+RDEPEND="${COMMON_DEPEND}"
pkg_setup() {
enewgroup plugdev
@@ -60,9 +54,20 @@ pkg_postinst() {
elog "Please add your user to the plugdev group"
elog "to be able to use ${PN} as a user"
elog
- ewarn "If ${PN}'s monitor command does not report"
- ewarn "changes to the devices when CD is inserted,"
- ewarn "make sure you have _kernel polling_ enabled or"
- ewarn "sys-fs/udisks installed on your system."
- ewarn "Reference: http://ignorantguru.github.com/udevil/#polling"
+ elog "Optional dependencies:"
+ elog "gnome-extra/zenity (devmon popups)"
+ elog "net-fs/cifs-utils (mounting samba shares)"
+ elog "net-fs/curlftpfs (mounting ftp shares)"
+ elog "net-fs/nfs-utils (mounting nfs shares)"
+ elog "sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog "virtual/eject (eject via devmon)"
+ einfo
+ if ! has_version 'sys-fs/udisks' ; then
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<sys-fs/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
}