summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDustin Polke <DuPol@gmx.de>2017-05-21 21:43:00 +0200
committerDustin Polke <DuPol@gmx.de>2017-05-21 21:43:00 +0200
commit3f4d2919af551d1be5d4a9579f7ede52ba4a9d2b (patch)
tree09c7ae6b7ad871b9eb99b6fdf0072e52352a5ec9
parent[x11-plugins/cd-plugins-old] Bump EAPI b/c cmake-utils eclass does not suppor... (diff)
downloadDuPol-3f4d2919af551d1be5d4a9579f7ede52ba4a9d2b.tar.gz
DuPol-3f4d2919af551d1be5d4a9579f7ede52ba4a9d2b.tar.bz2
DuPol-3f4d2919af551d1be5d4a9579f7ede52ba4a9d2b.zip
[x11-plugins/cd-plugins-stable] Bump EAPI b/c cmake-utils eclass does not support EAPI 4 anymore.
-rw-r--r--x11-plugins/cd-plugins-stable/ChangeLog4
-rw-r--r--x11-plugins/cd-plugins-stable/cd-plugins-stable-3.0.1-r1.ebuild (renamed from x11-plugins/cd-plugins-stable/cd-plugins-stable-3.0.1.ebuild)6
2 files changed, 8 insertions, 2 deletions
diff --git a/x11-plugins/cd-plugins-stable/ChangeLog b/x11-plugins/cd-plugins-stable/ChangeLog
index 1761196..2edbdcc 100644
--- a/x11-plugins/cd-plugins-stable/ChangeLog
+++ b/x11-plugins/cd-plugins-stable/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2017 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 21 May 2017; Dustin Polke <DuPol@gmx.de> -cd-plugins-stable-3.0.1.ebuild,
+ +cd-plugins-stable-3.0.1-r1.ebuild:
+ Bump EAPI b/c cmake-utils eclass does not support EAPI 4 anymore.
+
01 Feb 2017; Dustin Polke <DuPol@gmx.de>
-files/cd-plugins-stable-3.0.0-CMakeLists.txt:
Drop old CMakeLists.txt.
diff --git a/x11-plugins/cd-plugins-stable/cd-plugins-stable-3.0.1.ebuild b/x11-plugins/cd-plugins-stable/cd-plugins-stable-3.0.1-r1.ebuild
index 18e3cef..20db09c 100644
--- a/x11-plugins/cd-plugins-stable/cd-plugins-stable-3.0.1.ebuild
+++ b/x11-plugins/cd-plugins-stable/cd-plugins-stable-3.0.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
inherit cmake-utils cairo-dock
@@ -52,6 +52,8 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
+WANT_CMAKE="always"
+
pkg_setup() {
use alsa && CD_PLUGINS+=( "alsaMixer" )
use clipper && CD_PLUGINS+=( "Clipper" )