summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-07-04 12:16:32 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-07-04 12:16:32 +0200
commitb6eb9967cf623938bded44dbb9207b1b0e6fb083 (patch)
treeed6a41af30ddf9ca8396fcd5ec39f76dc26402de /sys-apps
parent+phoronix-test-suite-3.2.1.ebuild (diff)
downloadaluco-b6eb9967cf623938bded44dbb9207b1b0e6fb083.tar.gz
aluco-b6eb9967cf623938bded44dbb9207b1b0e6fb083.tar.bz2
aluco-b6eb9967cf623938bded44dbb9207b1b0e6fb083.zip
fakechroot-2.12-r1.ebuild:
- add hardened use flag. - Fix tests on hardened with a new patch.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fakechroot/Manifest5
-rw-r--r--sys-apps/fakechroot/fakechroot-2.12-r1.ebuild5
-rw-r--r--sys-apps/fakechroot/files/fakechroot-2.12-fix_chroot_test_location.patch (renamed from sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch)2
-rw-r--r--sys-apps/fakechroot/files/fakechroot-2.12-fix_test_hardened.patch23
4 files changed, 31 insertions, 4 deletions
diff --git a/sys-apps/fakechroot/Manifest b/sys-apps/fakechroot/Manifest
index 33338c6..6db7f7f 100644
--- a/sys-apps/fakechroot/Manifest
+++ b/sys-apps/fakechroot/Manifest
@@ -1,3 +1,4 @@
-AUX fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch 3475 RMD160 c74a3df50e2f7a79b7ba4e104b455a865ac83288 SHA1 bed4cdb0ed22c8255789fcdd89fd3211664bf824 SHA256 66520a01af063926aebbb42e923b55201cf014aa5b332365788a49260318f5d4
+AUX fakechroot-2.12-fix_chroot_test_location.patch 3544 RMD160 f3d3a3252e473263c61f259965d32f7bb77f5d41 SHA1 84c264fc629d007e79b8b5097a18c32a6398d011 SHA256 ca09808116801262577b93ec2e864472705d9a9a1223218a8a73b36d700ef895
+AUX fakechroot-2.12-fix_test_hardened.patch 1005 RMD160 349ea7261845711ce0431215723fc2449cb3e0a6 SHA1 96e9a0c37ea6455f0263f6c891afbab9e8a40509 SHA256 eb8099b341675384b95e132bb6fa1be9f42a30994db3be4a9664d71a572a9141
DIST fakechroot_2.12.orig.tar.gz 352298 RMD160 34a8068f360720032c82c6c6635c165da4a7d89b SHA1 b2e32c4de64ba2f2d83f3ac7947f502afbaa1cd9 SHA256 05174cc9caa3ec84cd7515caeafd809a9411e13498f972a617bf3616463b5d2b
-EBUILD fakechroot-2.12-r1.ebuild 807 RMD160 6766fb4e5b718dcaabf9cbe180ff2d63cce6d72e SHA1 7c7b4bc53ca9b7cbc4c6972f621fd2e1d6666171 SHA256 6fcccc731ea51a3812a860284ff00b253204411fc3cabf6300c28591842fbf7e
+EBUILD fakechroot-2.12-r1.ebuild 901 RMD160 75225e45a3c7e2e8a800ad9991bbe4e09e4e9ac2 SHA1 148bcb08b2be157eb44d84afe17e4445567aaa82 SHA256 fa3ea4f85c5a16c63289be1376980210089d45495b43066db683bd8e0bf45b56
diff --git a/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild b/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild
index 596ab7a..fc332d0 100644
--- a/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild
+++ b/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild
@@ -12,10 +12,11 @@ SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_${PV}.orig.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test hardened"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo_fix_chroot_location_in_test.patch
+ use test && epatch "${FILESDIR}"/${P}-fix_chroot_test_location.patch
+ use test && use hardened && epatch "${FILESDIR}"/${P}-fix_test_hardened.patch
}
src_configure() {
diff --git a/sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch b/sys-apps/fakechroot/files/fakechroot-2.12-fix_chroot_test_location.patch
index 6ad2548..ae3f968 100644
--- a/sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch
+++ b/sys-apps/fakechroot/files/fakechroot-2.12-fix_chroot_test_location.patch
@@ -1,3 +1,5 @@
+# Fix the location of chroot in gentoo (/bin instead of /usr/sbin).
+
diff -ur fakechroot-2.12.orig//test/chroot.sh fakechroot-2.12/test/chroot.sh
--- fakechroot-2.12.orig//test/chroot.sh 2011-06-27 22:29:30.780440922 +0200
+++ fakechroot-2.12/test/chroot.sh 2011-06-27 22:29:56.829440999 +0200
diff --git a/sys-apps/fakechroot/files/fakechroot-2.12-fix_test_hardened.patch b/sys-apps/fakechroot/files/fakechroot-2.12-fix_test_hardened.patch
new file mode 100644
index 0000000..f3541a6
--- /dev/null
+++ b/sys-apps/fakechroot/files/fakechroot-2.12-fix_test_hardened.patch
@@ -0,0 +1,23 @@
+# Some escape nested chroot are forbidden with grsecurity therefore hardened.
+# Disable the test that doesn't pass anymore with grsecurity.
+
+diff -ur fakechroot-2.12.orig//test/t/escape-nested-chroot.t fakechroot-2.12/test/t/escape-nested-chroot.t
+--- fakechroot-2.12.orig//test/t/escape-nested-chroot.t 2011-07-04 11:33:03.495441000 +0200
++++ fakechroot-2.12/test/t/escape-nested-chroot.t 2011-07-04 11:33:45.468440998 +0200
+@@ -24,16 +24,6 @@
+ ok "$chroot test-chroot $paths (not escaped):" $t
+ done
+
+- for paths in '. .'; do
+- t=`$srcdir/$chroot.sh testtree /bin/test-chroot / /testtree 'ls -id /' $paths 'ls -id /' 2>&1`
+- f1=`echo $t | awk '{print $1}'`
+- f2=`echo $t | awk '{print $2}'`
+- f3=`echo $t | awk '{print $3}'`
+- f4=`echo $t | awk '{print $4}'`
+- test "$f2" = "/" -a "$f4" = "/" -a "$f1" != "$f3" || not
+- ok "$chroot test-chroot $paths (escaped):" $t
+- done
+-
+ fi
+
+ done