summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/onnxruntime/onnxruntime-1.9.1.ebuild')
-rw-r--r--sci-libs/onnxruntime/onnxruntime-1.9.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/onnxruntime/onnxruntime-1.9.1.ebuild b/sci-libs/onnxruntime/onnxruntime-1.9.1.ebuild
index 2bbde3b..d6d82b3 100644
--- a/sci-libs/onnxruntime/onnxruntime-1.9.1.ebuild
+++ b/sci-libs/onnxruntime/onnxruntime-1.9.1.ebuild
@@ -26,7 +26,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="benchmark test"
+IUSE="benchmark test rocm"
# libonnxruntime_framework.so: undefined reference to `onnx::AttributeProto_AttributeType_Name[abi:cxx11](onnx::AttributeProto_AttributeType)'
RESTRICT="test"
@@ -53,6 +53,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${P}-system_libs.patch"
+ "${FILESDIR}/${P}-get-rocm-version-from-hipconfig.patch"
)
src_unpack() {
@@ -91,6 +92,7 @@ src_configure() {
-Donnxruntime_PREFER_SYSTEM_LIB=ON
-Donnxruntime_BUILD_BENCHMARKS=$(usex benchmark)
-Donnxruntime_BUILD_UNIT_TESTS=$(usex test)
+ -Donnxruntime_USE_ROCM=$(usex rocm)
)
cmake_src_configure