summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-12-21 11:34:27 -0500
committerRussell Harmon <russ@eatnumber1.com>2009-12-21 11:34:27 -0500
commit53351c7e6d13ddcb1c28efa785db36089a34d159 (patch)
tree92e1152d02905e90f70e3ad6917f8b6dc58ad843
parentAdd idea-community (diff)
downloadeatnumber1-53351c7e6d13ddcb1c28efa785db36089a34d159.tar.gz
eatnumber1-53351c7e6d13ddcb1c28efa785db36089a34d159.tar.bz2
eatnumber1-53351c7e6d13ddcb1c28efa785db36089a34d159.zip
Fix idea-community ebuild
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/idea-community-9.0.ebuild10
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index be4746d..fac559b 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,2 @@
-EBUILD idea-community-9.0.ebuild 933 RMD160 54a38fffb8c7a10061ccbb009958e2c4a8e50eb3 SHA1 ee06b2ab640e3f27823196207fc748aba13b332a SHA256 97464bd11b66128c87b90b313450a19588860274bcceed6a1cea8d5b5d5f299d
+EBUILD idea-community-9.0.ebuild 948 RMD160 3d5dc560c384c3cc01d2f917076cca1a4105cddd SHA1 65092741034ab2154c0279ee4fbee8ef9dc99ddd SHA256 3f0adda6e2d1532a57710b6bd6200a441a5577f6fea36f03d23f67956dd28f0e
DIST ideaIC-9.0.tar.gz 68240696 RMD160 f93ff16af7b0732fce918b9b39b550d6b5484a96 SHA1 a95bf688ade2b1d30b26c696bf898f41abdba709 SHA256 b51c4f8b6624f80605717158cf7b4ea07722947868c9965dcd8f21b19c35ba9a
diff --git a/dev-util/idea-community/idea-community-9.0.ebuild b/dev-util/idea-community/idea-community-9.0.ebuild
index 7046393..e109a2f 100644
--- a/dev-util/idea-community/idea-community-9.0.ebuild
+++ b/dev-util/idea-community/idea-community-9.0.ebuild
@@ -19,20 +19,20 @@ SRC_URI="http://download.jetbrains.com/${MY_PN}/${MY_PN}IC-${PV}.tar.gz"
LICENSE="IntelliJ-IDEA"
IUSE=""
KEYWORDS="~x86 ~amd64"
-S="${WORKDIR}/${PN}-IU-${MY_PV}"
+S="${WORKDIR}/${MY_PN}-IC-${MY_PV}"
src_install() {
local dir="/opt/${P}"
insinto "${dir}"
doins -r *
- fperms 755 "${dir}/bin/${PN}.sh"
- local exe=${PN}-${SLOT}
+ fperms 755 "${dir}/bin/${MY_PN}.sh"
+ local exe=${MY_PN}-${SLOT}
local icon=${exe}.png
- newicon "bin/${PN}32.png" ${icon}
+ newicon "bin/${MY_PN}32.png" ${icon}
dodir /usr/bin
cat > "${D}/usr/bin/${exe}" <<-EOF
#!/bin/sh
-/opt/${P}/bin/${PN}.sh \$@
+/opt/${P}/bin/${MY_PN}.sh \$@
EOF
fperms 755 /usr/bin/${exe}
make_desktop_entry ${exe} "IntelliJ IDEA ${PV}" ${icon} "Development;IDE"