summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pydsscc/pydsscc-0.3.0.ebuild')
-rw-r--r--sci-libs/pydsscc/pydsscc-0.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/pydsscc/pydsscc-0.3.0.ebuild b/sci-libs/pydsscc/pydsscc-0.3.0.ebuild
new file mode 100644
index 0000000..c48e543
--- /dev/null
+++ b/sci-libs/pydsscc/pydsscc-0.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.4
+
+inherit distutils eutils
+
+DESCRIPTION="PyDSSCC - Calibration Software for Distributed Smart Stereo
+Cameras"
+HOMEPAGE="http://www.mavrinac.com/research/index.cgi?page=dssccalib"
+SRC_URI="http://www.mavrinac.com/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE="doc"
+
+RDEPEND="virtual/python
+ >=dev-python/numpy-1.0.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/epydoc )"
+
+DOCS="AUTHORS README TODO"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ ./gendoc.sh
+ dohtml -r doc/
+ fi
+}