summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2023-08-11 17:51:14 +0200
committerhaarp <main.haarp@gmail.com>2023-08-11 17:51:14 +0200
commitb3d3f69a919965c73ee095cb86a4cfd8827b0bab (patch)
treea667265c04ad11e5c1a010f6b4c5b79126a4b677
parentUpgrade screenruler to GTK3 version (diff)
downloadhaarp-b3d3f69a919965c73ee095cb86a4cfd8827b0bab.tar.gz
haarp-b3d3f69a919965c73ee095cb86a4cfd8827b0bab.tar.bz2
haarp-b3d3f69a919965c73ee095cb86a4cfd8827b0bab.zip
Add OpenRC daemon to Touchegg
Signed-off-by: haarp <main.haarp@gmail.com>
-rw-r--r--x11-misc/touchegg/Manifest4
-rw-r--r--x11-misc/touchegg/files/touchegg.initd9
-rw-r--r--x11-misc/touchegg/files/touchegg.service13
-rw-r--r--x11-misc/touchegg/touchegg-2.0.16-r1.ebuild (renamed from x11-misc/touchegg/touchegg-2.0.16.ebuild)19
4 files changed, 39 insertions, 6 deletions
diff --git a/x11-misc/touchegg/Manifest b/x11-misc/touchegg/Manifest
index b267d86..e74e54c 100644
--- a/x11-misc/touchegg/Manifest
+++ b/x11-misc/touchegg/Manifest
@@ -1,2 +1,4 @@
+AUX touchegg.initd 273 BLAKE2B 5d6894f3937568094558136f6d0a0a1b375539bacdbaf748f759ce699daed39b145d63fbeada5e88fae88bdd4c723b8aa85d439b509242dfdf8861321e5132f3 SHA512 f97c2804e6f1ba91d83a2c529e95ebc92348c90059d0ceb2287035c5adb6aadcd10350738d0523366b0c425b389973e3ccdd72eb95a20b0d9c2ca6978bbef985
+AUX touchegg.service 266 BLAKE2B e0d7057cc029766dd24dab68bf62439aa4a45759edce300b55e1cf6d2beeaeb8d5b502ede3553e91ac53e54ec446626788b11a4cec27438d21f2160f468ac421 SHA512 4940156efa4dc955e11b1f665ea5aba46512b835e3dd43be5d18f72ec465427203d4e12671521c347077d00f766a662447ef3b1c5e62eb635dd25a56769d469b
DIST touchegg-2.0.16.tar.gz 26826100 BLAKE2B f3f2bc5aebc79f54ae99e3a1d914eed1281c4c48955a848fd4b54f4ab975aecb037b3322f2a6de750454da8a29e71f3aa10b905fe1b8b93ace145d34d5261824 SHA512 92a5409c1f570de2690e57e8ae291bda1c07b5d5c1094fd80a9648c5986f5dc8cd5a8e03c3714a8dc10b5305a75e52a0ef86f5bf52a038db08fedb86620af76f
-EBUILD touchegg-2.0.16.ebuild 1455 BLAKE2B f56d5360af5600bdd781f2d673bd8af1cfb36276a0da986c23a32ca0a46f24cf6ac6efa2a076d853d3bf797b06a77ba0e17ac79a5b5a307d2da41a1f63282312 SHA512 e57388efd7314635a0a7f0c84242a0c86280e78bab72d08eb6576f2fede37b9156b3a47ecdcb4d5cadc3ea4470355a7b0c9e59255a15fc1c7c7b3412e08d6e8f
+EBUILD touchegg-2.0.16-r1.ebuild 1651 BLAKE2B bed5f9122e485fdb33c882c8fdf59aef4bf023306e0be1199b85b9e141f6904beefbfc7ab18fa621856b0ec85d2477bbf21c6f1340d5037d476b7d8aed316cc6 SHA512 38bc2d5e074e6ae66c0c39cdd4f6759eb65a395287e3516666315d8715d12bb241e1cd5874f4bb1452f30faaa1816120c6e4d74a65e47a7bf65fe09eb757cc14
diff --git a/x11-misc/touchegg/files/touchegg.initd b/x11-misc/touchegg/files/touchegg.initd
new file mode 100644
index 0000000..f40da6d
--- /dev/null
+++ b/x11-misc/touchegg/files/touchegg.initd
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command=/usr/bin/touchegg
+command_args="--daemon"
+command_background=yes
+description="Linux multitouch gesture recognizer"
+pidfile=/run/touchegg.pid
diff --git a/x11-misc/touchegg/files/touchegg.service b/x11-misc/touchegg/files/touchegg.service
new file mode 100644
index 0000000..de39200
--- /dev/null
+++ b/x11-misc/touchegg/files/touchegg.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Touchégg Daemon
+Documentation=https://github.com/JoseExposito/touchegg/tree/master/installation#readme
+
+[Service]
+Type=simple
+Group=input
+ExecStart=/usr/bin/touchegg --daemon
+Restart=on-failure
+RestartSec=5s
+
+[Install]
+WantedBy=multi-user.target
diff --git a/x11-misc/touchegg/touchegg-2.0.16.ebuild b/x11-misc/touchegg/touchegg-2.0.16-r1.ebuild
index f95bfbd..ecc88d4 100644
--- a/x11-misc/touchegg/touchegg-2.0.16.ebuild
+++ b/x11-misc/touchegg/touchegg-2.0.16-r1.ebuild
@@ -18,7 +18,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+gtk systemd"
+IUSE="daemon +gtk systemd"
+
+REQUIRED_USE="systemd? ( daemon )"
RDEPEND="
dev-libs/libinput
@@ -53,15 +55,22 @@ src_install() {
cmake_src_install
- use systemd && newinitd "${FILESDIR}"/touchegg.initd touchegg
+ if use daemon; then
+ if use systemd; then
+ systemd_dounit "${FILESDIR}/touchegg.service"
+ else
+ newinitd "${FILESDIR}/touchegg.initd" touchegg
+ fi
+ fi
}
pkg_postinst() {
- if use systemd; then
- elog "On update run: 'systemctl daemon-reload && systemctl restart touchegg'"
+ if use daemon; then
+ elog "On update, don't forget to restart the system daemon and userspace client"
else
- elog "Not using systemd; in addition to 'touchegg', you have to manually"
+ elog "Not using system daemon; in addition to 'touchegg', you have to manually"
elog "run 'touchegg --daemon' as root or an user in the 'input' group"
+ elog "On update, don't forget to restart both"
fi
elog "See https://github.com/JoseExposito/touchegg#configuration for config information"
}