summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2018-08-28 11:06:46 +0200
committerhaarp <main.haarp@gmail.com>2018-08-28 11:06:46 +0200
commiteda2379d19ba4f8f2aeedacf85a38ab7ea6544e7 (patch)
tree61e03d4359d867cc32e5596e09e0a2ffc5c05bec /x11-misc/cvt12/cvt12-9999.ebuild
parentmtview: Don't install under /usr/local (diff)
downloadhaarp-eda2379d19ba4f8f2aeedacf85a38ab7ea6544e7.tar.gz
haarp-eda2379d19ba4f8f2aeedacf85a38ab7ea6544e7.tar.bz2
haarp-eda2379d19ba4f8f2aeedacf85a38ab7ea6544e7.zip
Add cvt12
Diffstat (limited to 'x11-misc/cvt12/cvt12-9999.ebuild')
-rw-r--r--x11-misc/cvt12/cvt12-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/cvt12/cvt12-9999.ebuild b/x11-misc/cvt12/cvt12-9999.ebuild
new file mode 100644
index 0000000..1de4969
--- /dev/null
+++ b/x11-misc/cvt12/cvt12-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="CVT (Coordinated Video Timings) modeline calculator with CVT v1.2 timings"
+HOMEPAGE="https://github.com/kevinlekiller/cvt_modeline_calculator_12"
+EGIT_REPO_URI="https://github.com/kevinlekiller/cvt_modeline_calculator_12.git"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=${RDEPEND}
+
+src_compile() {
+ echo "$(tc-getCC) ${LDFLAGS} ${CFLAGS} -Wall -o cvt12 cvt12.c -lm"
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} -Wall -o cvt12 cvt12.c -lm || die "compile failed"
+}
+
+src_install() {
+ dobin cvt12
+}