summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2022-06-03 15:31:49 +0200
committerhaarp <main.haarp@gmail.com>2022-06-06 16:37:05 +0200
commitc7bf0cf229c2dc4490c9374c62341115745ae1ac (patch)
treea460e5fc54411ea0ec533e46c528cb88ed4c5d91 /x11-misc
parentFix xed python stuff (diff)
downloadhaarp-c7bf0cf229c2dc4490c9374c62341115745ae1ac.tar.gz
haarp-c7bf0cf229c2dc4490c9374c62341115745ae1ac.tar.bz2
haarp-c7bf0cf229c2dc4490c9374c62341115745ae1ac.zip
Add cpptoml and Gebaar (fork)
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/gebaar/Manifest2
-rw-r--r--x11-misc/gebaar/gebaar-0.1.4.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/gebaar/Manifest b/x11-misc/gebaar/Manifest
new file mode 100644
index 0000000..bc6fcce
--- /dev/null
+++ b/x11-misc/gebaar/Manifest
@@ -0,0 +1,2 @@
+DIST gebaar-0.1.4.tar.gz 23972 BLAKE2B 6930211a4c2124ec08b3b8afd8f883a0b18437806137540c9bb493549071765e9461eff65056af35890e4c5c055092e625207b4f4ef9ec8c0fa19921e2a13935 SHA512 a5a01f565962f8d6bd0ea63e405d7050c44ad1b0faf2335bcb122cea1a9fcd3a20928f42a3e6f503a950a603be677b4de25c3573ce20c39c78467d3ac0e18332
+EBUILD gebaar-0.1.4.ebuild 721 BLAKE2B 9b382b4a30bd39230f018b6d5311b60240ccef2dfb77d94645934135d8fc184b16f1a0ce9bb1d01a80acf3ba7214207e0b73b7553323254074031cf4303b0ac7 SHA512 b1ff0233e9f8839f3350a9ae53ee0799311bcaf03da5c90c5090810ad4bcc9e353593afdb52cfbcb4ead24ee5722a759243e67006826c1fbba0991fb683ae2a5
diff --git a/x11-misc/gebaar/gebaar-0.1.4.ebuild b/x11-misc/gebaar/gebaar-0.1.4.ebuild
new file mode 100644
index 0000000..fb51092
--- /dev/null
+++ b/x11-misc/gebaar/gebaar-0.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop
+
+DESCRIPTION="Super Simple WM Independent Touchpad Gesture Daemon for libinput (forked version with new features)"
+HOMEPAGE="https://github.com/osleg/gebaar-libinput-fork"
+SRC_URI="https://github.com/osleg/gebaar-libinput-fork/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/cpptoml
+ dev-libs/cxxopts
+ dev-libs/libinput"
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}/gebaar-libinput-fork-${PV}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_install() {
+ dobin ${S}_build/gebaard
+ dodoc README.md
+ domenu assets/gebaar-libinput.desktop
+}