summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/geth/geth-1.6.7.ebuild')
-rw-r--r--net-p2p/geth/geth-1.6.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/geth/geth-1.6.7.ebuild b/net-p2p/geth/geth-1.6.7.ebuild
new file mode 100644
index 0000000..65088ed
--- /dev/null
+++ b/net-p2p/geth/geth-1.6.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Command line interface for running a full Ethereum node"
+HOMEPAGE="https://www.ethereum.org/"
+SRC_URI="https://github.com/ethereum/go-ethereum/archive/v${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+
+DEPEND="dev-lang/go"
+
+S="${WORKDIR}/go-ethereum-${PV}"
+
+src_compile() {
+ emake geth
+}
+
+src_install() {
+ dobin build/bin/geth
+ dodoc README.md AUTHORS
+}