summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gnome-disk-utility')
-rw-r--r--sys-apps/gnome-disk-utility/Manifest4
-rw-r--r--sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch46
-rw-r--r--sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch35
-rw-r--r--sys-apps/gnome-disk-utility/gnome-disk-utility-3.10.0.ebuild56
4 files changed, 141 insertions, 0 deletions
diff --git a/sys-apps/gnome-disk-utility/Manifest b/sys-apps/gnome-disk-utility/Manifest
new file mode 100644
index 0000000..4cbe78c
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/Manifest
@@ -0,0 +1,4 @@
+AUX gnome-disk-utility-3.10.0-kill-gsd-automagic.patch 1777 SHA256 578670aa845e876f8e0f935a47441af3a45a38abb7f84e8101f5017d7e532872 SHA512 3fd1d865fce3b1c5220ca33247e6291d7a1afe4c2e4715c6f5d5946bca853effa4fd5c28f906df03eb968930e46e3aa358027cf5db3cee880d3945246c5200c3 WHIRLPOOL 40db689e3c03ef30ad34bd2f6b4b3abec972fc40b8b3a855228b394319a44133cad3b079d87251dec1ed38b806d9432125fa7df15012864a10f858194312bd38
+AUX gnome-disk-utility-3.10.0-raise-gsd-dependency.patch 1122 SHA256 e6c5ab12de3bebe2ec64c9893a2bccf3dff3eab1d5eee6f101a85b7805f95681 SHA512 ed1ee38061196608d2448b2bfac69d32defed89c80704826cba21a2d65c4dbff51ca897a9db5da0be2b3c606302a64f036217af949c30a875ed57c05f0f206a1 WHIRLPOOL 6fc0ce6d3068a84b14c3d8fbc1bebbe8f38e1948df10a6bcb2c713f1367b69bcdd2fa6cf7c553d6554e25d363803e261c25b2c6167559bdd0d69b3edfa723a04
+DIST gnome-disk-utility-3.10.0.tar.xz 1401460 SHA256 34e23a62e711ec543670550f9312a5ad6610ce807d57345146b6af989788b8aa SHA512 0de9aaea7835dfa12525aeb8ae5e3d7fd8db89b449d979267c1b50cf3b447c495c56f5340dc8cf355941dab6b68a29a25c8c152197cfbf0b348cf09c347d5459 WHIRLPOOL 2bb703e1c77a42516476fbfb3e8782f81dee80a717e03183a408c5527ae4d947dcafe0e6bed1fb630abd9cc63d1b47d74a136e38da611a54deee8a07816c4cab
+EBUILD gnome-disk-utility-3.10.0.ebuild 1451 SHA256 2227a28704225bceb0c88c312ce902f607948c5a729856703ef804667fc120fb SHA512 c704fe3ed05d32f4aef771c6c76276e9c81bf462659566249056b7510181ead46e22afca04fd97efe1773cee2151f0061e19397317c9f138f106adb15c71811b WHIRLPOOL 2f38216b204382c16af80a613a03ee0cd82b252f3b30cc3c7f2016164ced026088d4d7003f889de7aaf6fd3b43d70d4fa36e4917f3be78919855238b5e8a07ca
diff --git a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch
new file mode 100644
index 0000000..c6d414c
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-kill-gsd-automagic.patch
@@ -0,0 +1,46 @@
+From cfefd62c7f23625fd1b07dacb35681bdf5aafa04 Mon Sep 17 00:00:00 2001
+From: Andreas Henriksson <andreas@fatal.se>
+Date: Fri, 5 Apr 2013 12:42:06 +0200
+Subject: [PATCH 1/2] Avoid needing gsd during build when --disable-gsd-plugin
+ is used
+
+PKG_CHECK_MODULES was previously unconditionally requiring
+gnome-settings-daemon to be available, even when it was later
+not going to be used because the --disable-gsd-plugin configure
+switch was passed.
+
+Move the check to only require g-s-d when it's actually going to be
+used.
+
+While at it, also fix the indentation of the msg_gsd_plugin=yes line.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=697146
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index cce9d62..d8f6198 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -120,7 +120,6 @@ PKG_CHECK_MODULES(LIBSECRET1, [libsecret-1 >= $LIBSECRET1_REQUIRED])
+ PKG_CHECK_MODULES(PWQUALITY, [pwquality >= $PWQUALITY_REQUIRED])
+ PKG_CHECK_MODULES(CANBERRA, [libcanberra-gtk3 >= $CANBERRA_REQUIRED])
+ PKG_CHECK_MODULES(LIBDVDREAD, [dvdread >= $LIBDVDREAD_REQUIRED])
+-PKG_CHECK_MODULES(GSD_PLUGIN, [gnome-settings-daemon >= $GSD_PLUGIN_REQUIRED])
+ PKG_CHECK_MODULES(LIBNOTIFY, [libnotify >= $LIBNOTIFY_REQUIRED])
+ PKG_CHECK_MODULES(LIBLZMA, [liblzma >= $LIBLZMA_REQUIRED])
+
+@@ -157,7 +156,8 @@ dnl *************************************
+ AC_ARG_ENABLE(gsd_plugin, AS_HELP_STRING([--disable-gsd-plugin],[don't build gnome-settings-daemon plug-in]))
+ msg_gsd_plugin=no
+ if test "x$enable_gsd_plugin" != "xno"; then
+- msg_gsd_plugin=yes
++ msg_gsd_plugin=yes
++ PKG_CHECK_MODULES(GSD_PLUGIN, [gnome-settings-daemon >= $GSD_PLUGIN_REQUIRED])
+ fi
+ AM_CONDITIONAL(USE_GSD_PLUGIN, [test "$msg_gsd_plugin" = "yes"])
+
+--
+1.8.3.2
+
diff --git a/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch
new file mode 100644
index 0000000..f5ff3ce
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/files/gnome-disk-utility-3.10.0-raise-gsd-dependency.patch
@@ -0,0 +1,35 @@
+From f05af64dd29a5119f36d0c34f0d6aa9f04567933 Mon Sep 17 00:00:00 2001
+From: Andreas Henriksson <andreas@fatal.se>
+Date: Fri, 5 Apr 2013 12:30:55 +0200
+Subject: [PATCH 2/2] Bump required version of gnome-settings-daemon to 3.8
+
+Reported by Pacho Ramos in https://bugzilla.gnome.org/697146
+and from the references gentoo bug report:
+
+With gnome-base/gnome-settings-daemon-3.6.4:
+
+gdusdmanager.c: At top level:
+gdusdmanager.c:42:1: error: unknown type name 'GduSdClass'
+gdusdmanager.c:80:1: warning: 'gdu_sd_manager_start' defined but not used [-Wunused-function]
+gdusdmanager.c:124:1: warning: 'gdu_sd_manager_new' defined but not used [-Wunused-function]
+make[3]: *** [libgdu_sd_la-gdusdmanager.lo] Error 1
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d8f6198..2604798 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -109,7 +109,7 @@ LIBSECRET1_REQUIRED=0.7
+ PWQUALITY_REQUIRED=1.0.0
+ CANBERRA_REQUIRED=0.1
+ LIBDVDREAD_REQUIRED=4.2.0
+-GSD_PLUGIN_REQUIRED=3.6
++GSD_PLUGIN_REQUIRED=3.8
+ LIBNOTIFY_REQUIRED=0.7
+ LIBLZMA_REQUIRED=5.0.5
+
+--
+1.8.3.2
+
diff --git a/sys-apps/gnome-disk-utility/gnome-disk-utility-3.10.0.ebuild b/sys-apps/gnome-disk-utility/gnome-disk-utility-3.10.0.ebuild
new file mode 100644
index 0000000..c0aab29
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/gnome-disk-utility-3.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gnome-disk-utility/Attic/gnome-disk-utility-3.10.0.ebuild,v 1.6 2014/11/13 12:38:07 pacho dead $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Disk Utility for GNOME using udisks"
+HOMEPAGE="http://git.gnome.org/browse/gnome-disk-utility"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="fat +gnome systemd"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31:2
+ >=sys-fs/udisks-2.1.1:2
+ >=x11-libs/gtk+-3.5.8:3
+ >=app-arch/xz-utils-5.0.5
+ >=app-crypt/libsecret-0.7
+ dev-libs/libpwquality
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/libdvdread-4.2.0
+ >=media-libs/libcanberra-0.1[gtk3]
+ >=x11-libs/libnotify-0.7:=
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ fat? ( sys-fs/dosfstools )
+ gnome? ( >=gnome-base/gnome-settings-daemon-3.8 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-libs/libxslt
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix USE=-gnome, bug #478820
+ epatch "${FILESDIR}"/${PN}-3.10.0-kill-gsd-automagic.patch
+ epatch "${FILESDIR}"/${PN}-3.10.0-raise-gsd-dependency.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gnome gsd-plugin) \
+ $(use_enable systemd libsystemd-login)
+}