aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idell5@iinet.com.au>2011-12-18 16:30:22 +0800
committerIan Delaney <idell5@iinet.com.au>2011-12-18 16:30:22 +0800
commit179731f6be99efddf8aac5ae4e5c00ad29f32b9c (patch)
tree1e6987c0c2ca662da2283d4a2be89b9df8ef0d7e
parentadding python packages mimeparse and django-tastypie (diff)
downloadimprovise-179731f6be99efddf8aac5ae4e5c00ad29f32b9c.tar.gz
improvise-179731f6be99efddf8aac5ae4e5c00ad29f32b9c.tar.bz2
improvise-179731f6be99efddf8aac5ae4e5c00ad29f32b9c.zip
adding python packages mimeparse and django-tastypie
(Portage version: 2.1.10.11/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/mimeparse/Manifest3
-rw-r--r--dev-python/mimeparse/metadata.xml (renamed from media-sound/lash/metadata.xml)3
-rw-r--r--dev-python/mimeparse/mimeparse-0.1.3.ebuild17
-rw-r--r--eclass/python.eclass4
-rw-r--r--media-gfx/inkscape/Manifest2
-rw-r--r--media-gfx/inkscape/inkscape-0.48.2.ebuild17
-rw-r--r--media-libs/libkate/Manifest4
-rw-r--r--media-libs/libkate/files/libkate-0.3.7-libpng14.patch38
-rw-r--r--media-libs/libkate/libkate-0.4.1.ebuild64
-rw-r--r--media-libs/libkate/metadata.xml18
-rw-r--r--media-sound/lash/Manifest4
-rw-r--r--media-sound/lash/files/lash-0.5.4-glibc2.8.patch14
-rw-r--r--media-sound/lash/lash-0.5.4-r1.ebuild56
-rw-r--r--www-apps/curator/Manifest2
-rw-r--r--www-apps/curator/curator-2.1.ebuild2
-rw-r--r--x11-misc/xac/Manifest2
-rw-r--r--x11-misc/xac/xac-0.6_pre4.ebuild13
17 files changed, 37 insertions, 226 deletions
diff --git a/dev-python/mimeparse/Manifest b/dev-python/mimeparse/Manifest
new file mode 100644
index 0000000..06d6e6c
--- /dev/null
+++ b/dev-python/mimeparse/Manifest
@@ -0,0 +1,3 @@
+DIST mimeparse-0.1.3.tar.gz 4423 RMD160 4ca6689b4002371b87b4e992d9f5fd6c43023e9e SHA1 afc02fec477bc3f138ac37c2528c1820518cec3d SHA256 534ff6feefe1cd03984f444e6415aacc79c0a85f3b868ec41a2fd5003004c31e
+EBUILD mimeparse-0.1.3.ebuild 409 RMD160 f7f324f26859fc0cfc013ea4ed0ca466bcde7516 SHA1 55cba490f86c634252eac381eda6758a428e58cf SHA256 2a84b8179f775515fed84e867eb59520399c41dd914de06ea32ef107ea0465b7
+MISC metadata.xml 244 RMD160 46d2db53fa106725ed5ad6484c86f1fc14d1fceb SHA1 2f8464ae7ec8a29a856447153cc8324db4b3f963 SHA256 575ec24fe6d3ad19381990f665a864b44763471dd4a7def25770bdf67443ed35
diff --git a/media-sound/lash/metadata.xml b/dev-python/mimeparse/metadata.xml
index 0dc3775..852ca30 100644
--- a/media-sound/lash/metadata.xml
+++ b/dev-python/mimeparse/metadata.xml
@@ -1,5 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>proaudio</herd>
+ <herd>python</herd>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
</pkgmetadata>
diff --git a/dev-python/mimeparse/mimeparse-0.1.3.ebuild b/dev-python/mimeparse/mimeparse-0.1.3.ebuild
new file mode 100644
index 0000000..739f683
--- /dev/null
+++ b/dev-python/mimeparse/mimeparse-0.1.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+inherit distutils
+
+DESCRIPTION="Basic functions for handling mime-types in python"
+HOMEPAGE="http://code.google.com/p/mimeparse"
+SRC_URI="http://mimeparse.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
diff --git a/eclass/python.eclass b/eclass/python.eclass
index 3db68cc..188d5ac 100644
--- a/eclass/python.eclass
+++ b/eclass/python.eclass
@@ -390,7 +390,7 @@ _python_check_python_pkg_setup_execution() {
[[ " ${FUNCNAME[@]:1} " =~ " "(python_set_active_version|python_pkg_setup)" " ]] && return
if ! has "${EAPI:-0}" 0 1 2 3 && [[ -z "${PYTHON_PKG_SETUP_EXECUTED}" ]]; then
- die "python_pkg_setup() not called"
+ ewarn "python_pkg_setup() not called"
fi
}
@@ -3014,13 +3014,13 @@ python_mod_optimize() {
# @DESCRIPTION:
# Delete orphaned byte-compiled Python modules corresponding to specified Python modules.
#
+# _python_check_python_pkg_setup_execution
# This function can be used only in pkg_postrm() phase.
python_mod_cleanup() {
if [[ "${EBUILD_PHASE}" != "postrm" ]]; then
die "${FUNCNAME}() can be used only in pkg_postrm() phase"
fi
- _python_check_python_pkg_setup_execution
_python_initialize_prefix_variables
local allow_evaluated_non_sitedir_paths="0" dir iterated_PYTHON_ABIS PYTHON_ABI="${PYTHON_ABI}" root search_paths=() sitedir
diff --git a/media-gfx/inkscape/Manifest b/media-gfx/inkscape/Manifest
index 4f60a9f..3e7529d 100644
--- a/media-gfx/inkscape/Manifest
+++ b/media-gfx/inkscape/Manifest
@@ -3,5 +3,5 @@ AUX inkscape-0.48.1-lcms.patch 368 RMD160 d0be9057ee064cfa87c15dd13b4f4f8c6ee227
AUX inkscape-0.48.1-libpng15.patch 1616 RMD160 ea6f011b2cd91db106aaed4ff4d387fc20f96214 SHA1 d6512f3cb38ca8e2436dc485aa652490d17b3a52 SHA256 55e113db90267d6789cdb6a54a6c744bd0e9d755b2a7b5835a3713ea04e98c87
AUX inkscape-0.48.2-libwpg.patch 1006 RMD160 207d25adc5bbde4e660a0f0a0723df417fd3817c SHA1 b2beb2c67b8ba8f04f928f2d02cce9d032617cd4 SHA256 12cea23c64ef880bbd02e67002ca05c33475701e489d9d0ba3e057b6c2c71c9d
DIST inkscape-0.48.2.tar.bz2 19583331 RMD160 3f658d373f976a41191d48d8248b33dfb3d65238 SHA1 be30ab2d2714d04ddd69b400bd6ad30b09e83067 SHA256 223a42ba6e3644bb2956c485ca0c210edc14e90fa882cdc57c1bb9f35b8f6783
-EBUILD inkscape-0.48.2.ebuild 2875 RMD160 4455a169f6e973ed9b9c61ca3bb6c273c42dc0de SHA1 e207243a555ba263c52b7142821d282696d14d8b SHA256 5dd73335ef27fcb63895822e7a73e5f94b20e0871e9e69c69a06f7427872f019
+EBUILD inkscape-0.48.2.ebuild 2744 RMD160 e1e1181e76a7d037d7098472406dd8a0fcf37739 SHA1 f3202d439ad8d5fe555e16af21f53240ce371b34 SHA256 c2cbcf1522db3ead7f39ee6d6d46150b7497763e16bb05c4d592eed95d9943e4
MISC metadata.xml 438 RMD160 255e104540381e2eda4bee5e06d13a3e5f9cd978 SHA1 8364d93a2a793fea4d5ace199ac7c25c67e896ab SHA256 d033e82cb1e2d7055baf12ffa4c1a21cfc79d3d45373c122ebf39d4c856437f3
diff --git a/media-gfx/inkscape/inkscape-0.48.2.ebuild b/media-gfx/inkscape/inkscape-0.48.2.ebuild
index 1621fb8..02f7bd9 100644
--- a/media-gfx/inkscape/inkscape-0.48.2.ebuild
+++ b/media-gfx/inkscape/inkscape-0.48.2.ebuild
@@ -99,21 +99,10 @@ src_configure() {
gnome2_src_configure
}
-pkg_postint() {
- python_mod_optimize -r "${ED}"
+pkg_postinst() {
+ python_mod_optimize /usr/share/"${PN}"/extensions
}
pkg_postrm() {
- python_mod_cleanup "${ED}"
-
-}
-
-pkg_postint() {
- python_pkg_setup
- python_mod_optimize usr/share/"${PN}"-extensions
-}
-
-pkg_postrm() {
- python_pkg_setup
- python_mod_cleanup usr/share/"${PN}"-extensions
+ python_mod_cleanup /usr/share/"${PN}"/extensions
}
diff --git a/media-libs/libkate/Manifest b/media-libs/libkate/Manifest
deleted file mode 100644
index 0b84372..0000000
--- a/media-libs/libkate/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX libkate-0.3.7-libpng14.patch 1083 RMD160 7c44551df5ff7dfaff645cc54b722eea879498ea SHA1 8306759bf08334a6d3116d4f85d71efc739e0d88 SHA256 66ef41f59aeabae04cc36dc865c00120419879281cd9e42aae5fad775b711537
-DIST libkate-0.4.1.tar.gz 906896 RMD160 e92e11bde9cd14312c304a89d79c3ba9e4384762 SHA1 87fd8baaddb7120fb4d20b0a0437e44ea8b6c9d8 SHA256 c40e81d5866c3d4bf744e76ce0068d8f388f0e25f7e258ce0c8e76d7adc87b68
-EBUILD libkate-0.4.1.ebuild 1487 RMD160 63da82ae0a4b0cb5765f9474985c16f3633562b7 SHA1 05a3567d0cd5573abaf47dc629f9713c49f02127 SHA256 801ba54334a0e30b1bbd367a54ca5823f991dc1ac7f49825a43fa2ef16b9be89
-MISC metadata.xml 895 RMD160 965d9cb4ddffaeb63805c6f45c3633cf64d45350 SHA1 74d627d9ef6d081e81589767d33a2724c258f7ad SHA256 c21a36a5f2d2c114213f7ab83d9dc6c5bbbce8f31969f1d31bb0270ea6302d85
diff --git a/media-libs/libkate/files/libkate-0.3.7-libpng14.patch b/media-libs/libkate/files/libkate-0.3.7-libpng14.patch
deleted file mode 100644
index e93ac75..0000000
--- a/media-libs/libkate/files/libkate-0.3.7-libpng14.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-http://code.google.com/p/libkate/issues/detail?id=15
-
---- tools/kpng.c
-+++ tools/kpng.c
-@@ -179,13 +179,13 @@
- }
- }
-
-- png_destroy_read_struct(&png_ptr,&info_ptr,png_infopp_NULL);
-+ png_destroy_read_struct(&png_ptr,&info_ptr,NULL);
- fclose(f);
-
- return 0;
-
- error:
-- if (png_ptr) png_destroy_read_struct(&png_ptr,info_ptr?&info_ptr:png_infopp_NULL,png_infopp_NULL);
-+ if (png_ptr) png_destroy_read_struct(&png_ptr,info_ptr?&info_ptr:NULL,NULL);
- if (f) fclose(f);
- return -1;
- }
-@@ -224,7 +224,7 @@
- if (w) *w=png_get_image_width(png_ptr,info_ptr);
- if (h) *h=png_get_image_height(png_ptr,info_ptr);
-
-- png_destroy_read_struct(&png_ptr,&info_ptr,png_infopp_NULL);
-+ png_destroy_read_struct(&png_ptr,&info_ptr,NULL);
-
- /* now read the whole file as a binary blob */
- fseek(f,0,SEEK_END);
-@@ -246,7 +246,7 @@
- return 0;
-
- error:
-- if (png_ptr) png_destroy_read_struct(&png_ptr,info_ptr?&info_ptr:png_infopp_NULL,png_infopp_NULL);
-+ if (png_ptr) png_destroy_read_struct(&png_ptr,info_ptr?&info_ptr:NULL,NULL);
- if (f) fclose(f);
- return -1;
- }
diff --git a/media-libs/libkate/libkate-0.4.1.ebuild b/media-libs/libkate/libkate-0.4.1.ebuild
deleted file mode 100644
index f80a799..0000000
--- a/media-libs/libkate/libkate-0.4.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libkate/libkate-0.4.1.ebuild,v 1.1 2011/09/08 18:00:27 aballier Exp $
-
-EAPI="3"
-PYTHON_DEPEND="wxwidgets? 2"
-inherit python
-
-DESCRIPTION="Codec for karaoke and text encapsulation for Ogg"
-HOMEPAGE="http://code.google.com/p/libkate/"
-SRC_URI="http://libkate.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc wxwidgets"
-
-COMMON_DEPEND="media-libs/libogg
- media-libs/libpng"
-DEPEND="${COMMON_DEPEND}
- dev-util/pkgconfig
- sys-devel/flex
- sys-devel/bison
- doc? ( app-doc/doxygen )"
-RDEPEND="${COMMON_DEPEND}
- wxwidgets? ( =dev-python/wxpython-2.8* media-libs/liboggz )"
-
-pkg_setup() {
- if use wxwidgets; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- echo "#!/bin/sh" > misc/autotools/py-compile
-}
-
-src_configure() {
- use wxwidgets || sed -i -e "s/HAVE_PYTHON=yes/HAVE_PYTHON=no/" configure
- econf $(use_enable debug) $(use_enable doc) --docdir=/usr/share/doc/${PF}
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README
- if use wxwidgets; then
- python_convert_shebangs -r 2 "${D}"
- fi
-}
-
-pkg_postinst() {
- if use wxwidgets; then
- python_mod_optimize kdj
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup kdj
-}
diff --git a/media-libs/libkate/metadata.xml b/media-libs/libkate/metadata.xml
deleted file mode 100644
index 775ac77..0000000
--- a/media-libs/libkate/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>video</herd>
- <longdescription lang="en">
- Kate is a codec for karaoke and text encapsulation for Ogg. Most of the
- time, this would be multiplexed with audio/video to carry subtitles,
- song lyrics (with or without karaoke data), etc, but doesn't have to be.
- A possible use of a lone Kate stream would be an e-book. Moreover, the
- motion feature gives Kate a powerful means to describe arbitrary curves,
- so hand drawing of shapes can be achieved. This was originally meant for
- karaoke use, but can be used for any purpose. Motions can be attached to
- various semantics, like position, color, etc, so scrolling or fading
- text can be defined.
-
- More information can be found at http://wiki.xiph.org/index.php/OggKate
- </longdescription>
-</pkgmetadata>
diff --git a/media-sound/lash/Manifest b/media-sound/lash/Manifest
deleted file mode 100644
index cc34711..0000000
--- a/media-sound/lash/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX lash-0.5.4-glibc2.8.patch 337 RMD160 a06ca6ffb2b5e0e7bc8cd0dde2afb963841e663b SHA1 72e1881315df0b04cb650c6282b3d0feaa24aee1 SHA256 f3ae3954e6754b9d2fc43773fb1472f5e64c58188c6fff3517f11f0f75a1f546
-DIST lash-0.5.4.tar.gz 623469 RMD160 251a20c0597b8ec6fac2a39bab1d18ab5c017f40 SHA1 d8fa24ebef0807c3b0426894d7ecd6229fda28b4 SHA256 105a7da84415c4725c6bcad28e70f23aeb4534f94fc80ca262b6a2cef2226c16
-EBUILD lash-0.5.4-r1.ebuild 1334 RMD160 5813bd0ea47cf75d14639f5bca24c3579919a552 SHA1 b27db0fc69cdb3977904bc8fdfba7d38aace3acd SHA256 e2439d2f44a4549597ccd81bb116c695b0fa7681563d165dd4bbe93e231cfbbc
-MISC metadata.xml 161 RMD160 2738d17827a71b5ccbadae4c4f909d2b57d147b0 SHA1 90201ddb830142147774cc7b7b5178fbd0a9af0c SHA256 0ba191421eefd954d1efe9f6c3384e8c8d7455d35a7e79457272e1c29211b09e
diff --git a/media-sound/lash/files/lash-0.5.4-glibc2.8.patch b/media-sound/lash/files/lash-0.5.4-glibc2.8.patch
deleted file mode 100644
index 56bc89a..0000000
--- a/media-sound/lash/files/lash-0.5.4-glibc2.8.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- liblash/socket.c.old 2008-06-26 15:20:44.227064193 +0200
-+++ liblash/socket.c 2008-06-26 15:21:18.245063129 +0200
-@@ -20,6 +20,11 @@
-
- #define _POSIX_SOURCE /* addrinfo */
-
-+#ifdef LASH_BUILD
-+#define _GNU_SOURCE
-+#include "config.h"
-+#endif /* LASH_BUILD */
-+
- #include <stdint.h>
- #include <sys/types.h>
- #include <sys/socket.h>
diff --git a/media-sound/lash/lash-0.5.4-r1.ebuild b/media-sound/lash/lash-0.5.4-r1.ebuild
deleted file mode 100644
index 98153a2..0000000
--- a/media-sound/lash/lash-0.5.4-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lash/lash-0.5.4-r1.ebuild,v 1.12 2011/03/29 06:56:34 radhermit Exp $
-
-EAPI=4
-PYTHON_DEPEND="python? 2"
-inherit eutils libtool python
-
-DESCRIPTION="LASH Audio Session Handler"
-HOMEPAGE="http://www.nongnu.org/lash/"
-SRC_URI="http://download.savannah.gnu.org/releases/lash/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE="alsa debug gtk python"
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- media-sound/jack-audio-connection-kit
- dev-libs/libxml2
- gtk? ( x11-libs/gtk+:2 )
- || ( sys-libs/readline dev-libs/libedit )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- python? ( >=dev-lang/swig-1.3.31 )"
-
-pkg_setup() {
- if use python; then
- python_set_active_version 2
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-glibc2.8.patch"
- elibtoolize
-}
-
-src_configure() {
- local myconf
-
- # Yet-another-broken-configure: --enable-pylash would disable it.
- use python || myconf="${myconf} --disable-pylash"
-
- econf \
- $(use_enable alsa alsa-midi) \
- $(use_enable gtk gtk2) \
- $(use_enable debug) \
- ${myconf} \
- --disable-dependency-tracking
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ${DOCS[@]}
-}
diff --git a/www-apps/curator/Manifest b/www-apps/curator/Manifest
index 3e15fb7..13e3dc2 100644
--- a/www-apps/curator/Manifest
+++ b/www-apps/curator/Manifest
@@ -1,5 +1,5 @@
DIST curator-2.0.tar.gz 29531 RMD160 cda9cf3972cae8e56686f3ef1d5de490bc65297b SHA1 ecacc36b274acf6fb7f0ea95ea5cf51bdead8621 SHA256 ec84ef5d14e6612c47bec01814cf7d92a95b63195f242446351457f0a5a913d6
DIST curator-2.1.tar.gz 37457 RMD160 fe6120d320819f7b7235740b5a6ab558c1c978c3 SHA1 306bb811fe5a10b739dc2e89195b520e92b4b85f SHA256 2f17ac6547f8d6f44be3a36bfeefe65d92d7a1fe9920f7d509a6ad692e2bcd7b
EBUILD curator-2.0.ebuild 709 RMD160 0bf5cf35522ac4c482ccfbe893ec4daf11d7ca69 SHA1 1a15a34a8d25bafe40c1640676e9fce3717f9c4a SHA256 2814843e72ed6fb55e5b8e9fe3f31ef2f145b6a8dcadad133b2d2cb70a2573c0
-EBUILD curator-2.1.ebuild 705 RMD160 a5fabf827430efed4b688709d55eea91ad56852d SHA1 223ad5bd032746bb89e7251acbf9b7e8087036a7 SHA256 d5b9fa80e9d8511957c67f7eb51c44bce4057fd463c4c328d798111453ceff6a
+EBUILD curator-2.1.ebuild 731 RMD160 20656d40620139f37a1f83c98e57bcdd53e4882c SHA1 910bf17af4ddf563c2d4f6fa5b809b16ef9a9915 SHA256 c70c6eb68910bb2ab530bcb4adecba5cc7ac99ef7dc2ddf1fea830939a82e4f6
MISC metadata.xml 162 RMD160 0b015f5ff17c4d8e7aee826d48b326cc19b1fed4 SHA1 671b30dafbea01228c8bb606af451a0795922840 SHA256 84ff2fc6c9a4af1b9dbe32aa81ab84c2958bc1bd65a9977686df2dcab6e420d0
diff --git a/www-apps/curator/curator-2.1.ebuild b/www-apps/curator/curator-2.1.ebuild
index 89789b2..9f6daf0 100644
--- a/www-apps/curator/curator-2.1.ebuild
+++ b/www-apps/curator/curator-2.1.ebuild
@@ -27,5 +27,5 @@ pkg_setup() {
src_install() {
dobin bin/curator || die "dobin bin/curator failed!"
dodoc CHANGES README
- python_convert_shebangs
+ python_convert_shebangs 2 "${ED}"/usr/bin/curator
}
diff --git a/x11-misc/xac/Manifest b/x11-misc/xac/Manifest
index 0abacc0..d3c8879 100644
--- a/x11-misc/xac/Manifest
+++ b/x11-misc/xac/Manifest
@@ -1,4 +1,4 @@
AUX x86-biosfix.patch 1113 RMD160 ef1a1bf5851f41c0aaeac007e48879537827f7e2 SHA1 869632cdbc75cd634e3a53656692ea31264b5d60 SHA256 def8c236d6f9695aede8f6ea6b05e1a9268f8f1f29c9756962fcf2e3efc4593b
DIST xac-0.6_pre4.tar.bz2 37409 RMD160 ecc98ef512c52f793cbaf1e1f8ed5497e108a2d3 SHA1 5ab11f5f859d9a635b4c59d4b75ec6ac66665ad6 SHA256 ff34e1e6e7027a22e712307e3832423b512af894e8ad9678e2f5d022a699a4d4
-EBUILD xac-0.6_pre4.ebuild 1370 RMD160 04be72a0e1e856ac063251d73efb111760e2f8ba SHA1 72d5c68c541a6ab64acd5e45fb52c6d831ad4762 SHA256 2805e71303add8d8f4ad05ad1dcff3bf52d63fc185f809fa437bc8f67150d6c8
+EBUILD xac-0.6_pre4.ebuild 1352 RMD160 91bcc2de4dbb4be76a64b18783ed7bb2ad4d4e04 SHA1 a2b27d6efa7b167f1db040847f14f20ddcdb26de SHA256 fe86b4e1476d1c4333a32b15dcedd4a50e7610dd899c86023aac35b07b1d48da
MISC metadata.xml 320 RMD160 78cab489a12745f39406d93c3e8610c4b24ed92d SHA1 acb57f81fb40c0c20813fea8500fc9716a096504 SHA256 dc6c4f2001a55deaf64a90ac21e6d3a198ef09f26e3adbd67ae14b193e9d1cea
diff --git a/x11-misc/xac/xac-0.6_pre4.ebuild b/x11-misc/xac/xac-0.6_pre4.ebuild
index ba7fcd0..aa18ddf 100644
--- a/x11-misc/xac/xac-0.6_pre4.ebuild
+++ b/x11-misc/xac/xac-0.6_pre4.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
PYTHON_DEPEND="2"
-inherit toolchain-funcs eutils distutils
+inherit toolchain-funcs eutils distutils multilib
DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
@@ -12,16 +12,15 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ppc ppc64 ~x86"
SLOT="0"
IUSE="livecd"
-DEPEND=">=dev-lang/python-2.3
- sys-apps/pciutils"
+DEPEND="sys-apps/pciutils"
RDEPEND=">=dev-lang/python-2.3
x11-base/xorg-server"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
DISTUTILS_SETUP_FILES=("src|setup.py")
pkg_setup() {
- python_pkg_setup
python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -51,9 +50,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "${EROOT}"usr/lib64/xac
+ python_mod_optimize /usr/$(get_libdir)/xac
}
pkg_postrm() {
- python_mod_cleanup "${EROOT}"usr/lib64/xac
-} \ No newline at end of file
+ python_mod_cleanup /usr/$(get_libdir)/xac
+}