aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idell5@iinet.com.au>2012-03-06 05:30:24 +0800
committerIan Delaney <idell5@iinet.com.au>2012-03-06 05:30:24 +0800
commit8083a747529656956634a18a13c65a0db56132e1 (patch)
tree6f91a54e6a69f381dbcb4a4b92b923c08ce5d981
parent[kde-misc/Webcamoid] -r2 ebuild with plasmoid pattern refelcted (diff)
downloadimprovise-8083a747529656956634a18a13c65a0db56132e1.tar.gz
improvise-8083a747529656956634a18a13c65a0db56132e1.tar.bz2
improvise-8083a747529656956634a18a13c65a0db56132e1.zip
[kde-misc/Webcamoid] refinements reductions in -r3
(Portage version: 2.2.0_alpha84/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild32
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild74
-rw-r--r--kde-misc/Webcamoid/Webcamoid-9999.ebuild62
-rw-r--r--kde-misc/Webcamoid/files/setup.py18
-rw-r--r--kde-misc/Webcamoid/files/setup2.cfg2
-rw-r--r--kde-misc/Webcamoid/files/tampakrap_note.txt10
6 files changed, 143 insertions, 55 deletions
diff --git a/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild b/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild
index b28f0df..ab745ea 100644
--- a/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild
+++ b/kde-misc/Webcamoid/Webcamoid-9999-r2.ebuild
@@ -9,7 +9,7 @@ PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
inherit git-2 distutils
-
+
DESCRIPTION="A plasmoid used to show and take photos with your webcam"
HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
LICENSE="GPL-2"
@@ -27,32 +27,32 @@ DISTUTILS_SETUP_FILES=("contents/code/v4l2|setup.py")
PYTHON_MODNAME="v4l2.py"
src_unpack() {
- git-2_src_unpack
- cd ${S}
- cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
+ git-2_src_unpack
+ cd ${S}
+ cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
cp "${FILESDIR}"/setup2.cfg contents/code/v4l2/
- touch contents/code/__init__.py
+ touch contents/code/__init__.py
}
src_prepare() {
- python_copy_sources
+ python_copy_sources
}
src_compile() {
- :
+ :
}
src_install() {
distutils_src_install
- installation() {
- cd contents/code/v4l2
- $(PYTHON) setup.py install --prefix="${D}usr"
- insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
- doins *.py
- cd ../../../
- $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
- }
+ installation() {
+ cd contents/code/v4l2
+ $(PYTHON) setup.py install --prefix="${D}usr"
+ insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
+ doins *.py
+ cd ../../../
+ $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
+ }
python_execute_function -s installation
dobin contents/code/v4l2tools.py
@@ -60,7 +60,7 @@ src_install() {
insinto usr/share/kde4/services
newins metadata.desktop webcamoid.plasmoid
doins metadata.desktop
-
+
insinto ${INSTALLDIR}
doins contents/code/{config.py,__init__.py,main.py,webcamoidgui.py}
insinto usr/share/apps/plasma/plasmoids/webcamoid/contents
diff --git a/kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild b/kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild
new file mode 100644
index 0000000..00a6d35
--- /dev/null
+++ b/kde-misc/Webcamoid/Webcamoid-9999-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+KDE_SCM="git"
+EGIT_REPO_URI="git://github.com/hipersayanX/Webcamoid"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit git-2 distutils
+
+DESCRIPTION="A plasmoid used to show and take photos with your webcam"
+HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
+LICENSE="GPL-2"
+INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/contents/code"
+
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="kde-base/pykde4
+ kde-base/kdepimlibs"
+RDEPEND="${DEPEND} media-video/ffmpeg"
+
+DISTUTILS_SETUP_FILES=("contents/code/v4l2|setup.py")
+PYTHON_MODNAME="v4l2.py webcamoid"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ git-2_src_unpack
+ cd ${S}
+ cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
+ cp "${FILESDIR}"/setup2.cfg contents/code/v4l2/
+ touch contents/code/__init__.py
+}
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_install() {
+ installation() {
+ cd contents/code/v4l2
+ $(PYTHON) setup.py install --prefix="${D}usr"
+ insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
+ doins *.py
+ $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}/v4l2"
+ insinto ${INSTALLDIR}/v4l2
+ doins *.py
+
+ cd ../../../
+ $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
+ }
+ python_execute_function -s installation
+
+ dobin contents/code/v4l2tools.py
+
+ insinto usr/share/kde4/services
+ newins metadata.desktop webcamoid.plasmoid
+ doins metadata.desktop
+
+ insinto ${INSTALLDIR}
+ doins contents/code/{config.py,__init__.py,main.py,webcamoidgui.py}
+ insinto usr/share/apps/plasma/plasmoids/webcamoid/contents
+ insinto usr/share/apps/plasma/plasmoids/webcamoid/
+ doins metadata.desktop
+ newins metadata.desktop webcamoid.plasmoid
+
+ dodoc contents/code/v4l2/{NEWS,README}
+ insinto usr/share/doc/${P}
+ newins README.markdown README
+}
diff --git a/kde-misc/Webcamoid/Webcamoid-9999.ebuild b/kde-misc/Webcamoid/Webcamoid-9999.ebuild
index e554eff..8dfeadb 100644
--- a/kde-misc/Webcamoid/Webcamoid-9999.ebuild
+++ b/kde-misc/Webcamoid/Webcamoid-9999.ebuild
@@ -4,79 +4,71 @@
EAPI=4
+KDE_SCM="git"
EGIT_REPO_URI="git://github.com/hipersayanX/Webcamoid"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit git-2 python
-#distutils
+inherit git-2 distutils
DESCRIPTION="A plasmoid used to show and take photos with your webcam"
HOMEPAGE="http://kde-apps.org/content/show.php/Webcamoid?content=144796"
-LICENSE="GPL-3"
-INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/code"
+LICENSE="GPL-2"
+INSTALLDIR="usr/share/apps/plasma/plasmoids/webcamoid/contents/code"
SLOT="4"
KEYWORDS=""
IUSE=""
DEPEND="kde-base/pykde4
- kde-base/kdepimlibs
- kde-base/libkworkspace"
-RDEPEND="${DEPEND} media-video/ffmpeg
- kde-base/plasma-runtime"
+ kde-base/kdepimlibs"
+RDEPEND="${DEPEND} media-video/ffmpeg"
+
+DISTUTILS_SETUP_FILES=("contents/code/v4l2|setup.py")
+PYTHON_MODNAME="v4l2.py webcamoid"
+S=${WORKDIR}/${P}
src_unpack() {
git-2_src_unpack
cd ${S}
cp "${FILESDIR}"/setup.py "${FILESDIR}"/setup.cfg .
- mv contents webcamoid
- touch webcamoid/code/__init__.py webcamoid/__init__.py
- mv webcamoid/code/v4l2 .
+ cp "${FILESDIR}"/setup2.cfg contents/code/v4l2/
+ touch contents/code/__init__.py
}
src_prepare() {
python_copy_sources
}
-src_compile() {
- :
-}
-
src_install() {
installation() {
- cd v4l2
+ d contents/code/v4l2
$(PYTHON) setup.py install --prefix="${D}usr"
insinto usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2
- doins *.py
- cd ../
+ doins *.py
+ $(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}/v4l2"
+ insinto ${INSTALLDIR}/v4l2
+ doins *.py
+
+ cd ../../../
$(PYTHON) setup.py install --install-purelib="${D}${INSTALLDIR}"
}
python_execute_function -s installation
- dobin webcamoid/code/v4l2tools.py
+ dobin contents/code/v4l2tools.py
insinto usr/share/kde4/services
- newins metadata.desktop webcamoid.desktop
+ newins metadata.desktop webcamoid.plasmoid
+ doins metadata.desktop
insinto ${INSTALLDIR}
- doins webcamoid/code/{config.py,__init__.py,main.py,webcamoidgui.py}
+ doins contents/code/{config.py,__init__.py,main.py,webcamoidgui.py}
+ insinto usr/share/apps/plasma/plasmoids/webcamoid/contents
insinto usr/share/apps/plasma/plasmoids/webcamoid/
- doins webcamoid/__init__.py
-
- insinto usr/share/doc/${P}/v4l2
- doins v4l2/{NEWS,README}
+ doins metadata.desktop
+ newins metadata.desktop webcamoid.plasmoid
+ dodoc contents/code/v4l2/{NEWS,README}
insinto usr/share/doc/${P}
newins README.markdown README
}
-
-postrm() {
- python_mod_optimize v4l2
- python_mod_optimize usr/share/apps/plasma/plasmoids/webcamoid
-}
-
-postinst() {
- python_mod_optimize v4l2
- python_mod_optimize usr/share/apps/plasma/plasmoids/webcamoid
-}
diff --git a/kde-misc/Webcamoid/files/setup.py b/kde-misc/Webcamoid/files/setup.py
index 37d24ff..ef47600 100644
--- a/kde-misc/Webcamoid/files/setup.py
+++ b/kde-misc/Webcamoid/files/setup.py
@@ -4,9 +4,21 @@ from distutils.core import setup
setup ( name = "webcamoid",
version = "9999",
- description = "A plasmoid used to show and take photos with your webcam",
+ summary = "A plasmoid used to show and take photos with your webcam",
author = "Gonzalo Exequiel Pedone",
- author_email = "hipersayan.x.gmail.com"
+ author_email = "hipersayan.x.gmail.com",
url = "http://kde-apps.org/",
- package_dir = {'webcamoid/code': 'webcamoid/code'}
+ package_dir = {'webcamoid/code': 'webcamoid/code'},
+ license = 'GPLv3',
+ description = "A plasmoid used to show and take photos with your webcam",
+ classifiers = (
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL-3)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: C',
+ 'Programming Language :: Python',
+ 'Topic :: Multimedia :: Plasmoid',
+ ),
+
)
diff --git a/kde-misc/Webcamoid/files/setup2.cfg b/kde-misc/Webcamoid/files/setup2.cfg
index 037f8c5..51ea61c 100644
--- a/kde-misc/Webcamoid/files/setup2.cfg
+++ b/kde-misc/Webcamoid/files/setup2.cfg
@@ -1,2 +1,2 @@
[install]
-install-data="/usr/$(get_libdir)/${PYTHON}/site-packages/v4l2"
+install-data="usr/$(get_libdir)/python$(python_get_version)/site-packages/v4l2"
diff --git a/kde-misc/Webcamoid/files/tampakrap_note.txt b/kde-misc/Webcamoid/files/tampakrap_note.txt
index 3bf8936..6038730 100644
--- a/kde-misc/Webcamoid/files/tampakrap_note.txt
+++ b/kde-misc/Webcamoid/files/tampakrap_note.txt
@@ -13,3 +13,13 @@ It should now give the correct install pattern I was intending.
Whether this is the right one is dtill to be determined.
Seeing no-one knows about plasmoids and thei setup, I am figuring it as I go.
+-r2 is like a combo of the first version which uses distutils and adds the install of the plasmoid itself
+into usr/share/apps/plasma/plasmoids.
+
+-r3 refined a little, removed some un-needed lines. Added installing the v4l2 python folder into its place in
+the source into /usr/share/apps/plasma/plasmoids/webcamoid
+
+Just don't consider this as a suggested final form, it's experimental because I can find no present python
+written plasmoids and no-one seems to know how to use plasmapkg. In its current form it doubles the install
+of the v4l2 to 2 sites to cover all possibilites. Once I figure what is not required those lines will go and
+it will shrink.