aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-20 20:49:31 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-20 20:49:31 +0800
commitfbc7fd4c53e7eab8824b72dd63a71b7655fb8544 (patch)
treed2e562c1ed7199d1cb29e8664941b63a7d203fc1 /dev-python
parent{dev-python/[manuel,xlutils] refined (diff)
downloadimprovise-fbc7fd4c53e7eab8824b72dd63a71b7655fb8544.tar.gz
improvise-fbc7fd4c53e7eab8824b72dd63a71b7655fb8544.tar.bz2
improvise-fbc7fd4c53e7eab8824b72dd63a71b7655fb8544.zip
[dev-python/testfixtures] final cleanup
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-pipeline/Manifest1
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.6.ebuild67
-rw-r--r--dev-python/django-pipeline/metadata.xml10
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild8
4 files changed, 1 insertions, 85 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
deleted file mode 100644
index a64494a..0000000
--- a/dev-python/django-pipeline/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST django-pipeline-1.2.6.tar.gz 27135 SHA256 8de30a83ff1a1ea2683713580aae8be4ecc5bd1a4a22da6296115caaff67c60f SHA512 8dc02d1f0021179d4f430be18597f704d04c41580d523877bfe1206fa713f7ff7687f101ccd2dd50d1b729bf500015fc55303c740068d171bec41433eaf2a75a WHIRLPOOL 9847cedd633c75d04240e20b3529579701335bd29f21d3dc5f69a2146a887f7186c545775bd20b8933464957db7a9ddb329517be5a00ca2ec126524860211a84
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
deleted file mode 100644
index 74ecf7e..0000000
--- a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-LICENSE="MIT"
-SLOT="0"
-PYTHON_MODNAME="pipeline"
-DISTUTILS_SRC_TEST=nosetests
-RDEPEND=">=dev-python/django-1.4"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-src_compile() {
- use doc && emake -C docs html
- rm -f docs/_build/doctrees/environment.pickle || die
- distutils_src_compile
-}
-
-src_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- # Python.[56] trigger a harmless deprecation warning
- testing() {
- local exit_status=0 test
- pushd build-${PYTHON_ABI}/lib/tests/tests/ > /dev/null || die
- for test in [a-z]*.py
- do
- if ! "$(PYTHON)" ${test}; then
- eerror "test "${test}" failed"
- exit_status="1"
- else
- einfo "test "${test}" passed OK"
- fi
- done
- popd > /dev/null
- return ${exit_status}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/
- fi
-
- # Remove un-needed tests to avoid file collisions
- rmtests() {
- rm -rf ${ED}/$(python_get_sitedir)/tests/ || die
- }
-
- python_execute_function rmtests
-}
diff --git a/dev-python/django-pipeline/metadata.xml b/dev-python/django-pipeline/metadata.xml
deleted file mode 100644
index d02cc23..0000000
--- a/dev-python/django-pipeline/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <maintainer><email>tampakrap@gentoo.org</email></maintainer>
- <maintainer>
- <email>della5@iinet.com.au</email>
- <name>Ian Delaney aka idella4 proxy maintainer</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
index 4a84ad5..31cae10 100644
--- a/dev-python/testfixtures/testfixtures-2.3.4.ebuild
+++ b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
@@ -35,10 +35,7 @@ src_prepare() {
src_compile() {
distutils_src_compile
- # Needs abs path
- if use doc; then
- PYTHONPATH="${S}" emake -C docs html
- fi
+ use doc && emake -C docs html
}
src_test() {
@@ -49,8 +46,5 @@ src_install() {
distutils_src_install
if use doc; then
dohtml -r docs/_build/html/
- docompress -x usr/share/doc/${P}/doctrees
- insinto usr/share/doc/${P}/
- doins -r docs/_build/doctrees/
fi
}