summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaroslav Hron <jaroslav.hron@gmail.com>2011-08-11 11:39:49 +0200
committerJaroslav Hron <jaroslav.hron@gmail.com>2011-08-11 11:39:49 +0200
commitedf24aa16c45fd703a1552613e3134fa47639227 (patch)
tree14619557a5d9d083e079cf657f1358af0303c467 /app-misc
parentset repo name (diff)
downloadjxh-edf24aa16c45fd703a1552613e3134fa47639227.tar.gz
jxh-edf24aa16c45fd703a1552613e3134fa47639227.tar.bz2
jxh-edf24aa16c45fd703a1552613e3134fa47639227.zip
initial check-in
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fslint/Manifest2
-rw-r--r--app-misc/fslint/fslint-2.42.ebuild109
-rw-r--r--app-misc/mendeleydesktop/Manifest18
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-0.9.6.3.ebuild68
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-0.9.7.1.ebuild54
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-0.9.8.1.ebuild54
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-0.9.8.2.ebuild61
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-0.9.9.2.ebuild62
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-0.9.9.ebuild62
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-1.0.1.ebuild62
-rw-r--r--app-misc/mendeleydesktop/mendeleydesktop-1.0.ebuild62
11 files changed, 614 insertions, 0 deletions
diff --git a/app-misc/fslint/Manifest b/app-misc/fslint/Manifest
new file mode 100644
index 0000000..cfe430d
--- /dev/null
+++ b/app-misc/fslint/Manifest
@@ -0,0 +1,2 @@
+DIST fslint-2.42.tar.gz 111520 RMD160 23e825cd7d798b750c4fe435b731c6e77f15badb SHA1 607a1a8cc391537151660e1129a4c95908509b80 SHA256 babbef4a34f42ab1d396152fd79b4353adc114b2e8d68b838e20a8067c5a3273
+EBUILD fslint-2.42.ebuild 2702 RMD160 ae28a3051d0374d9764dac374fd8ff1d5fa173ce SHA1 f8d3e2bd40ef7b5d0f0bde07789212bf0d56bd28 SHA256 4dc58d6ef5c8586332c81b3abc8f119d82ae7a460cee4f72478a2a39f51a9907
diff --git a/app-misc/fslint/fslint-2.42.ebuild b/app-misc/fslint/fslint-2.42.ebuild
new file mode 100644
index 0000000..079f1dc
--- /dev/null
+++ b/app-misc/fslint/fslint-2.42.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# original ebuild by bearingspacer@free.fr
+# updated ebuild by mobidyc@msn.com
+# updated ebuild by davide.bettio@kdemail.net
+
+DESCRIPTION="A utility to find and clean various forms of lint on a filesystem."
+HOMEPAGE="http://www.pixelbeat.org/fslint/"
+SRC_URI="http://www.pixelbeat.org/fslint/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-lang/python-2.3
+ gnome-base/libglade
+ >=dev-python/pygtk-2.4"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if [ "${A}" != "" ]; then
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ echo ${S}
+ pwd
+
+# GUI executable
+ dodir /usr/bin
+ exeinto /usr/bin
+ doexe fslint-gui
+
+# GUI file
+ dodir /usr/share/fslint
+ insinto /usr/share/fslint
+ doins fslint.glade
+
+# other executables
+ dodir /usr/share/fslint/fslint
+ exeinto /usr/share/fslint/fslint
+ doexe fslint/find* fslint/zipdir fslint/fslint
+
+ dodir /usr/share/fslint/fslint/fstool
+ exeinto /usr/share/fslint/fslint/fstool
+ doexe fslint/fstool/*
+
+ dodir /usr/share/fslint/fslint/supprt
+ exeinto /usr/share/fslint/fslint/supprt
+ doexe fslint/supprt/get* fslint/supprt/fslver fslint/supprt/md5sum_approx
+
+ dodir /usr/share/fslint/fslint/supprt/rmlint
+ exeinto /usr/share/fslint/fslint/supprt/rmlint
+ doexe fslint/supprt/rmlint/*
+
+# icon
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins fslint_icon.png
+
+# shortcut
+ dodir /etc/X11/applnk/System
+ insinto /etc/X11/applnk/System
+ doins fslint.desktop
+
+# locales
+ cd po
+ emake DESTDIR=${D}/usr DATADIR=share install
+ cd ..
+
+# docs
+ cd doc
+ dodoc FAQ NEWS README TODO
+ cd ..
+
+ cd man
+ doman fslint-gui.1 fslint.1
+ cd ..
+
+# create python init file
+# Other option here is to instead edit fslint-gui itself so that:
+# ^liblocation = '/usr/share/fslint/'
+# ^locale_base = None
+ python_site=`python -c "import sys ; \
+ print '%s/lib/python%s/site-packages' % (sys.exec_prefix,sys.version[:3])"`
+ dodir $python_site/fslint
+ echo "liblocation = '/usr/share/fslint/'" > ${D}/$python_site/fslint/__init__.py
+
+# link to icon in main fslint dir
+ dosym /usr/share/pixmaps/fslint_icon.png /usr/share/fslint/fslint_icon.png
+}
+
+pkg_postinst() {
+ einfo "Note the fslint tools do a lot of inode access and to speed them"
+ einfo "up you can use the following method to not update access times"
+ einfo "on disk while gathering inode information:"
+ einfo "mount -o remount,noatime mountpoint"
+ einfo "fslint or fslint-gui"
+ einfo "mount -o remount,atime mountpoint"
+ einfo ""
+ einfo "Command Line Executables are installed in:"
+ einfo "/usr/share/fslint/fslint"
+ einfo "you may want to add them in your PATH."
+}
diff --git a/app-misc/mendeleydesktop/Manifest b/app-misc/mendeleydesktop/Manifest
new file mode 100644
index 0000000..b386805
--- /dev/null
+++ b/app-misc/mendeleydesktop/Manifest
@@ -0,0 +1,18 @@
+DIST mendeleydesktop-0.9.6.3-linux-x86_64.tar.bz2 23168726 RMD160 ef52fa071285072930a933ca48798c1db2df89f9 SHA1 90b730e72176402fe2e2dae32ee8f87d896c8a1a SHA256 c6a89e11dbd5348b96fa9eac4dd4276388326c7160e9959dd2b19d9128a56018
+DIST mendeleydesktop-0.9.7.1-linux-x86_64.tar.bz2 31653285 RMD160 57aedc7490b9024b5f6897d70c413303426da13c SHA1 e8f8781a58d47baf3464e0278aef57b0c73e5b83 SHA256 5b6935a34225bac6c92ebc1535106934f41d2c4112c0669b68cf3d0d2bbc209d
+DIST mendeleydesktop-0.9.8.1-linux-x86_64.tar.bz2 32615789 RMD160 ec255ca75326aa5b168228a6c443cb51bcefe8ae SHA1 947b517be6560560e8a71677a8602e0a8e102e8d SHA256 2ef4cb5f6d8b2c63955ad480d6b85aa451faa1fdd4f5042b30fa5695fab6ef13
+DIST mendeleydesktop-0.9.8.2-linux-x86_64.tar.bz2 32862729 RMD160 78f69187a0f86215b4e2a34472341e1bffcf7a44 SHA1 7e599321609aa5276e969caf4b6648d7c7f4b0a2 SHA256 d6672eb4fe339b52a939afa7dea451a61300109b028d37d4b1109ac0a50703e2
+DIST mendeleydesktop-0.9.9-linux-x86_64.tar.bz2 33319773 RMD160 5f612ec0227c9364a8c8f38d94ab36c49cc502b1 SHA1 2fe90c714137d93c78eb59ee8ed12e38d8a541a7 SHA256 f50edef24d595b318fc4681c27d6672881a2720c5dc5ef8ef379f0af2a3d8d27
+DIST mendeleydesktop-0.9.9.2-linux-x86_64.tar.bz2 33345234 RMD160 426c42bdefee97b047aa7e6390019e54386e0606 SHA1 3a4717616841b9395531e789d4d7891866f6fe68 SHA256 77c2c7b851f0c99816555c86d7b94072ab049903e147fb0c0f5bbec9129df697
+DIST mendeleydesktop-1.0-linux-x86_64.tar.bz2 33484854 RMD160 fd812e5b980d826f460fdbf0dc3d66aab42d295f SHA1 b45209d92f3dde6b8342b807b0552653170e2b32 SHA256 04bbacffeabf5341c669a0eb1c25e0d634019738f63cbe94179ed6ed8768db6c
+DIST mendeleydesktop-1.0.1-linux-x86_64.tar.bz2 33484854 RMD160 fd812e5b980d826f460fdbf0dc3d66aab42d295f SHA1 b45209d92f3dde6b8342b807b0552653170e2b32 SHA256 04bbacffeabf5341c669a0eb1c25e0d634019738f63cbe94179ed6ed8768db6c
+EBUILD mendeleydesktop-0.9.6.3.ebuild 2223 RMD160 d1bb1345166209f969c1351ac30907e6abfc38e5 SHA1 6b0392d50bfea8bc0bdfcb76d9dea9cb6340b749 SHA256 b0724e502527fdb5ac8ad777c6f219e2008ea8158349eda37e7bc0eed2d9237c
+EBUILD mendeleydesktop-0.9.7.1.ebuild 1593 RMD160 02458506d5cd5947f43654eb6be23e84c91c21f7 SHA1 975b5f90197c5680c949a7299a6a2f25b2321a47 SHA256 13d7d7d150c5ea615afb55ac68c4a65ded97d1a6783ec16b0fb234ab6045e6e5
+EBUILD mendeleydesktop-0.9.8.1.ebuild 1593 RMD160 02458506d5cd5947f43654eb6be23e84c91c21f7 SHA1 975b5f90197c5680c949a7299a6a2f25b2321a47 SHA256 13d7d7d150c5ea615afb55ac68c4a65ded97d1a6783ec16b0fb234ab6045e6e5
+EBUILD mendeleydesktop-0.9.8.2.ebuild 1749 RMD160 6c9fd293bbd2f065d7a826bd31915642031b5b5a SHA1 c1750d601045dd847f62b9a671006ffdbe39731e SHA256 f73622d1274af2830e1dbcb599a843e060ec8676255746bf50a19763ecaae6bd
+EBUILD mendeleydesktop-0.9.9.2.ebuild 1742 RMD160 4711940050a239edaca165112232813b881cae63 SHA1 342958bb5be92c8c3dd2332e55eaaa1eb74eb021 SHA256 923362184100e359418eec5a4dc5332c3061a4cfadc8ae1a78342dc40313b06c
+EBUILD mendeleydesktop-0.9.9.ebuild 1742 RMD160 4711940050a239edaca165112232813b881cae63 SHA1 342958bb5be92c8c3dd2332e55eaaa1eb74eb021 SHA256 923362184100e359418eec5a4dc5332c3061a4cfadc8ae1a78342dc40313b06c
+EBUILD mendeleydesktop-1.0.1.ebuild 1747 RMD160 e34c3d4109c9a247dbf39625376aecff292c6e48 SHA1 c72456d035aee08fbac5ea2f294574abd5cd5d8b SHA256 72a361a126d876162ddd497b220c5c6c0aa948be5df47753b4bce8e386eeb9b3
+EBUILD mendeleydesktop-1.0.ebuild 1742 RMD160 4711940050a239edaca165112232813b881cae63 SHA1 342958bb5be92c8c3dd2332e55eaaa1eb74eb021 SHA256 923362184100e359418eec5a4dc5332c3061a4cfadc8ae1a78342dc40313b06c
+MISC mendeleydesktop-0.9.9.ebuild~ 1702 RMD160 f1bc60d1185f0007c1f433fd95732890f212d701 SHA1 1e928e2943354b8b569de23ba70a0b36a9ccb06a SHA256 31ce569213e6b3117cb59c35972a093db44a6446a152353adda466304da2d79b
+MISC mendeleydesktop-1.0.1.ebuild~ 1742 RMD160 4711940050a239edaca165112232813b881cae63 SHA1 342958bb5be92c8c3dd2332e55eaaa1eb74eb021 SHA256 923362184100e359418eec5a4dc5332c3061a4cfadc8ae1a78342dc40313b06c
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-0.9.6.3.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-0.9.6.3.ebuild
new file mode 100644
index 0000000..68c4804
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-0.9.6.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="http://www.mendeley.com/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+RDEPEND="media-libs/libpng:1.2"
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu ${S}/share/applications/${PN}.desktop || die "Installing desktop files failed."
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto /usr/share/icons/hicolor/${res}/apps
+ doins share/icons/hicolor/${res}/apps/${PN}.png || die "Installing icons failed."
+ done
+ insinto /usr/share/pixmaps
+ doins share/icons/hicolor/48x48/apps/${PN}.png || die "Installing pixmap failed."
+
+
+ # dodoc
+ dodoc ${S}/share/doc/${PN}/* || die "Installing docs failed."
+
+ dodir ${MENDELEY_INSTALL_DIR}
+ dodir ${MENDELEY_INSTALL_DIR}/lib
+ dodir ${MENDELEY_INSTALL_DIR}/share
+ #mv ${S}/share/icons ${D}/usr/share
+ mv ${S}/bin ${D}${MENDELEY_INSTALL_DIR} || die "Installing bin failed."
+ mv ${S}/lib ${D}${MENDELEY_INSTALL_DIR} || die "Installing libs failed."
+ mv ${S}/share/${PN} ${D}${MENDELEY_INSTALL_DIR}/share || die "Installing shared files failed."
+
+ dosym /opt/${PN}/bin/${PN} /opt/bin/${PN} || die "Installing launcher symlinks failed."
+
+}
+
+pkg_postinst() {
+
+ einfo "If you have an error message \"Cannot mix incompatible Qt libraries\","
+ einfo "when you run mendeleydesktop, follow the instructions below:"
+ echo
+ einfo "- To disable the default widget style, run Mendeley with the "
+ einfo "'-style cleanlooks' argument (where 'cleanlooks' can also be substituted"
+ einfo "with 'gtk' or 'plastique' amongst others)."
+ echo
+ einfo "- To disable the 'platform integration' plugin (new feature in Qt >= 4.6),"
+ einfo "set the QT_PLATFORM_PLUGIN environment variable to some nonsense value "
+ einfo "(eg. \"ignoreme\") before running Mendeley."
+}
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-0.9.7.1.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-0.9.7.1.ebuild
new file mode 100644
index 0000000..286ebb8
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-0.9.7.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="http://www.mendeley.com/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu ${S}/share/applications/${PN}.desktop || die "Installing desktop files failed."
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto /usr/share/icons/hicolor/${res}/apps
+ doins share/icons/hicolor/${res}/apps/${PN}.png || die "Installing icons failed."
+ done
+ insinto /usr/share/pixmaps
+ doins share/icons/hicolor/48x48/apps/${PN}.png || die "Installing pixmap failed."
+
+
+ # dodoc
+ dodoc ${S}/share/doc/${PN}/* || die "Installing docs failed."
+
+ dodir ${MENDELEY_INSTALL_DIR}
+ dodir ${MENDELEY_INSTALL_DIR}/lib
+ dodir ${MENDELEY_INSTALL_DIR}/share
+ #mv ${S}/share/icons ${D}/usr/share
+ mv ${S}/bin ${D}${MENDELEY_INSTALL_DIR} || die "Installing bin failed."
+ mv ${S}/lib ${D}${MENDELEY_INSTALL_DIR} || die "Installing libs failed."
+ mv ${S}/share/${PN} ${D}${MENDELEY_INSTALL_DIR}/share || die "Installing shared files failed."
+
+ dosym /opt/${PN}/bin/${PN} /opt/bin/${PN} || die "Installing launcher symlinks failed."
+
+}
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-0.9.8.1.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-0.9.8.1.ebuild
new file mode 100644
index 0000000..286ebb8
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-0.9.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="http://www.mendeley.com/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror strip"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu ${S}/share/applications/${PN}.desktop || die "Installing desktop files failed."
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto /usr/share/icons/hicolor/${res}/apps
+ doins share/icons/hicolor/${res}/apps/${PN}.png || die "Installing icons failed."
+ done
+ insinto /usr/share/pixmaps
+ doins share/icons/hicolor/48x48/apps/${PN}.png || die "Installing pixmap failed."
+
+
+ # dodoc
+ dodoc ${S}/share/doc/${PN}/* || die "Installing docs failed."
+
+ dodir ${MENDELEY_INSTALL_DIR}
+ dodir ${MENDELEY_INSTALL_DIR}/lib
+ dodir ${MENDELEY_INSTALL_DIR}/share
+ #mv ${S}/share/icons ${D}/usr/share
+ mv ${S}/bin ${D}${MENDELEY_INSTALL_DIR} || die "Installing bin failed."
+ mv ${S}/lib ${D}${MENDELEY_INSTALL_DIR} || die "Installing libs failed."
+ mv ${S}/share/${PN} ${D}${MENDELEY_INSTALL_DIR}/share || die "Installing shared files failed."
+
+ dosym /opt/${PN}/bin/${PN} /opt/bin/${PN} || die "Installing launcher symlinks failed."
+
+}
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-0.9.8.2.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-0.9.8.2.ebuild
new file mode 100644
index 0000000..45670aa
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-0.9.8.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="${HOMEPAGE}/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+RDEPEND="dev-libs/openssl:0.9.8
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:1.2"
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu "share/applications/${PN}.desktop"
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto "/usr/share/icons/hicolor/${res}/apps"
+ doins "share/icons/hicolor/${res}/apps/${PN}.png" || \
+ die "Installing icons failed."
+ done
+ insinto "/usr/share/pixmaps"
+ doins "share/icons/hicolor/48x48/apps/${PN}.png" || \
+ die "Installing pixmap failed."
+
+ # dodoc
+ dodoc "share/doc/${PN}/"* || die "Installing docs failed."
+
+ # create directories for installation
+ dodir ${MENDELEY_INSTALL_DIR} || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/lib" || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/share" || die "dodir failed"
+
+ # install binaries
+ mv "bin" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing bin failed."
+ mv "lib" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing libs failed."
+ mv "share/${PN}" "${D}${MENDELEY_INSTALL_DIR}/share" || \
+ die "Installing shared files failed."
+ dosym "${MENDELEY_INSTALL_DIR}/bin/${PN}" "/opt/bin/${PN}" || \
+ die "Installing launcher symlinks failed."
+}
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-0.9.9.2.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-0.9.9.2.ebuild
new file mode 100644
index 0000000..027add8
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-0.9.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="${HOMEPAGE}/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+RDEPEND="dev-libs/openssl:0.9.8
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:1.2"
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu "share/applications/${PN}.desktop"
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto "/usr/share/icons/hicolor/${res}/apps"
+ doins "share/icons/hicolor/${res}/apps/${PN}.png" || \
+ die "Installing icons failed."
+ done
+ insinto "/usr/share/pixmaps"
+ doins "share/icons/hicolor/48x48/apps/${PN}.png" || \
+ die "Installing pixmap failed."
+
+ # dodoc
+ dodoc "share/doc/${PN}/"* || die "Installing docs failed."
+
+ # create directories for installation
+ dodir ${MENDELEY_INSTALL_DIR} || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/lib" || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/share" || die "dodir failed"
+
+ # install binaries
+ mv "bin" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing bin failed."
+ mv "lib" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing libs failed."
+ mv "share/${PN}" "${D}${MENDELEY_INSTALL_DIR}/share" || \
+ die "Installing shared files failed."
+ dosym "${MENDELEY_INSTALL_DIR}/bin/${PN}" "/opt/bin/${PN}" || \
+ die "Installing launcher symlinks failed."
+}
+
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-0.9.9.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-0.9.9.ebuild
new file mode 100644
index 0000000..027add8
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-0.9.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="${HOMEPAGE}/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+RDEPEND="dev-libs/openssl:0.9.8
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:1.2"
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu "share/applications/${PN}.desktop"
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto "/usr/share/icons/hicolor/${res}/apps"
+ doins "share/icons/hicolor/${res}/apps/${PN}.png" || \
+ die "Installing icons failed."
+ done
+ insinto "/usr/share/pixmaps"
+ doins "share/icons/hicolor/48x48/apps/${PN}.png" || \
+ die "Installing pixmap failed."
+
+ # dodoc
+ dodoc "share/doc/${PN}/"* || die "Installing docs failed."
+
+ # create directories for installation
+ dodir ${MENDELEY_INSTALL_DIR} || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/lib" || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/share" || die "dodir failed"
+
+ # install binaries
+ mv "bin" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing bin failed."
+ mv "lib" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing libs failed."
+ mv "share/${PN}" "${D}${MENDELEY_INSTALL_DIR}/share" || \
+ die "Installing shared files failed."
+ dosym "${MENDELEY_INSTALL_DIR}/bin/${PN}" "/opt/bin/${PN}" || \
+ die "Installing launcher symlinks failed."
+}
+
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-1.0.1.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-1.0.1.ebuild
new file mode 100644
index 0000000..64d8ad2
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-1.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="${HOMEPAGE}/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+RDEPEND="dev-libs/openssl:0.9.8
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:1.2"
+
+S="${WORKDIR}/${PN}-1.0-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu "share/applications/${PN}.desktop"
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto "/usr/share/icons/hicolor/${res}/apps"
+ doins "share/icons/hicolor/${res}/apps/${PN}.png" || \
+ die "Installing icons failed."
+ done
+ insinto "/usr/share/pixmaps"
+ doins "share/icons/hicolor/48x48/apps/${PN}.png" || \
+ die "Installing pixmap failed."
+
+ # dodoc
+ dodoc "share/doc/${PN}/"* || die "Installing docs failed."
+
+ # create directories for installation
+ dodir ${MENDELEY_INSTALL_DIR} || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/lib" || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/share" || die "dodir failed"
+
+ # install binaries
+ mv "bin" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing bin failed."
+ mv "lib" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing libs failed."
+ mv "share/${PN}" "${D}${MENDELEY_INSTALL_DIR}/share" || \
+ die "Installing shared files failed."
+ dosym "${MENDELEY_INSTALL_DIR}/bin/${PN}" "/opt/bin/${PN}" || \
+ die "Installing launcher symlinks failed."
+}
+
diff --git a/app-misc/mendeleydesktop/mendeleydesktop-1.0.ebuild b/app-misc/mendeleydesktop/mendeleydesktop-1.0.ebuild
new file mode 100644
index 0000000..027add8
--- /dev/null
+++ b/app-misc/mendeleydesktop/mendeleydesktop-1.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+if [ "${ARCH}" = "amd64" ] ; then
+ LNXARCH="linux-x86_64"
+else
+ LNXARCH="linux-i486"
+fi
+
+DESCRIPTION="A free research management tool for desktop & web"
+HOMEPAGE="http://www.mendeley.com/"
+SRC_URI="${HOMEPAGE}/downloads/linux/${P}-${LNXARCH}.tar.bz2"
+
+LICENSE="Mendelay-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+RDEPEND="dev-libs/openssl:0.9.8
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng:1.2"
+
+S="${WORKDIR}/${P}-${LNXARCH}"
+
+MENDELEY_INSTALL_DIR="/opt/${PN}"
+
+src_install() {
+ # install menu
+ domenu "share/applications/${PN}.desktop"
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto "/usr/share/icons/hicolor/${res}/apps"
+ doins "share/icons/hicolor/${res}/apps/${PN}.png" || \
+ die "Installing icons failed."
+ done
+ insinto "/usr/share/pixmaps"
+ doins "share/icons/hicolor/48x48/apps/${PN}.png" || \
+ die "Installing pixmap failed."
+
+ # dodoc
+ dodoc "share/doc/${PN}/"* || die "Installing docs failed."
+
+ # create directories for installation
+ dodir ${MENDELEY_INSTALL_DIR} || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/lib" || die "dodir failed"
+ dodir "${MENDELEY_INSTALL_DIR}/share" || die "dodir failed"
+
+ # install binaries
+ mv "bin" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing bin failed."
+ mv "lib" "${D}${MENDELEY_INSTALL_DIR}" || die "Installing libs failed."
+ mv "share/${PN}" "${D}${MENDELEY_INSTALL_DIR}/share" || \
+ die "Installing shared files failed."
+ dosym "${MENDELEY_INSTALL_DIR}/bin/${PN}" "/opt/bin/${PN}" || \
+ die "Installing launcher symlinks failed."
+}
+