aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2020-10-31 19:11:57 +0000
committerPaul Healy <lmiphay@gmail.com>2020-10-31 19:11:57 +0000
commit58c613ad1229f82bba5b2ea94a891a89a3b9bba7 (patch)
treea6b94e27c85920367409bdcb3ea1e2342d14a7b6
parentremove gitea ebuilds (diff)
downloadlmiphay-58c613ad1229f82bba5b2ea94a891a89a3b9bba7.tar.gz
lmiphay-58c613ad1229f82bba5b2ea94a891a89a3b9bba7.tar.bz2
lmiphay-58c613ad1229f82bba5b2ea94a891a89a3b9bba7.zip
remove old clion ebuild
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--dev-util/clion/Manifest2
-rw-r--r--dev-util/clion/clion-2020.1.1.ebuild80
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
deleted file mode 100644
index 1846f92..0000000
--- a/dev-util/clion/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST clion-2020.1.tar.gz 510270266 BLAKE2B 4231737d972a8cde9a84db9c9c3a6478a7bba1eb3df11066b2808a016bfda47b4a4d22cee465d628ab03e4656acc087bcd31733112fa5a79807de6ddee5475bb SHA512 eb0d04646df482c7b42bdbc1df6cfbe46ddae6c98f73b1a9d5ad2560efb25a088be2a95eebd1e21981490b79600705c36f723310b7dedc89531296268acd24f6
-EBUILD clion-2020.1.ebuild 2179 BLAKE2B 198748c33f57fedf4153c6f1d5f3982a901cc951d95e9b9e8c49d716e5ced2cbbac6bae3f186d76b84e3ea5d4f4c4ee33c3ea657c6d4b936120d66d08fbd2252 SHA512 0c223ad5cd9536eaf96b3ff9ad7deabe9f04124cf1b66b009168f676907da8c0e9d5939e428bb9f8baf1d26b48bc0c810f8b1e5abf3b4c3691f02a74116356d3
diff --git a/dev-util/clion/clion-2020.1.1.ebuild b/dev-util/clion/clion-2020.1.1.ebuild
deleted file mode 100644
index d50ca20..0000000
--- a/dev-util/clion/clion-2020.1.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop eutils
-
-DESCRIPTION="A complete toolset for C and C++ development"
-HOMEPAGE="https://www.jetbrains.com/clion"
-SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( IDEA IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )
- Apache-1.1 Apache-2.0 BSD BSD-2 CC0-1.0 CDDL-1.1 CPL-0.5 CPL-1.0
- EPL-1.0 EPL-2.0 GPL-2 GPL-2-with-classpath-exception GPL-3 ISC JDOM
- LGPL-2.1+ LGPL-3 MIT MPL-1.0 MPL-1.1 OFL public-domain PSF-2 UoI-NCSA ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="bindist mirror splitdebug"
-IUSE="custom-jdk"
-
-# RDEPENDS may cause false positives in repoman.
-# clion requires cmake and gdb at runtime to build and debug C/C++ projects
-RDEPEND="
- dev-libs/libdbusmenu
- dev-util/cmake
- sys-devel/gdb
- !custom-jdk? ( virtual/jdk )"
-
-QA_PREBUILT="opt/${P}/*"
-
-src_prepare() {
- default
-
- local remove_me=(
- bin/gdb/linux
- bin/lldb/linux
- bin/cmake
- license/CMake*
- lib/pty4j-native/linux/ppc64le
- )
-
- use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
- use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
-
- use custom-jdk || remove_me+=( jbr )
-
- rm -rv "${remove_me[@]}" || die
-}
-
-src_install() {
- local dir="/opt/${P}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
-
- if use amd64; then
- fperms 755 "${dir}"/bin/fsnotifier64
- fi
- if use arm; then
- fperms 755 "${dir}"/bin/fsnotifier-arm
- fi
- if use x86; then
- fperms 755 "${dir}"/bin/fsnotifier
- fi
-
- if use custom-jdk; then
- if [[ -d jbr ]]; then
- fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
- fi
- fi
-
- make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
- newicon "bin/${PN}.svg" "${PN}.svg"
- make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- dodir /usr/lib/sysctl.d/
- echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
-}