aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-04-07 15:32:05 +0100
committerPaul Healy <lmiphay@gmail.com>2019-04-07 15:32:05 +0100
commit94c3b66757c1d9512d8801dc471c4108a5826a55 (patch)
treea3e6195f47d5992d87c28c09ae4c939d9f5aa3af
parentfix 2015 era grief build (diff)
downloadlmiphay-94c3b66757c1d9512d8801dc471c4108a5826a55.tar.gz
lmiphay-94c3b66757c1d9512d8801dc471c4108a5826a55.tar.bz2
lmiphay-94c3b66757c1d9512d8801dc471c4108a5826a55.zip
add ebuild for 3.2.1 snapshot
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--app-editors/grief/Manifest1
-rw-r--r--app-editors/grief/grief-20190309.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/grief/Manifest b/app-editors/grief/Manifest
index b4b2cc8..ef0d075 100644
--- a/app-editors/grief/Manifest
+++ b/app-editors/grief/Manifest
@@ -5,3 +5,4 @@ AUX disable-hlpdoc.patch 282 BLAKE2B 65af195a2eb8832b38b3ce0cd8c888395d9d371804b
AUX generate-libchartable.sh 583 BLAKE2B da608986f2477177c0b5045778cc46c271dc4c7046ef94f1e4117f2723c30f04773b632d2f08ef61fb53c5a04d42589dc8f32923bb7ddb8dcdcff8d6efe515e0 SHA512 c71a7a62486daffac6708a95f675daed55f00832c530be183bfe3c7627e4b57fda3cc73ea553f9d73e405249e599bc8fd23fe2dc9d44033ec316acd603297044
DIST grief-libchartable-1.0.tar.xz 5697524 BLAKE2B 00968983781da53d9a548c51c77d730bb39a3ea481250d1391c1905a7a8e713390683a7027db068af75d9de16bbd2439dc641f90b83c478da0f33921281db704 SHA512 6be2d706b01cd055b005bcb5ba9295be041bff9ab24ba2ba11f85b347fed2f72368e64888c1896d117a6058ed5f867141bf6692fa47e37963a6aa02e50e72827
EBUILD grief-20150315.ebuild 1408 BLAKE2B 36c87a1685957580a77492c78b202e18805f3d67a9f7abfbb1deec7cdaed3f1d2e77154d3288af10404198b0964ac6900e5ac5e08a06fb9435046d3c3ca7bc8d SHA512 6b885e7c270f6c5ae26cfbb9f210435da70add71729fb46365fa1557edcc173f5b5b707dfa7e3941a63dcfb9125e0b8212ee7209077e14cc5fa00018cfaa7a46
+EBUILD grief-20190309.ebuild 1430 BLAKE2B 68794f7dfae2d30e0a16aca7d696bbbd614d1e827550aad3cd569808059fed1a9ab65f219bb30ed191f7093c1942dd2c9b791e47250f133d1a3034c4952b8c0a SHA512 e3df56d41dfcb232b8fb4a18fc8dbf856832428f52ebf0c4c7d2f5d5221ffdb997c8ca101a4e9fbead17c9d24e6f9330fdb1bb80a0db317419bcd457266c5813
diff --git a/app-editors/grief/grief-20190309.ebuild b/app-editors/grief/grief-20190309.ebuild
new file mode 100644
index 0000000..f95cee0
--- /dev/null
+++ b/app-editors/grief/grief-20190309.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils git-r3
+
+DESCRIPTION="Programmers console editor/a BRIEF clone"
+HOMEPAGE="https://sourceforge.net/projects/grief/"
+EGIT_REPO_URI="https://git.code.sf.net/p/grief/code"
+EGIT_COMMIT="9987f47178c896a4132398c8d0e36cb7f2882ac5" # aka 3.2.1 snapshot
+SRC_URI="grief-libchartable-1.0.tar.xz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+
+DEPEND="
+ app-arch/unzip
+ dev-lang/perl
+ sys-libs/binutils-libs
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( \
+ "${FILESDIR}"/bfd_config.patch \
+ "${FILESDIR}"/clocks_per_second.patch \
+ "${FILESDIR}"/disable-hlpdoc.patch \
+ "${FILESDIR}"/define-cbegin-decls.patch
+)
+
+pkg_nofetch() {
+ einfo "Please generate libchartable data"
+ einfo "using ${FILESDIR}/generate-libchartable.sh"
+ einfo "and move the resulting tarball into ${DISTDIR}"
+}
+
+src_prepare() {
+ (cd "${S}"/libchartable && unpack ${A})
+ default
+}
+
+src_configure() {
+ # this needs work:
+ # with ED grief looks in the wrong places for macros (and installs to /usr/share/macros instead of /usr/share/grief/macros)
+ # without it, there are sandbox violations
+ ./configure_new --prefix=${ED}/usr
+}
+
+src_compile() {
+ emake -j1
+}
+
+pkg_postinst() {
+ elog "For the moment documentation is online only at: http://grief.sourceforge.net/"
+ elog "export GRPATH=/usr/share/macros to allow grief startup"
+}