aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-03-24 14:13:03 +0000
committerPaul Healy <lmiphay@gmail.com>2019-03-24 14:13:03 +0000
commit6e699101ac94eaf649719159483d34a6cb03cd26 (patch)
tree1557b6c3ab671a4dd99b9104aaf7ee64299548ce /dev-python
parentrevbump homeassistant (diff)
downloadlmiphay-6e699101ac94eaf649719159483d34a6cb03cd26.tar.gz
lmiphay-6e699101ac94eaf649719159483d34a6cb03cd26.tar.bz2
lmiphay-6e699101ac94eaf649719159483d34a6cb03cd26.zip
fixup pydbus 9999 and add the 0.6.0 release
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydbus/Manifest4
-rw-r--r--dev-python/pydbus/pydbus-0.6.0.ebuild26
-rw-r--r--dev-python/pydbus/pydbus-9999.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-python/pydbus/Manifest b/dev-python/pydbus/Manifest
index 49f1f99..76ef458 100644
--- a/dev-python/pydbus/Manifest
+++ b/dev-python/pydbus/Manifest
@@ -1 +1,3 @@
-EBUILD pydbus-9999.ebuild 511 SHA256 95cbcf2244415a901ddb63d51ae266b149a6c6eee6addd030eae816adb5d33c3 SHA512 3324715b502a4fdbb11dd2d382521adc9e82a69b5e6082c1fffea0626f4c57c42ede836db29afbb222fabb0373cae553f6f8fdfb916d68d5088ea9f03c6e4330 WHIRLPOOL 9a9fa749c1eab5481e1a4e4eab3a91d4ed2f452338a8dfa8ff65be303b7f965cbb46ab4a4a492b60bc4fa3cdeaa69dfef901fa6af380c41cf751d1bf0fffc829
+DIST pydbus-0.6.0.tar.gz 22079 BLAKE2B 5e532972e917ffa363ff00bd480d1454c96993fc4235df213c1daba24836a3f3884570200827f0660c4aa27ca8f11392a9caa459bf8a9eb54b098f78291014d2 SHA512 a8d473080faaad7e6f44030b4355ae5535ca4b2aa62b94b05c782832a4732b0c9cfda40020005ced848bcfae8fb1783575e72c7a86104bf9fb05ab409178a9ea
+EBUILD pydbus-0.6.0.ebuild 484 BLAKE2B 8016d90dff1fcf460ab0f71c06b2697000de76cfb6992c47078eb3b5e35fc4eb51d1ecb3f828fe5ce52c69eb28d68c13b1351d5891de8b30f930666370f3d912 SHA512 a7a9de5b4cbd09837eced6eb3e3e6b1158291ad682026ae549919c1b180b8f141745f19dafb6d84a5b89fe92ef0f51644c4143e538c2cd58bdc8c9f56b3d15f3
+EBUILD pydbus-9999.ebuild 491 BLAKE2B d89ec7cc143e87652747677e22c2b6f12d0c5712379f9b4b79a301857e4ef603c26981599085185dc711e170269c4da0e2010e6216d796a25e0ab6bcf6284380 SHA512 5c2635facfeb623f68d45ce64dfaf5f00c1743257b026fd58b2b7e1ef4a32b7a54b5c4cd176cc10114066ab760e60ce1f56eb099f38615da165e2b77b1c30fea
diff --git a/dev-python/pydbus/pydbus-0.6.0.ebuild b/dev-python/pydbus/pydbus-0.6.0.ebuild
new file mode 100644
index 0000000..5686284
--- /dev/null
+++ b/dev-python/pydbus/pydbus-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python{2_7,3_6})
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Pythonic DBus library"
+HOMEPAGE="https://github.com/LEW21/pydbus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
diff --git a/dev-python/pydbus/pydbus-9999.ebuild b/dev-python/pydbus/pydbus-9999.ebuild
index 23a7bea..f281537 100644
--- a/dev-python/pydbus/pydbus-9999.ebuild
+++ b/dev-python/pydbus/pydbus-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=(python{2_7,3_{3,4}})
+PYTHON_COMPAT=(python{2_7,3_6})
inherit eutils distutils-r1 git-r3