aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-11-03 14:00:33 +0000
committerPaul Healy <lmiphay@gmail.com>2018-11-03 14:00:33 +0000
commit81a8d13ece3a0951b2e9afeddf7bc4f194af6338 (patch)
tree43153a5e1d20e2a51c5b2461f837eec2e239cbb4 /dev-python
parentrevbump opengrok (diff)
downloadlmiphay-81a8d13ece3a0951b2e9afeddf7bc4f194af6338.tar.gz
lmiphay-81a8d13ece3a0951b2e9afeddf7bc4f194af6338.tar.bz2
lmiphay-81a8d13ece3a0951b2e9afeddf7bc4f194af6338.zip
revbump requests (for opengrok)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests/Manifest2
-rw-r--r--dev-python/requests/requests-2.20.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
new file mode 100644
index 0000000..243c0a9
--- /dev/null
+++ b/dev-python/requests/Manifest
@@ -0,0 +1,2 @@
+DIST requests-2.20.0.tar.gz 111179 BLAKE2B 642adfb54fb4ac1a4dee3b3b2d16386b099fe97f1713f77104a1402d17714886e954e4c476aa04ad1e0d17309e2d3d0e8d4098d66a48cd7a64399e2bdf5ad63f SHA512 d9d44ed56f868484e36686dee7a2507d8fef45f9cbd861971bb2b6956c7aecb20988f4830017f111027b5eebd00541805797820b0a455694fdbd1b5dce8907d2
+EBUILD requests-2.20.0.ebuild 1425 BLAKE2B 04be7607fd99a9ba3e7597432ae81fb67cce32567706edd2abd7995ce45b2677b8c054e9fb466782052c05418938ce8419b2ceb751aba880322907363bb8d44b SHA512 48d9e316bb6ac62ac98e047bf896e577dcb90bd66db48b0aa9aee0e5bd30873aa0589a29732ea1e9a462b5a6d705ffaf1c74e32b198ffbffa1e37aeab13bc665
diff --git a/dev-python/requests/requests-2.20.0.ebuild b/dev-python/requests/requests-2.20.0.ebuild
new file mode 100644
index 0000000..0d6c239
--- /dev/null
+++ b/dev-python/requests/requests-2.20.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="socks5 +ssl"
+
+RDEPEND="
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ <dev-python/idna-2.8[${PYTHON_USEDEP}]
+ <dev-python/urllib3-1.24[${PYTHON_USEDEP}]
+ socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
+ ssl? (
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
+ )
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+#DEPEND+="
+# test? (
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-xdist[${PYTHON_USEDEP}]
+# >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+# )
+#"
+
+python_test() {
+ py.test || die
+}