aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-04-28 12:13:22 +0100
committerPaul Healy <lmiphay@gmail.com>2018-04-28 12:13:22 +0100
commit873b30f64c1bc4f72457a5de84049a5e3684d173 (patch)
treed58cd55f70d40c0076d9a8249fdadfb86fa4d647 /dev-python
parentswitch to python 3.5 and 3.6 support only (diff)
downloadlmiphay-873b30f64c1bc4f72457a5de84049a5e3684d173.tar.gz
lmiphay-873b30f64c1bc4f72457a5de84049a5e3684d173.tar.bz2
lmiphay-873b30f64c1bc4f72457a5de84049a5e3684d173.zip
add ebuild for smpplib
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-smpplib/Manifest1
-rw-r--r--dev-python/python-smpplib/python-smpplib-20180221.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-smpplib/Manifest b/dev-python/python-smpplib/Manifest
new file mode 100644
index 0000000..8d99e9d
--- /dev/null
+++ b/dev-python/python-smpplib/Manifest
@@ -0,0 +1 @@
+EBUILD python-smpplib-20180221.ebuild 782 BLAKE2B 6353aae3655bac3f547f8d865f030aa1060f4a8972a7d85c4b334f87b4a51ccbd09fc712ccc9249590a09401f12910376b4d13f0117a280f7e388ed7c389dca8 SHA512 ff0af2872cd3b1dab73819242e6a98c8f1d2f47c6150148f43fda0bbef3c99ee3c454030508a4e5362a5780c5bf3ad26a9e046a20bc68d6daf57e7a435025801
diff --git a/dev-python/python-smpplib/python-smpplib-20180221.ebuild b/dev-python/python-smpplib/python-smpplib-20180221.ebuild
new file mode 100644
index 0000000..1c032bb
--- /dev/null
+++ b/dev-python/python-smpplib/python-smpplib-20180221.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7 python3_5)
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="SMPP library for python"
+HOMEPAGE="https://github.com/podshumok/python-smpplib"
+EGIT_REPO_URI="https://github.com/podshumok/python-smpplib.git"
+EGIT_COMMIT="f6b0a8529f3973110bcc999a706666703e6c3a2b"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i -e 's;packages=find_packages();packages=find_packages(exclude=["tests"]);' "setup.py"
+ eapply_user
+}