aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-03-17 15:09:08 +0000
committerPaul Healy <lmiphay@gmail.com>2018-03-17 15:09:08 +0000
commitbe9722e9143bf56659438280c8cad858505d6092 (patch)
tree009a0d6bfadf36cbc8713e7b5f92ddc33bb15850 /dev-python
parentrev bump eliot tree with py3.5 support (diff)
downloadlmiphay-be9722e9143bf56659438280c8cad858505d6092.tar.gz
lmiphay-be9722e9143bf56659438280c8cad858505d6092.tar.bz2
lmiphay-be9722e9143bf56659438280c8cad858505d6092.zip
revbump eliiot
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/eliot/Manifest6
-rw-r--r--dev-python/eliot/eliot-1.3.0.ebuild45
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/eliot/Manifest b/dev-python/eliot/Manifest
index 96555ee..aebc3b1 100644
--- a/dev-python/eliot/Manifest
+++ b/dev-python/eliot/Manifest
@@ -1,2 +1,4 @@
-DIST eliot-1.0.0.tar.gz 115986 SHA256 e3403067aa568a332767d223acc29f7c79309080dd4588cb579d82b2a22483b6 SHA512 276347d9ee6a571d785f546468d52bb835d7693f011d6f70e3b4414912d632e45c4623a8e8b235dc3c533a7fc2b861b74e74048d2793f1d9e1fab1655cc5921f WHIRLPOOL a1cc1bfd2a2b033c50923e5b9f222399d15660420a59a912692693a8bde496d964902b6a05986c1f3e6fc0568e46410df08993faf1194f07df51025bbc8ba960
-EBUILD eliot-1.0.0.ebuild 1120 SHA256 733ce84bd18f287b869fdb7edbbb6c14dcee88086c130c6bd3d50bec49f43989 SHA512 3f998fb9e14429132e188fcbd4154e9515ddb9e4508f70d685c21beb7c472bfeac5233915ef111637d81bedbd2bc62b4257e99f79e46155da14766c9fca39543 WHIRLPOOL 8e8a24c04c48ed341c7bf77389c93a43203340cfed075faf96500cdbfd6d75cdbb97a4b5bb6e4dc87cd62bc99ce53947646027e39def01c71a58e4bd57a8cc8d
+DIST eliot-1.0.0.tar.gz 115986 BLAKE2B 74ea813b67231aad0e8ac3bb1a610e4cd6eb4775ef460df4021b57991e0a3e512a9f7498510ba00c9d49dbdaac12b71b5c65b197b9304d6dec90808415c4abb0 SHA512 276347d9ee6a571d785f546468d52bb835d7693f011d6f70e3b4414912d632e45c4623a8e8b235dc3c533a7fc2b861b74e74048d2793f1d9e1fab1655cc5921f
+DIST eliot-1.3.0.tar.gz 130059 BLAKE2B daf85d4a3d5f8f8c388912c34316f0b7cabbe1c178e35e4bfb7cc33af6833ed563ecf8cd182bde4d64b7682bd9782ead376e5216f03de2424e66860cfd6e7142 SHA512 43cfe98a9150018413214c69ad00afbac4c7cb8f26fd69d05437167ba07f19ae40d633ebd0abdee2efdb5c61e05bfc179f566d74c22d01317ede80073f092af6
+EBUILD eliot-1.0.0.ebuild 1120 BLAKE2B 19107a56fe14d21b9a55acf6ded9f89f5ae8bc4f75674ed7b1baec080964832c11453ab02fc17175bb8941070a8267575772c8e1626612c2b472d79934209c1a SHA512 3f998fb9e14429132e188fcbd4154e9515ddb9e4508f70d685c21beb7c472bfeac5233915ef111637d81bedbd2bc62b4257e99f79e46155da14766c9fca39543
+EBUILD eliot-1.3.0.ebuild 1124 BLAKE2B 4415e2bcc1457de8535e8e419d7b2d6fa9f75c9182b12f29d54218ea960c567060297a0736e8ff4377602b2b6581614af24ad7e25b0025845281a7e4cba4d8dd SHA512 5ab5beee0c4026faaa0c9529231bfbe6f37a6c504b896da07e0584491da0fbdb920909dbad84c2f879526c83553aeaa62837cee491333c90e1e2aac21db3ea14
diff --git a/dev-python/eliot/eliot-1.3.0.ebuild b/dev-python/eliot/eliot-1.3.0.ebuild
new file mode 100644
index 0000000..4414f71
--- /dev/null
+++ b/dev-python/eliot/eliot-1.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Logging as Storytelling"
+HOMEPAGE="https://github.com/ScatterHQ/eliot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc systemd test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ systemd? ( dev-python/cffi[${PYTHON_USEDEP}] )
+ "
+
+python_compile_all() {
+ emake -C "${S}/docs" man
+ use doc && emake -C "${S}/docs" html
+}
+
+python_install_all() {
+ doman "docs/build/man/${PN}.1"
+ use doc && DOCS="docs/build/html" einstalldocs
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}