aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-06-01 17:18:58 +0100
committerPaul Healy <lmiphay@gmail.com>2019-06-01 17:18:58 +0100
commit8e393e2267847d4c615885143deddfc919c578fa (patch)
tree0c7d52434b3a46a50e388bc107c5a36e276126f1 /www-apps
parentrevbump kokua (diff)
downloadlmiphay-8e393e2267847d4c615885143deddfc919c578fa.tar.gz
lmiphay-8e393e2267847d4c615885143deddfc919c578fa.tar.bz2
lmiphay-8e393e2267847d4c615885143deddfc919c578fa.zip
revbump gitea
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.8.2.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 5f7f500..183a61a 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -5,5 +5,7 @@ AUX gitea.logrotated 87 BLAKE2B 373830ddd6eed0ce2f0f7b1dab14e4a253e5a56a73f477cf
AUX gitea.service 472 BLAKE2B 4c728e2987d0c0a86e65d4b9c1a59f6193ff8a3f9b066991a06f495ad1c5586b3497c71fca1cce5b65f167af09343e7bf3215ee5e8fdefa539e384198d2d88d6 SHA512 6666fe3b4cdbb78a58db4a6bf47a15e6be9ab30b666c6eb77a9e8a002d8c0abd510fc75ef463a11ee6892ab12c98943774616072cb64fd9f2fa42ff8f676aa95
DIST gitea-1.8.0.tar.gz 24268907 BLAKE2B b46a17733fc7bd0f228620bdfadf0d596ea56fca6e685afab7734e794c1f87c5e004529ca3d69e907d516bcb83563565b1d8c32501f1c2c0f9295ca028d96ad0 SHA512 eebbe2f77ed2e4c3562f48a6fa647e6f2a0492c5b6ea4f13542a5ef82e94a357a8d53897aa013107b5f735d2aff9d719893b5724de44831c43998c2e9c6e78d7
DIST gitea-1.8.1.tar.gz 24304805 BLAKE2B 4300125da2116218c0609bb8974b2abea22593161dd60e12390eea7e60865df40a089126748b3f5c9e856b2c59fdb6a4b9997c6d0bb9743ceb0c413c41caa903 SHA512 b583ba21ae9c896d527d299d5a14f7b99e40b474da7ca40521487f0459c877da9c21825b40dc0f981af7813bcabca11f62d8076cc1e401adda57d0e0505b96ce
+DIST gitea-1.8.2.tar.gz 24321492 BLAKE2B 48a718edd1d607e4f8ee2a301bdd907f2a233be515fa327eac9cfb50cdbc024e5f90e6e86e95056c256cb35497c5a3b2ab5fa4a068a22b28c1a3d2b94780da7a SHA512 23ef63c1cea276800a19fe04b87b4baa421e1202260b4ec55614a77ee54c0bc9e5db6dad7f98791c4d902b2d4cb15f4facc4d201631cf2ef7cefd0ff996753be
EBUILD gitea-1.8.0.ebuild 1937 BLAKE2B 62966ac3fb1df33057720084d66e5ff7ca07e72e8c14fec6ca3c3c128bd782804ddb614c605e83dd5dd4606a252d5d010997f07cc685473096d0cc086e5bbb3d SHA512 4184590b31bbe750d08ea20ef7c6099f8c61e69d41bc458f9dca0de20cbe125283cd489ddca4bf2802a2fa7caa626709eb17f02c4608a656904d082dd7e3fea5
EBUILD gitea-1.8.1.ebuild 1937 BLAKE2B 62966ac3fb1df33057720084d66e5ff7ca07e72e8c14fec6ca3c3c128bd782804ddb614c605e83dd5dd4606a252d5d010997f07cc685473096d0cc086e5bbb3d SHA512 4184590b31bbe750d08ea20ef7c6099f8c61e69d41bc458f9dca0de20cbe125283cd489ddca4bf2802a2fa7caa626709eb17f02c4608a656904d082dd7e3fea5
+EBUILD gitea-1.8.2.ebuild 1937 BLAKE2B 62966ac3fb1df33057720084d66e5ff7ca07e72e8c14fec6ca3c3c128bd782804ddb614c605e83dd5dd4606a252d5d010997f07cc685473096d0cc086e5bbb3d SHA512 4184590b31bbe750d08ea20ef7c6099f8c61e69d41bc458f9dca0de20cbe125283cd489ddca4bf2802a2fa7caa626709eb17f02c4608a656904d082dd7e3fea5
diff --git a/www-apps/gitea/gitea-1.8.2.ebuild b/www-apps/gitea/gitea-1.8.2.ebuild
new file mode 100644
index 0000000..b2ba2af
--- /dev/null
+++ b/www-apps/gitea/gitea-1.8.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-build golang-vcs-snapshot
+
+EGO_PN="code.gitea.io/gitea"
+KEYWORDS="~amd64 ~arm"
+
+DESCRIPTION="A painless self-hosted Git service, written in Go"
+HOMEPAGE="https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/go-bindata"
+RDEPEND="dev-vcs/git"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
+ -e "s/-ldflags '-s/-ldflags '/" \
+ -e "s/GOFLAGS := -i -v/GOFLAGS := -v/" \
+ src/${EGO_PN}/Makefile || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
+ TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="-fno-PIC" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin gitea
+ insinto /var/lib/gitea/conf
+ newins custom/conf/app.ini.sample app.ini.example
+ popd || die
+ newinitd "${FILESDIR}"/gitea.initd-r1 gitea
+ newconfd "${FILESDIR}"/gitea.confd gitea
+ keepdir /var/log/gitea /var/lib/gitea/data
+ fowners -R git:git /var/log/gitea /var/lib/gitea/
+ systemd_dounit "${FILESDIR}/gitea.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ elog "No app.ini found, copying initial config over"
+ cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
+ chown git:git /var/lib/gitea/conf/app.ini
+ else
+ elog "app.ini found, please check example file for possible changes"
+ ewarn "Please note that environment variables have been changed:"
+ ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
+ ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
+ fi
+}