summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre PIGNÉ <alex@freesenses.net>2015-09-05 14:05:04 +0200
committerAlexandre PIGNÉ <alex@freesenses.net>2015-09-05 14:05:04 +0200
commit3ad82d6d9639c788fdf0920e4e3da6cb149bafe1 (patch)
treeedc7a6b0d2b52afe3510075c3d72d45d6dbfd736
parentpull pcapy-0.10.8 (diff)
downloadlootr-3ad82d6d9639c788fdf0920e4e3da6cb149bafe1.tar.gz
lootr-3ad82d6d9639c788fdf0920e4e3da6cb149bafe1.tar.bz2
lootr-3ad82d6d9639c788fdf0920e4e3da6cb149bafe1.zip
Remove obsolete nfqueue-bindings ebuild
-rw-r--r--net-libs/nfqueue-bindings/Manifest2
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.3.ebuild58
2 files changed, 0 insertions, 60 deletions
diff --git a/net-libs/nfqueue-bindings/Manifest b/net-libs/nfqueue-bindings/Manifest
deleted file mode 100644
index 892bbf8..0000000
--- a/net-libs/nfqueue-bindings/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST nfqueue-bindings-0.3.tar.gz 22436 RMD160 d9930f0779e7a2d126a6a83bc9e221950ce41354 SHA1 ac9dda8956f0c5f6619b628ceaf209d97e4124d6 SHA256 515795fb500ba06364f1af68e3b12feb2a9fc7c0ed94b5e95e9301f216be9748
-EBUILD nfqueue-bindings-0.3.ebuild 1952 RMD160 ba7b907a356a9599dd2140e336bba4b3c2cd4b0f SHA1 cc93350edb52ba0aa663c078609b0933c91a6a5d SHA256 de5177d2ef8acd84dba68915cb2caee7ff3ad55e7212fe44f1ef02772f39a175
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.3.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.3.ebuild
deleted file mode 100644
index 2d77375..0000000
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-inherit cmake-utils perl-module linux-info
-
-
-DESCRIPTION="nfqueue-bindings is a set of high-level modules for several
-languages (Python and Perl, for the moment), for libnetfilter_queue"
-HOMEPAGE="http://software.inl.fr/trac/wiki/nfqueue-bindings"
-SRC_URI="https://www.wzdftpd.net/redmine/attachments/download/59/${P}.tar.gz"
-
-KEYWORDS="~x86 ~amd64"
-SLOT="0"
-LICENSE="GPL-3"
-IUSE="perl python examples"
-
-DEPEND="python? (
- dev-lang/python
- dev-python/dpkt
- )
- perl? ( dev-lang/perl )
- net-libs/libnetfilter_queue
- dev-lang/swig"
-
-pkg_setup() {
- # At least one of Python or Perl must be selected
- useq python || useq perl || die "At least one supported language must be selected."
- # Check kernel configuration for NFQUEUE
- if linux_config_exists; then
- ebegin "Checking NETFILTER_NETLINK_QUEUE support"
- linux_chkconfig_present NETFILTER_NETLINK_QUEUE
- eend $? || \
- eerror 'Netfilter NFQUEUE over NFNETLINK interface support not found!'
- ebegin "Checking NETFILTER_XT_TARGET_NFQUEUE support"
- linux_chkconfig_present NETFILTER_XT_TARGET_NFQUEUE
- eend $? || \
- eerror '"NFQUEUE" target Support not found!'
- fi
-}
-
-src_unpack() {
- unpack ${A}
- perl_set_version
- # Fix include Perl search directory
- sed -i "/SET[[:space:]]*([[:space:]]*PERL_POSSIBLE_INCLUDE_PATHS/a\ ${ARCH_LIB}/CORE" ${P}/FindPerlLibs2.cmake
- # Fix Perl destination directory
- sed -i "/DESTINATION/s#\(perl\${PERL_VERSION}\)#\1/site_perl/${PERL_VERSION}/${ARCH_LIB##*/}#g" ${P}/perl/CMakeLists.txt
- # Disable Perl/Python from USE flags
- useq perl || sed -i '/ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*perl[[:space:]]*)/s/^/#/g' ${P}/CMakeLists.txt
- useq python || sed -i '/ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*python[[:space:]]*)/s/^/#/g' ${P}/CMakeLists.txt
-}
-
-src_install() {
- emake DESTDIR="${D}" install PREFIX=/usr || die
- docinto examples
- useq examples && dodoc examples/*
-}