summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Haegler <shaegler@esri.com>2017-02-06 21:28:06 +0100
committerSimon Haegler <shaegler@esri.com>2017-02-06 21:28:06 +0100
commit7b533638f5bbdae77b3238e81ef2c6dd1aa2a18c (patch)
treeaafcc011ba3cbca2b4ba32fa42c3927f960c99a9
parentremoved blender-cycles (diff)
downloadmistafunk-7b533638f5bbdae77b3238e81ef2c6dd1aa2a18c.tar.gz
mistafunk-7b533638f5bbdae77b3238e81ef2c6dd1aa2a18c.tar.bz2
mistafunk-7b533638f5bbdae77b3238e81ef2c6dd1aa2a18c.zip
removing obsolete openmesh
-rw-r--r--media-gfx/openmesh/Manifest2
-rw-r--r--media-gfx/openmesh/openmesh-2.0.1.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/media-gfx/openmesh/Manifest b/media-gfx/openmesh/Manifest
deleted file mode 100644
index 6869ea4..0000000
--- a/media-gfx/openmesh/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST OpenMesh-2.0.1.tar.bz2 17586878 RMD160 82fa5904193b1042ad4c7ff1f49d08991c219f05 SHA1 ff2a5841f16a4ae280cef83f6893c27ad405dd69 SHA256 5aa92ad275b67c37480ab21ec1b901e56a9e2f1559b84195a7c5a0c74c294045
-EBUILD openmesh-2.0.1.ebuild 1623 RMD160 3f0f95e0d63065387b21b2fcfbbfa6891d2301af SHA1 d416ae0d637a42a030ca27d09f9b126326de038e SHA256 838541700e1cf8ad870f9c5688ea4d3b9452b8318022ed487bae51316696cab6
diff --git a/media-gfx/openmesh/openmesh-2.0.1.ebuild b/media-gfx/openmesh/openmesh-2.0.1.ebuild
deleted file mode 100644
index 4aa64ef..0000000
--- a/media-gfx/openmesh/openmesh-2.0.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-2.0_rc5.ebuild,v 1.3 2011/04/05 14:18:20 jsbronder Exp $
-
-EAPI="3"
-inherit eutils cmake-utils
-
-MY_PN="OpenMesh"
-MY_PV="${PV/_rc/-RC}"
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
-DESCRIPTION="A generic and efficient data structure for representing and manipulating polygonal meshes"
-HOMEPAGE="http://www.openmesh.org/"
-SRC_URI="http://openmesh.org/fileadmin/${PN}-files/${MY_PV/-RC/RC}/${MY_PN}-${MY_PV}.tar.bz2"
-
-# See COPYING.EXCEPTIONS
-LICENSE="LGPL-3 as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qt4 debug static-libs"
-
-RDEPEND="qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-opengl:4
- media-libs/freeglut )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- # Fix libdir and remove rpath.
- cd "${S}"
- sed -i \
- -e "s|\(set (ACG_PROJECT_LIBDIR \"\).*|\1$(get_libdir)/\")|" \
- -e "s|\(set (ACG_PROJECT_PLUGINDIR \"\)lib\(.*\)|\1$(get_libdir)\2|" \
- -e "s|\(BUILD_WITH_INSTALL_RPATH \)1|\1 0|" \
- -e "s|\(SKIP_BUILD_RPATH\) 0|\1 1|" \
- -e '/^ *INSTALL_RPATH/d' \
- cmake/ACGCommon.cmake || die
-}
-
-src_configure() {
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- CMAKE_BUILD_TYPE=Release
- append-cppflags -DNDEBUG
- fi
- mycmakeargs="$(cmake-utils_use_build "qt4" "APPS")"
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if ! use static-libs; then
- # No way to set this in the build system as of 2.0_rc5
- rm -f "${D}"/usr/$(get_libdir)/*.a \
- || die "Failed to remove static libraries."
- fi
- cd "${S}"
- dodoc LICENSE/* README CHANGELOG || die
-}