aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Klich <michal@michalklich.com>2015-06-14 15:52:52 +0100
committerMichael Klich <michal@michalklich.com>2015-06-14 15:52:52 +0100
commit6d9dcb0024649a7d633cf77f50586e057b168318 (patch)
tree1d5d08bb9992657a736a8c0a8a2a3c5debe59c47
parentForgot again (diff)
downloadmklich-6d9dcb0024649a7d633cf77f50586e057b168318.tar.gz
mklich-6d9dcb0024649a7d633cf77f50586e057b168318.tar.bz2
mklich-6d9dcb0024649a7d633cf77f50586e057b168318.zip
Add bumpversion ebuild
-rw-r--r--dev-python/bumpversion/bumpversion-0.5.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/bumpversion/bumpversion-0.5.3.ebuild b/dev-python/bumpversion/bumpversion-0.5.3.ebuild
new file mode 100644
index 0000000..4a3c4c1
--- /dev/null
+++ b/dev-python/bumpversion/bumpversion-0.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{2,3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A command-line utility that creates projects from cookiecutters (project templates)"
+HOMEPAGE="http://pypi.python.org/pypi/bumpversion https://github.com/peritus/bumpversion"
+SRC_URI="https://github.com/peritus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="doc test"
+
+# TODO: dependencies must have versions
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+
+DOCS=( docs/index.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}